Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th October 2012, 18:22
pebkac pebkac is offline
Senior Member
 
Join Date: Feb 2009
Posts: 132
Thanks: 2
Thanked 7 Times in 7 Posts
Question Multiple SMTP Smarthosts for each domain

Hey folks,

I need to configure my smarthost relay to send to certain smarthost based upon domain. Right now I have one for all domains on the server. I would like to have two domains use the current setup and 1 domain send out using a different smart host.


--Steve
Reply With Quote
Sponsored Links
  #2  
Old 16th October 2012, 19:39
pebkac pebkac is offline
Senior Member
 
Join Date: Feb 2009
Posts: 132
Thanks: 2
Thanked 7 Times in 7 Posts
Default

I found this, http://forum.soft32.com/linux2/postf...pict29748.html

But we dont have a transport file in /etc/postfix, we do have a mysql_virtual_transport...but not sure if that is where it would go??
Reply With Quote
  #3  
Old 17th October 2012, 09:28
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 90 Times in 68 Posts
Default

You can define your transports under email->email routing

Cheers
Reply With Quote
  #4  
Old 17th October 2012, 10:15
pebkac pebkac is offline
Senior Member
 
Join Date: Feb 2009
Posts: 132
Thanks: 2
Thanked 7 Times in 7 Posts
Default

i have since figured that out. however it is still sending from itself and not the smarthost. I restared postfix to no avail. any ideas?
Reply With Quote
  #5  
Old 17th October 2012, 10:25
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 90 Times in 68 Posts
Default

Yes, you have to create a Relay recipient for each route too.

Email-> Relay Recipients
Reply With Quote
  #6  
Old 19th October 2012, 19:07
pebkac pebkac is offline
Senior Member
 
Join Date: Feb 2009
Posts: 132
Thanks: 2
Thanked 7 Times in 7 Posts
 
Default

Thanks for the replies. I'm so confused now though. Here is my exact scenario:

I have an external SPAM/Continuity/Encryption service I am testing. I have set my MX records for this domain to point to the service provider. In ISPconfig I have a domain set for the domain and have two email accounts. I then added a new email transport for the domain and in the destination added the mail server the provider gave me (this in hopes that all outgoing mail for this domain gets sent through the providers' mail server). I then added a relay recipient of @domain. Now when I send a message through the account it would not go through my service provider, it would just send it directly from the ISPConfig server, which is not my desired result. The mail goes through fine. I looked in the logs and noticed this entry "Oct 19 09:33:03 abda postfix/trivial-rewrite[17652]: warning: do not list domain nextcode.info in BOTH virtual_mailbox_domains and relay_domains". So I did some searching on the forums and found that I should remove that domain from domains. I did that but it then deletes the mail accounts and when I try to send a mail of course it does not go through.

Can someone tell me the correct way to get the ISPConfig server to send out to this other server so that I can use their services.

Thanks.

--Steve
Reply With Quote
Reply

Bookmarks

Tags
realy, smarthost, smtp relay

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
mysql and mail problem viritech General 3 16th October 2012 12:54
sneaking suspicion my postfix config has gone awry mjbarfoot Installation/Configuration 7 24th August 2010 12:23
Sending emails with custom FROM email address merisor Installation/Configuration 4 8th February 2010 16:27
Postfix issues NewMee Installation/Configuration 7 20th April 2009 18:52


All times are GMT +2. The time now is 00:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.