Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th October 2012, 15:58
joemiller joemiller is offline
Junior Member
 
Join Date: Oct 2012
Location: Carlisle, United Kingdom
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
Default Ports problem with phpmyadmin and squirrelmail

Hi, I've managed to install ISPConfig 3.0.4.6 on Centos 6.3, running nginx.
Everything runs smoothly, so far, thanks to Falko and his precise tutorials :-)

One small problem is when I try to access phpmyadmin, and squirrelmail, from the ISPConfig control panel, it directs me to the wrong ports.
e.g.
Click on the database in the control panel, and it send me to
https://mysite.co.uk:8080/phpmyadmin, which returns a 404 page not found error. If I manually change the url to
http://mysite.co.uk.co.uk:8081/phpmyadmin then I get the phpmyadmin login page.
In the manual it says that phpmyadmin listens on port 8081, so I don't understand why ISPConfig is directing me to port 8080.

I'm also not sure why my ssl isn't working; I've got the following in my nginx directives for the site;
location /phpmyadmin {
root /usr/share/;
index index.php index.html index.htm;
location ~ $host:8081/phpmyadmin/(.+\.php)$ {
try_files $uri =404;
root /usr/share/;
fastcgi_pass 127.0.0.1:9000;
fastcgi_param HTTPS on; # <-- add this line
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $request_filename;
include /etc/nginx/fastcgi_params;
fastcgi_param PATH_INFO $fastcgi_script_name;
fastcgi_buffer_size 128k;
fastcgi_buffers 256 4k;
fastcgi_busy_buffers_size 256k;
fastcgi_temp_file_write_size 256k;
fastcgi_intercept_errors on;
}
location ~* ^/phpmyadmin/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ {
root /usr/share/;
}
}
location /phpMyAdmin {
rewrite ^/* /phpmyadmin last;
}
location /squirrelmail {
root /usr/share/;
index index.php index.html index.htm;
location ~ ^/squirrelmail/(.+\.php)$ {
try_files $uri =404;
root /usr/share/;
fastcgi_pass 127.0.0.1:9000;
fastcgi_param HTTPS on; # <-- add this line
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $request_filename;
include /etc/nginx/fastcgi_params;
fastcgi_param PATH_INFO $fastcgi_script_name;
fastcgi_buffer_size 128k;
fastcgi_buffers 256 4k;
fastcgi_busy_buffers_size 256k;
fastcgi_temp_file_write_size 256k;
fastcgi_intercept_errors on;
}
location ~* ^/squirrelmail/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ {
root /usr/share/;
}
}
location /webmail {
rewrite ^/* /squirrelmail last;
}
According to the setup instructions, this should allow me to use https on both phpmyadmin and squirrelmail.

I have very similar problems with squirrelmail. Can anyone advise me please?
Many thanks.
Reply With Quote
Sponsored Links
  #2  
Old 13th October 2012, 13:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by joemiller View Post
Hi, I've managed to install ISPConfig 3.0.4.6 on Centos 6.3, running nginx.
Everything runs smoothly, so far, thanks to Falko and his precise tutorials :-)

One small problem is when I try to access phpmyadmin, and squirrelmail, from the ISPConfig control panel, it directs me to the wrong ports.
e.g.
Click on the database in the control panel, and it send me to
https://mysite.co.uk:8080/phpmyadmin, which returns a 404 page not found error. If I manually change the url to
http://mysite.co.uk.co.uk:8081/phpmyadmin then I get the phpmyadmin login page.
In the manual it says that phpmyadmin listens on port 8081, so I don't understand why ISPConfig is directing me to port 8080.
You must set the correct phpMyAdmin URL in the system settings in ISPConfig (Interface Config, I think).

Quote:
Originally Posted by joemiller View Post
I'm also not sure why my ssl isn't working; I've got the following in my nginx directives for the site;
location /phpmyadmin {
root /usr/share/;
index index.php index.html index.htm;
location ~ $host:8081/phpmyadmin/(.+\.php)$ {
try_files $uri =404;
root /usr/share/;
fastcgi_pass 127.0.0.1:9000;
fastcgi_param HTTPS on; # <-- add this line
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $request_filename;
include /etc/nginx/fastcgi_params;
fastcgi_param PATH_INFO $fastcgi_script_name;
fastcgi_buffer_size 128k;
fastcgi_buffers 256 4k;
fastcgi_busy_buffers_size 256k;
fastcgi_temp_file_write_size 256k;
fastcgi_intercept_errors on;
}
location ~* ^/phpmyadmin/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ {
root /usr/share/;
}
}
location /phpMyAdmin {
rewrite ^/* /phpmyadmin last;
}
location /squirrelmail {
root /usr/share/;
index index.php index.html index.htm;
location ~ ^/squirrelmail/(.+\.php)$ {
try_files $uri =404;
root /usr/share/;
fastcgi_pass 127.0.0.1:9000;
fastcgi_param HTTPS on; # <-- add this line
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $request_filename;
include /etc/nginx/fastcgi_params;
fastcgi_param PATH_INFO $fastcgi_script_name;
fastcgi_buffer_size 128k;
fastcgi_buffers 256 4k;
fastcgi_busy_buffers_size 256k;
fastcgi_temp_file_write_size 256k;
fastcgi_intercept_errors on;
}
location ~* ^/squirrelmail/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ {
root /usr/share/;
}
}
location /webmail {
rewrite ^/* /squirrelmail last;
}
According to the setup instructions, this should allow me to use https on both phpmyadmin and squirrelmail.

I have very similar problems with squirrelmail. Can anyone advise me please?
Many thanks.
The apps vhost doesn't use SSL. You'd have to configure it manually to do so.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th October 2012, 09:48
joemiller joemiller is offline
Junior Member
 
Join Date: Oct 2012
Location: Carlisle, United Kingdom
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Ok, thanks I'll add it to my to-do list.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
After Installed of ISPConfig 3(last version) not worked phpmyadmin and squirrelmail kings Installation/Configuration 3 12th October 2012 12:57
Slight problem with Squirrelmail DaleHutch Server Operation 2 19th May 2010 18:26
Phpmyadmin, squirrelmail, pear, ioncube, Zend loader cat Feature Requests 0 5th August 2009 19:01
phpmyadmin and squirrelmail are 404 & ClamAV is outdated kvand General 22 16th July 2009 14:24
phpmyadmin problem on ubuntu mail server virtual domains almeister9 HOWTO-Related Questions 1 19th September 2008 16:52


All times are GMT +2. The time now is 12:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.