#1  
Old 9th December 2012, 11:35
Hasanov Hasanov is offline
Junior Member
 
Join Date: Dec 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default dovecot problem after ISPCONFIG

I went through step-by-step installation guide and did everything that had to be done to install ISPconfig on my new centos 5.8 server. There is just one problem and that is Dovecot is not installed. When I try to install again it shows some missing dependencies... AND one more thing from where I can get GPG key for ATrpms repository.. Thanks..



Code:
[root@baki ~]# yum install dovecot dovecot-sieve
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * atomic: mir01.syntis.net
 * base: mirror.ovh.net
 * centosplus: mirror.ovh.net
 * contrib: mirror.ovh.net
 * extras: mirror.ovh.net
 * rpmforge: archive.cs.uu.nl
 * updates: mirror.ovh.net
Excluding Packages in global exclude list
Finished
Excluding Packages from Red Hat Enterprise Linux 5 - x86_64 - ATrpms
Finished
Reducing Red Hat Enterprise Linux 5 - x86_64 - ATrpms to included packages only
Finished
Excluding Packages from Red Hat Enterprise Linux 5 - x86_64 - ATrpms testing
Finished
Reducing Red Hat Enterprise Linux 5 - x86_64 - ATrpms testing to included packages only
Finished
Excluding Packages from CentOS-5 - Base
Finished
Reducing CentOS-5 - Plus to included packages only
Finished
Excluding Packages from CentOS-5 - Updates
Finished
Setting up Install Process
No package dovecot-sieve available.
Resolving Dependencies
--> Running transaction check
---> Package dovecot.x86_64 1:1.0.15-1_74.el3 set to be updated
--> Processing Dependency: libpq.so.3()(64bit) for package: dovecot
--> Processing Dependency: libmysqlclient.so.10()(64bit) for package: dovecot
--> Processing Dependency: libldap.so.2()(64bit) for package: dovecot
--> Processing Dependency: liblber.so.2()(64bit) for package: dovecot
--> Finished Dependency Resolution
1:dovecot-1.0.15-1_74.el3.x86_64 from atrpms has depsolving problems
  --> Missing Dependency: libmysqlclient.so.10()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
1:dovecot-1.0.15-1_74.el3.x86_64 from atrpms has depsolving problems
  --> Missing Dependency: libldap.so.2()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
1:dovecot-1.0.15-1_74.el3.x86_64 from atrpms has depsolving problems
  --> Missing Dependency: libpq.so.3()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
1:dovecot-1.0.15-1_74.el3.x86_64 from atrpms has depsolving problems
  --> Missing Dependency: liblber.so.2()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
Error: Missing Dependency: libldap.so.2()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
Error: Missing Dependency: libpq.so.3()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
Error: Missing Dependency: libmysqlclient.so.10()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
Error: Missing Dependency: liblber.so.2()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
BTW. I'm a total newbie to linux but not an idiot. So if you guys can show me around, I will be able to know what to do. Thank you all in advance, kind regards!
Reply With Quote
Sponsored Links
  #2  
Old 10th December 2012, 10:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Which tutorial (URL) did you use? What are the outputs of
Code:
netstat -tap
,
Code:
 iptables -L
, and
Code:
getconfig
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 11th December 2012, 21:33
Hasanov Hasanov is offline
Junior Member
 
Join Date: Dec 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Which tutorial (URL) did you use?
I used tutorial for ISPconfig 3 installation for CentOS 5.7 - http://www.howtoforge.com/perfect-se...64-ispconfig-3

Quote:
Originally Posted by falko View Post
What are the outputs of
Code:
netstat -tap
Code:
[root@baki ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
tcp        0      0 localhost.localdomain:10024 *:*                         LISTEN      14306/amavisd (mast 
tcp        0      0 *:mysql                     *:*                         LISTEN      5416/mysqld         
tcp        0      0 localhost.local:dyna-access *:*                         LISTEN      14323/clamd         
tcp        0      0 *:sunrpc                    *:*                         LISTEN      3899/portmap        
tcp        0      0 *:721                       *:*                         LISTEN      3931/rpc.statd      
tcp        0      0 baki.***.net:domain       *:*                         LISTEN      3970/named          
tcp        0      0 localhost.localdomai:domain *:*                         LISTEN      3970/named          
tcp        0      0 *:ftp                       *:*                         LISTEN      14352/pure-ftpd (SE 
tcp        0      0 *:ssh                       *:*                         LISTEN      3021/sshd           
tcp        0      0 localhost.localdomain:smtp  *:*                         LISTEN      5577/master         
tcp        0      0 localhost.localdomain:rndc  *:*                         LISTEN      3970/named          
tcp        0    976 baki.***.net:ssh          MYREALIP:61779          ESTABLISHED 18640/sshd          
tcp        0      0 *:webcache                  *:*                         LISTEN      4955/httpd          
tcp        0      0 *:http                      *:*                         LISTEN      4955/httpd          
tcp        0      0 *:tproxy                    *:*                         LISTEN      4955/httpd          
tcp        0      0 *:domain                    *:*                         LISTEN      3970/named          
tcp        0      0 *:ftp                       *:*                         LISTEN      14352/pure-ftpd (SE 
tcp        0      0 *:ssh                       *:*                         LISTEN      3021/sshd           
tcp        0      0 ::1:rndc                    *:*                         LISTEN      3970/named          
[root@baki ~]#
Quote:
Originally Posted by falko View Post
What are the outputs of
Code:
 iptables -L
Code:
[root@baki ~]# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         
[root@baki ~]#
Quote:
Originally Posted by falko View Post
What are the outputs of
Code:
getconfig
?
Code:
[root@baki ~]# getconfig
-bash: getconfig: command not found
[root@baki ~]#
Reply With Quote
  #4  
Old 12th December 2012, 10:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by Hasanov View Post
AND one more thing from where I can get GPG key for ATrpms repository.. Thanks..
Just run
Code:
wget http://ATrpms.net/RPM-GPG-KEY.atrpms
rpm --import RPM-GPG-KEY.atrpms
Can you run
Code:
/etc/init.d/dovecot start
? Does it work then? If not, what's the output of
Code:
uname -a
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 12th December 2012, 16:53
Hasanov Hasanov is offline
Junior Member
 
Join Date: Dec 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Just run
Code:
wget http://ATrpms.net/RPM-GPG-KEY.atrpms
rpm --import RPM-GPG-KEY.atrpms
Code:
[root@baki ~]# wget http://ATrpms.net/RPM-GPG-KEY.atrpms
--2012-12-12 16:49:52--  http://atrpms.net/RPM-GPG-KEY.atrpms
Resolving atrpms.net... 160.45.254.26
Connecting to atrpms.net|160.45.254.26|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2012-12-12 16:49:52 ERROR 404: Not Found.

[root@baki ~]# rpm --import RPM-GPG-KEY.atrpms
error: RPM-GPG-KEY.atrpms: import read failed(-1).
[root@baki ~]#

Quote:
Originally Posted by falko View Post

Can you run
Code:
/etc/init.d/dovecot start
? Does it work then?
Code:
[root@baki ~]# /etc/init.d/dovecot start
-bash: /etc/init.d/dovecot: No such file or directory
[root@baki ~]#
Quote:
Originally Posted by falko View Post
If not, what's the output of
Code:
uname -a
?
Code:
[root@baki ~]# uname -a
Linux baki.***.net 3.2.13-grsec-xxxx-grs-ipv6-64 #1 SMP Thu Mar 29 09:48:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@baki ~]#
it's just it does not install dovecot because of missing dependencies that are mentioned in my first post..
Reply With Quote
  #6  
Old 13th December 2012, 17:53
Hasanov Hasanov is offline
Junior Member
 
Join Date: Dec 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

it will sound stupid, but i just updated ISPconfig (through ssh) and everything works perfectly now.. dovecot runs too
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 19:02
around 80 sleeping connections created by ISPConfig bkilinc General 2 1st October 2012 16:12
No dns zone files created? sjau Installation/Configuration 7 13th March 2012 13:15
MySQL Error Nolan Installation/Configuration 12 16th February 2011 02:15
Hosting multiple websites and webmail dmwcool Installation/Configuration 8 30th March 2010 03:15


All times are GMT +2. The time now is 06:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.