Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th October 2012, 15:02
dsautet dsautet is offline
Member
 
Join Date: Feb 2012
Posts: 31
Thanks: 2
Thanked 2 Times in 2 Posts
Default Run Symfony 2 on ISPConfig

Hi everybody!

I have a little problem.
In fact I would like to install Symfony 2 and use it with ISPConfig.

Once I have installed ISPConfig3 I don't know how to insert Symfony 2 in it.
First I unzip the symfony2 archive into /var/www/MyProject/web but after I have an error to access to the main page.

I think it is a problem in apache configuration.

Is there somebody who can help me on that?

Thank you very much!
Reply With Quote
The Following User Says Thank You to dsautet For This Useful Post:
adamassasda291 (4th June 2013)
Sponsored Links
  #2  
Old 12th October 2012, 15:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,665
Thanks: 819
Thanked 5,316 Times in 4,169 Posts
Default

ensure that you chowned all symfony files to the web[ID] user and client[id] group of the website, otherwise the files can not be accessed by apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th October 2012, 15:13
dsautet dsautet is offline
Member
 
Join Date: Feb 2012
Posts: 31
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Thank you!

And do I have to keep cgi-bin, index.htm, ... files that we have by default on IspConfig?
Reply With Quote
  #4  
Old 12th October 2012, 15:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,665
Thanks: 819
Thanked 5,316 Times in 4,169 Posts
Default

the index.html file has to be deleted. the cgi-bin folder must stay there.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 12th October 2012, 15:16
dsautet dsautet is offline
Member
 
Join Date: Feb 2012
Posts: 31
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Ok I'll try this evening.

Thank you very much!!!
Reply With Quote
  #6  
Old 13th October 2012, 21:21
dsautet dsautet is offline
Member
 
Join Date: Feb 2012
Posts: 31
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Hello,

Still have a problem.

In fact here is the error I have in my browser when I go my website mywebsite.fr/config.php

Major problems have been detected and must be fixed before continuing :

- Change the permissions of the "app/cache/" directory so that the web server can write into it.
- Change the permissions of the "app/logs/" directory so that the web server can write into it.

I change the chown for all my folders and files and put a chmod 777 for log and cahe's folders like this :

/var/www/mywebsite.fr# ls -la

drwxr-xr-x 6 web2 client0 4096 13 oct. 02:04 app
drwxr-xr-x 2 web2 client0 4096 13 oct. 01:41 bin
drwxr-x--x 2 web2 client0 4096 13 oct. 01:28 cgi-bin
-rwxr-x--x 1 web2 client0 1574 13 oct. 01:41 deps
-rwxr-x--x 1 web2 client0 487 13 oct. 01:41 deps.lock
-rwxr-x--x 1 web2 client0 1065 13 oct. 01:41 LICENSE
lrwxrwxrwx 1 web2 client0 40 13 oct. 01:28 log -> /var/log/ispconfig/httpd/mywebsite.fr
-rwxr-x--x 1 web2 client0 6405 13 oct. 01:41 README.md
drwxr-xr-x 3 web2 client0 4096 13 oct. 01:41 src
drwxr-x--x 2 web2 client0 4096 13 oct. 01:28 ssl
drwxrwxrwx 2 web2 client0 4096 13 oct. 01:28 tmp
drwxr-xr-x 13 web2 client0 4096 13 oct. 01:41 vendor
drwxr-xr-x 5 web2 client0 4096 13 oct. 12:43 web

/var/www/mywebsite.fr/app# ls -la

-rw-r--r-- 1 web2 client0 141 13 oct. 01:41 AppCache.php
-rw-r--r-- 1 web2 client0 1413 13 oct. 01:41 AppKernel.php
-rw-r--r-- 1 web2 client0 1841 13 oct. 01:41 autoload.php
-rw-r--r-- 1 web2 client0 40237 13 oct. 01:41 bootstrap.php.cache
drwxrwxrwx 3 web2 client0 4096 13 oct. 03:09 cache
-rw-r--r-- 1 web2 client0 6026 13 oct. 01:41 check.php
drwxr-xr-x 2 web2 client0 4096 13 oct. 02:12 config
-rwxr-xr-x 1 web2 client0 734 13 oct. 01:41 console
-rw-r--r-- 1 web2 client0 13 13 oct. 01:41 .htaccess
drwxrwxrwx 2 web2 client0 4096 13 oct. 02:04 logs
-rw-r--r-- 1 web2 client0 1327 13 oct. 01:41 phpunit.xml.dist
drwxr-xr-x 3 web2 client0 4096 13 oct. 01:41 Resources

I don't know what I have missed.

Thanks for reply!!

Last edited by dsautet; 13th October 2012 at 21:31.
Reply With Quote
  #7  
Old 13th October 2012, 21:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,665
Thanks: 819
Thanked 5,316 Times in 4,169 Posts
Default

the permission change is not nescessary, just select the correct php mode.

You have to use php-fcgi and enable the suexec checkbox in the website settings as described in the manual when a php script shall be able to write to the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 13th October 2012, 22:17
dsautet dsautet is offline
Member
 
Join Date: Feb 2012
Posts: 31
Thanks: 2
Thanked 2 Times in 2 Posts
Default

I have already Suexec enable and fcgi like php mode.

Any others ideas?
Reply With Quote
The Following User Says Thank You to dsautet For This Useful Post:
adamassasda291 (26th May 2013)
  #9  
Old 14th October 2012, 11:31
dsautet dsautet is offline
Member
 
Join Date: Feb 2012
Posts: 31
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Nobody has ideas?

I'll try to give you my diffenrent configuration.

Wich files or folders do you need to see?

I still have the same errors and when I go on app_dev.fr the page is blank.

Thanks
Reply With Quote
  #10  
Old 15th October 2012, 17:42
dsautet dsautet is offline
Member
 
Join Date: Feb 2012
Posts: 31
Thanks: 2
Thanked 2 Times in 2 Posts
 
Default

Please help me, I have tried all options but still the same error
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 18:10
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 19:02
Ubuntu 11.10, ISPConfig 3.0.4.1 needs some nginx.conf tweaks after following guide. talkingnews Installation/Configuration 10 28th November 2011 21:55
PHP warnings after upgrade to ISP config 3.03 stevegjacobs Installation/Configuration 5 30th October 2010 14:31
ISPConfig 3.0.0.7 Beta released till General 78 24th December 2008 11:47


All times are GMT +2. The time now is 07:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.