Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th October 2012, 10:26
Tarm Tarm is offline
Junior Member
 
Join Date: Oct 2012
Posts: 10
Thanks: 2
Thanked 2 Times in 1 Post
Default [SOLVED]Perfect server Ubuntu 12.04 - no mail in mailbox

Hi,

I've followed the Perfect Server Ubuntu with apache and ISPConfig 3 (great tutorial).

I've just got the server up and running, but it seems like there are some problems regarding the email. When sending an email to me@mydomain.com nothing shows up in the SquirrelMail inbox. Although I'm fully able to send out emails.

in /var/log/mail.log I get the following:

Code:
Oct 12 09:03:23 MyServer postfix/smtpd[1483]: 421E7CC12B4: client=localhost[127.0.0.1]
Oct 12 09:03:23 MyServer postfix/cleanup[1479]: 421E7CC12B4: message-id=<5077C093.20004@SomeOneElse.Com>
Oct 12 09:03:23 MyServer postfix/smtpd[1483]: disconnect from localhost[127.0.0.1]
Oct 12 09:03:23 MyServer postfix/qmgr[1398]: 421E7CC12B4: from=<someONe@SomeOneElse.com>, size=1408, nrcpt=1 (queue active)
Oct 12 09:03:23 MyServer postfix/trivial-rewrite[1474]: warning: do not list domain MyDomain.com in BOTH mydestination and virtual_mailbox_domains
Oct 12 09:03:23 MyServer amavis[1568]: (01568-04) Passed CLEAN, [194.63.252.54] [194.63.252.54] <someOne@SomeOneElse.com> -> <me@myDomain.com>, Message-ID: <5077C093.20004@SomeOneElse.com>, mail_id: 7gPmU0XPdBVc, Hits: 0, size: 957, queued_as: 421E7CC12B4, 2319 ms
Oct 12 09:03:23 MyServer postfix/smtp[1480]: EBFC5CC01DE: to=<me@myDomain.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=2.4, delays=0.06/0.01/0/2.3, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 421E7CC12B4)
Oct 12 09:03:23 MyServer postfix/qmgr[1398]: EBFC5CC01DE: removed
Oct 12 09:03:23 MyServer postfix/local[1484]: 421E7CC12B4: to=<me@myDomain.com>, relay=local, delay=0.12, delays=0.07/0.01/0/0.04, dsn=2.0.0, status=sent (delivered to mailbox)
Oct 12 09:03:23 MyServer postfix/qmgr[1398]: 421E7CC12B4: removed
MyServer has the same name as MyDomain.com.
When looking around a bit, I can read all my emails at /var/mail/userName. It seems like the mail is not delivered to the virtual mailboxes.

I'm using Postfix, Dovecot and SqurrelMail (according to the tutorial).

Does anyone have a suggestion on how to fix this?

Thanks!

Last edited by Tarm; 12th October 2012 at 11:41.
Reply With Quote
Sponsored Links
  #2  
Old 12th October 2012, 11:24
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,012
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

See Here:

Oct 12 09:03:23 MyServer postfix/trivial-rewrite[1474]: warning: do not list domain MyDomain.com in BOTH mydestination and virtual_mailbox_domains

The problem is that a wrong hostname was used for the server. In the tutorial a subdomain like server1.mydomain.tld is used as hostname, if you use mydomain.tld instead, email will fail for all email accounts of mydomain.tld

To fix that, edit /etc/hostname, /etc/mailname, /etc/hosts and /etc/postfix/main.cf and replace mydomain.tld with server1.mydomain.tld and restart your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
alexeyttsy3922 (24th June 2013)
  #3  
Old 12th October 2012, 11:41
Tarm Tarm is offline
Junior Member
 
Join Date: Oct 2012
Posts: 10
Thanks: 2
Thanked 2 Times in 1 Post
 
Default

Thanks a lot, it works great now! : - )
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Email Working ISPConfig3 Squirrelmail and Courier etc Ian Wilson Installation/Configuration 17 19th June 2013 23:58
Postfix/courier/Centos 6 cant send email to external email servers maxtorzito Installation/Configuration 14 7th October 2011 11:56
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 15:49
Debian 5 Ajax error + network interface always shutting down ev0css Installation/Configuration 3 5th June 2010 13:58
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 15:33


All times are GMT +2. The time now is 18:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.