Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th October 2012, 20:17
BeauSanders BeauSanders is offline
Junior Member
 
Join Date: Oct 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default How to Setup Postfix to Work with Fortimail

I am attempting to configure a Postfix MTA in CentOS 6.3 for our school. The Postfix server has to send and receive email through a Fortimail firewall. Outgoing email is working fine. Email sent locally using the mail command to a local user on the CentOS/Postfix server works fine. However, all email coming in to the Fortimail firewall addressed to users on the Postfix server is NOT being accepted by Postfix. Inbound mail from Fortimail is being deferred and ultimately rejected by Postfix. It appears the email is being forwarded/relayed from the Fortimail firewall to the Postfix server. There are no errors on the Fortimail firewall.

Here is the main.cf file as it is currently configured:

Code:
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
mail_owner = postfix
myhostname = bps.gvltec.edu
inet_interfaces = all
inet_protocols = all
mydestination = $myhostname, localhost.$mydomain, localhost
unknown_local_recipient_reject_code = 550
relayhost = [fortimail.ip.address.here]
relay_recipient_maps = hash:/etc/postfix/relay_recipients
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         ddd $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.6.6/samples
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
Please advise me on what I am missing. I have not been able to locate any posts from users with similar problems. I will be happy to answer questions if somewhere will help me correct this issue.

Thank you in advance for your help.

-Beau
Reply With Quote
Sponsored Links
  #2  
Old 12th October 2012, 13:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Are there any errors in your mail log (in the /var/log/ directory)?

Is port 25 open on your firewall? Is your firewall configured to forward port 25 to your Postfix server?

Did you check if maybe your ISP is blocking port 25?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
postfix problem jagsler Server Operation 41 7th July 2011 14:19
Postfix SMTP Auth to Dovecot Not Working -- HELP! Scratchpad Server Operation 6 12th April 2011 13:29
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36


All times are GMT +2. The time now is 12:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.