Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st October 2012, 12:11
Justin Albstmeijer Justin Albstmeijer is offline
Member
 
Join Date: Dec 2007
Posts: 76
Thanks: 1
Thanked 6 Times in 6 Posts
Default ISPconfig3 creating user with old mysql password hashes?

Hi,

I'm currently running ISPconfig 3.0.4.5.
I noticed in the 'users' table of mysql on the database servers, that database users get created with the old shorter mysql password hashes.
Looking at earlier accounts created with ISPconfig, they all have the new longer mysql password hashes.

Was this a deliberate change in ISPconfig?
Can I change this behaviour?

The reason I noticed this was because newer mysql clients (5.5+) start to refuse to authenticated using the old password hashes.

Thanks in advance for any feedback.

Justin
Reply With Quote
Sponsored Links
  #2  
Old 1st October 2012, 12:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,405
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

ISPConfig creates passwords with the default mysql password() command. If the short or long hashes are used is configured in mysql my.cnf, thats not a setting in ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Justin Albstmeijer (1st October 2012)
  #3  
Old 1st October 2012, 13:35
Justin Albstmeijer Justin Albstmeijer is offline
Member
 
Join Date: Dec 2007
Posts: 76
Thanks: 1
Thanked 6 Times in 6 Posts
 
Default

Till,

Thanks, you are right for some reason I had "old_passwords=1" in my.cnf.

Justin
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My Server Is Sending Spam. How Do I Block This? LordJ Server Operation 1 7th July 2011 19:34
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
pure-ftpd + mysql cemmo Installation/Configuration 6 21st August 2010 20:17
Squirrel Mail Unknown user or password incorrect. Dovecot-Postfix with MySQL Support dpicella Installation/Configuration 6 20th August 2010 15:48
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24


All times are GMT +2. The time now is 01:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.