Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th August 2005, 12:45
skeeta skeeta is offline
Junior Member
 
Join Date: Aug 2005
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Question How can I use email addresses for usernames

I have removed the username prefix as I want to use email addresses as usernames.
However, when I try to use an email address I get an error as "@" is not an accepted character.

Could you please guide me to which file/line needs modifying.
Reply With Quote
Sponsored Links
  #2  
Old 25th August 2005, 13:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

You cannot use email addresses as usernames because email addresses aren't accepted by Linux as usernames. There's nothing you can do about it...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 25th August 2005, 14:03
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 9 Times in 8 Posts
Default

I'm a bit confused here. As it stands, the current username for webmail is: web1_username@domain.com

If by removing the prefix web1_, wouldn't the username just be: username@ domain.com? WHich is completely acceptable with the two popular webmail clients, Horde and Squirrelmail.
Reply With Quote
  #4  
Old 25th August 2005, 14:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by domino
I'm a bit confused here. As it stands, the current username for webmail is: web1_username@domain.com

If by removing the prefix web1_, wouldn't the username just be: username@ domain.com? WHich is completely acceptable with the two popular webmail clients, Horde and Squirrelmail.
Yes, but skeeta is talking about system users; system users are the part before the @ sign. System users are the users you create in ISPConfig and who can then use FTP and email. The login for webmail is then [username]@[domain].
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 25th August 2005, 15:57
Bedevere Bedevere is offline
Junior Member
 
Join Date: Aug 2005
Location: NYC
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Bedevere Send a message via MSN to Bedevere Send a message via Yahoo to Bedevere
Default

I think this whole set up is pretty good, but it is too bad that users of email readers (Outlook, etc) have to put in "web<number>_Username" for their log in. I too wish I could put "username@domain.com".

Along this line I saw a setting for the default prefix for domain accounts. maybe you could create an option to use a suffix instead or to use other fields...so instead of id number use the domain name for the real user name in the system, then you could have "user_domain" or even "domain_user" as the mail and ftp log in which would be more intuative for a user.

Last edited by Bedevere; 25th August 2005 at 15:59.
Reply With Quote
  #6  
Old 25th August 2005, 18:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by Bedevere
I think this whole set up is pretty good, but it is too bad that users of email readers (Outlook, etc) have to put in "web<number>_Username" for their log in. I too wish I could put "username@domain.com".

Along this line I saw a setting for the default prefix for domain accounts. maybe you could create an option to use a suffix instead or to use other fields...so instead of id number use the domain name for the real user name in the system, then you could have "user_domain" or even "domain_user" as the mail and ftp log in which would be more intuative for a user.
Go to Management -> System Config -> Settings. On the tab ISP-Manager you will see the field User Prefix where you can specify a prefix for users. You can use one of the following placeholders:
  • [DOMAIN]
  • [HOST]
  • [WEBID]

If you don't want a prefix, just leave it blank.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 25th August 2005, 21:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,409
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
Originally Posted by Bedevere
I think this whole set up is pretty good, but it is too bad that users of email readers (Outlook, etc) have to put in "web<number>_Username" for their log in. I too wish I could put "username@domain.com".
Mailboxes are linux system user accounts in the current ISPConfig setup. An the "@" sign is not allowed in linux usernames.
Reply With Quote
  #8  
Old 27th November 2005, 22:33
willcee willcee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

good evening,

i also want to use the full email addresse instead of the system username (web#_username) to login to horde.
im asking me, why does it function in uebimail with the email address, and in horde it wont run?
must i set a config entry in horde, or do anybody no how to fix this?

does it run with just leave blank the user prefix?

sorry i dont really understand the answers above...

thanks for help

willcee
Reply With Quote
  #9  
Old 27th November 2005, 22:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by willcee
im asking me, why does it function in uebimail with the email address, and in horde it wont run?
Because we tweaked Uebimiau so that it accepts email addresses.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 28th November 2005, 00:22
willcee willcee is offline
Junior Member
 
Join Date: Nov 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

o yes i see... but is it possible to tweak horde that it also accept email addresses?

i know its possible, my hosting provider also has horde an it accept email addresses.
or could it be that my provider has an other imap or pop server behind horde, who has its own users and do not use the system users?
thanks for all
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hiding email addresses myles Programming/Scripts 5 1st December 2008 12:09
Help forward root email to me domino Technical 10 2nd May 2006 15:01
email client configuration davidg General 3 22nd August 2005 16:40
Adding IP Addresses radioguy Installation/Configuration 1 15th August 2005 09:07
Location of IP addresses roadrunner Programming/Scripts 2 2nd May 2005 22:19


All times are GMT +2. The time now is 15:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.