Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th March 2011, 11:04
JohnnyBeGood JohnnyBeGood is offline
HowtoForge Supporter
 
Join Date: Mar 2008
Posts: 40
Thanks: 8
Thanked 4 Times in 4 Posts
Default Easy RoundCube (Over SSL) And Webmin With fail2ban For ISPConfig 3 On Debian Squeeze

Hi,

I was happy to see there's how-to on roundcube for Debian Squeeze and ISPconfig 3 because I couldn't get to work with squirrelmail http://www.howtoforge.com/forums/showthread.php?t=50797

After following tutorial to a T I get this error
when trying to access https://www.tld.com/webmail

Code:
Secure Connection Failed

      
          

An error occurred during a connection to www.tld.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

    


    *   The page you are trying to view can not be shown because the authenticity of the received data could not be verified.

    *   Please contact the web site owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.
What am I missing?

Thanks in advance!
Reply With Quote
Sponsored Links
  #2  
Old 4th March 2011, 12:31
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default

You have to type

http://www.tld.com/webmail
or
https://www.tld.com:8080/webmail

the same is for phpmyadmin or whatever else you set up following the guide

The ssl is setup for port 8080
Reply With Quote
  #3  
Old 4th March 2011, 17:06
JohnnyBeGood JohnnyBeGood is offline
HowtoForge Supporter
 
Join Date: Mar 2008
Posts: 40
Thanks: 8
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by 8omas View Post
You have to type

http://www.tld.com/webmail
or
https://www.tld.com:8080/webmail

the same is for phpmyadmin or whatever else you set up following the guide

The ssl is setup for port 8080
I get same error when trying to access either one.
Does ssl needs to be enabled somewhere?
Reply With Quote
  #4  
Old 4th March 2011, 21:17
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default

In the beginning of the HowTo I mention :
Quote:
If you want to access ISPConfig Panel and webmail through SSL I also assume that you followed the chapter 6.2 Enabling SSL For The ISPConfig Web Interface of The ISPConfig 3 manual (this is only needed if you want to access the control panel AND the webmail interface through ssl on port 8080).

If you followed the above, then I finally assume that you read the workaround in this post.
You HAVE to do those things to have SSL over port 8080. After that you can follow anyone of the 2 links in my previous post.
Reply With Quote
  #5  
Old 4th March 2011, 21:29
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default

If you don't have the manual, the following will help:
http://www.faqforge.com/linux/contro...-controlpanel/

This does NOT include instruction for enabling SuExec for ISPConfig, so you probably will not need the last referred link (http://www.howtoforge.com/forums/showthread.php?t=51236). As I understand it only resolves the removing of symlink to /var/www/ispconfig, which you (probably didn't remove)
Reply With Quote
  #6  
Old 5th March 2011, 13:57
JohnnyBeGood JohnnyBeGood is offline
HowtoForge Supporter
 
Join Date: Mar 2008
Posts: 40
Thanks: 8
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by 8omas View Post
In the beginning of the HowTo I mention :


You HAVE to do those things to have SSL over port 8080. After that you can follow anyone of the 2 links in my previous post.
Sorry, I missed that step. I did not enable ssl. Since I'm supporter of this site I do have ISPconfig manual.

No, I do not need SuExec.

After enabling ssl now I'm able to access roundcube
by typing http://www.tld.com/webmail which redirects me to https://www.tld.com:8080/webmail/ but I get the following error:

DATABASE ERROR: CONNECTION FAILED!

Unable to connect to the database!
Please contact your server-administrator.


If I remember correctly after I issued apt-get install roundcube command it asked if I wanted to auto configure DB, I selected no, I can't quote exact phrase but it was confusing and I thought it would mess up ISPconfig DB.
Reply With Quote
  #7  
Old 5th March 2011, 14:24
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default

This step would simply create the necessary roundcube db. It would ask for a user and a pass.
Remove (purge) and reinstall round cube
Reply With Quote
  #8  
Old 5th March 2011, 15:17
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default

Maybe I must include this to the guide.
When you run apt-get install roundcube, then you'll be asked about the database system to use (I use mysql). After that you'll be asked for the password of the db admin user (usually root). At the end you'll be asked for the password of roundcube database (the db-config system will create the roundcube database and the roundcube user)

If all the above do not help (and you cannot recreate or configure the db) then:
Code:
apt-get remove --purge roundcube roundcube-mysql
apt-get install  roundcube roundcube-mysql
dpkg-reconfigure roundcube-core
The last one will ask you a lot of questions (assuming that you install on a single server installation, I 'll post some possible answers):
1) ... IMAP = leave blank or enter localhost or even your server's full hostname
2) language = whatever you want
3) Reinstall database? = Yes
4) Database type = mysql
5) Connection method = unix socket
6) Name of the database's administrative user root (almost always .. few people changes this)
7) root password = the administrative user's password (this is needed to create the roundcube db and user)
8) username for roundcube = roundcube (or whatever you want)
9) database name for roundcube = roundcube (or whatever you want)
10) Web server(s) to configure automatically = apache2 (possibly)

If you already created the db, then in the last step you'll get an error. Ignore it, remove the db (roundcube's db) and the roundcube user, with the phpmyadmin and rerun the dpkg-reconfigure roundcube-core.

Last edited by 8omas; 5th March 2011 at 19:26.
Reply With Quote
The Following User Says Thank You to 8omas For This Useful Post:
JohnnyBeGood (5th March 2011)
  #9  
Old 5th March 2011, 23:35
JohnnyBeGood JohnnyBeGood is offline
HowtoForge Supporter
 
Join Date: Mar 2008
Posts: 40
Thanks: 8
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by 8omas View Post
Maybe I must include this to the guide.
When you run apt-get install roundcube, then you'll be asked about the database system to use (I use mysql). After that you'll be asked for the password of the db admin user (usually root). At the end you'll be asked for the password of roundcube database (the db-config system will create the roundcube database and the roundcube user)

If all the above do not help (and you cannot recreate or configure the db) then:
Code:
apt-get remove --purge roundcube roundcube-mysql
apt-get install  roundcube roundcube-mysql
dpkg-reconfigure roundcube-core
The last one will ask you a lot of questions (assuming that you install on a single server installation, I 'll post some possible answers):
1) ... IMAP = leave blank or enter localhost or even your server's full hostname
2) language = whatever you want
3) Reinstall database? = Yes
4) Database type = mysql
5) Connection method = unix socket
6) Name of the database's administrative user root (almost always .. few people changes this)
7) root password = the administrative user's password (this is needed to create the roundcube db and user)
8) username for roundcube = roundcube (or whatever you want)
9) database name for roundcube = roundcube (or whatever you want)
10) Web server(s) to configure automatically = apache2 (possibly)

If you already created the db, then in the last step you'll get an error. Ignore it, remove the db (roundcube's db) and the roundcube user, with the phpmyadmin and rerun the dpkg-reconfigure roundcube-core.
Thank you!
I works now. Finally webmail works because I gave up on trying to get SquirrelMail to work with ISPconfig.
Attached is the step that I messed up and selected "No"
If you can please edit your tutorial and add above instructions it might help some newbie like me
Attached Images
 
Reply With Quote
The Following User Says Thank You to JohnnyBeGood For This Useful Post:
8omas (6th March 2011)
  #10  
Old 6th March 2011, 01:35
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
 
Default

You are right. After your previous post, I realized this and I already updated the guide.
Thanks for the suggestion
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.