Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th July 2006, 03:13
dreger dreger is offline
Junior Member
 
Join Date: Jul 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig: Install: mysql: unknown variable 'db-name=default'

All prerequisites are fulfilled.
Here we go...
Please enter your MySQL server:localhost
OK
Please enter your MySQL user: myuser
Please enter your MySQL password: mypass
mysql: unknown variable 'db-name=default'
The provided MySQL password is wrong!
Please enter your MySQL server:

The name and password is correct.. What's with the "mysql: unknown variable?" I've googled and yahooed and msned and and with no indications that anyone has had this problem...

My configuration is Fedora Core 5 with all the latest updates running MySQL 5.0 updated via yum following the directions for FC5 from the link in the ISPConfig website. Everything went well until this point. Is there something I can change to remedy this? I really need a hosting admin system that runs on FC5, so plesk is out of the question.

Last edited by dreger; 29th July 2006 at 06:20.
Reply With Quote
Sponsored Links
  #2  
Old 29th July 2006, 07:58
dreger dreger is offline
Junior Member
 
Join Date: Jul 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Talking

I figured it out! <blushes>

After myssing with mysql for some time and deciding it had to be in a config file somewhere.. well.. it wasn't ~/my.cnf or /etc/my.cnf it was ~/.my.cnf!

<chuckles>

Oh well.. maybe this'll help someone some day..

So many settings, so many configs, so many places...

<waves>
Reply With Quote
  #3  
Old 30th July 2006, 13:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by dreger
Please enter your MySQL user: myuser
I hope you entered root here. Otherwise you'll get problems with permissions.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 30th July 2006, 22:23
dreger dreger is offline
Junior Member
 
Join Date: Jul 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Actually I had set up an account with full permissions for that purpose, so no not root, but no problems All is running well now thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
php script injections Grizzly General 21 18th July 2006 08:55
configuring IPTABLES firewall adityavpratap HOWTO-Related Questions 9 27th May 2006 21:42
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 09:41


All times are GMT +2. The time now is 14:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.