Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th December 2005, 09:41
rosa hsiao rosa hsiao is offline
Member
 
Join Date: Oct 2005
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Default Email aliases problem

I can send email with "web1_pink@test.com" or its alias name "pink@test.com". But I can only receive reply email to web1_pink@test.com. If the sender puts "pink@test.com" as recipient,I can't receive the email and the maillog looks like:

Dec 9 16:26:37 server1 postfix/smtpd[20380]: connect from webmsr1.webmail.hinet.net[61.220.15.201]
Dec 9 16:26:37 server1 postfix/smtpd[20380]: NOQUEUE: reject: RCPT from webmsr1.webmail.hinet.net[61.220.15.201]: 550 <pink@test.com>: Recipient address rejected: User unknown in local recipient table; from=<bytelib@ms2.hinet.net> to=<pink@test.com> proto=ESMTP helo=<webmsr1.webmail.hinet.net>
Dec 9 16:26:52 server1 postfix/smtpd[20380]: disconnect from webmsr1.webmail.hinet.net[61.220.15.201]
Dec 9 16:27:04 server1 ipop3d[20392]: pop3 service init from 127.0.0.1
Dec 9 16:27:04 server1 ipop3d[20392]: Login user=web1_pink host=server1.bytelib.com.tw [127.0.0.1] nmsgs=1/1
Dec 9 16:27:04 server1 ipop3d[20392]: Logout user=web1_pink host=server1.test.com [127.0.0.1] nmsgs=1 ndele=0

Should I install vm-pop3 instead of ipop3 to get the problem solved?
Reply With Quote
Sponsored Links
  #2  
Old 9th December 2005, 10:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Is pink@test.com in your /etc/postfix/virtusertable?

Do you have this line in your postfix main.cf?

virtual_maps = hash:/etc/postfix/virtusertable
Reply With Quote
  #3  
Old 9th December 2005, 13:38
rosa hsiao rosa hsiao is offline
Member
 
Join Date: Oct 2005
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till
Is pink@test.com in your /etc/postfix/virtusertable?

Do you have this line in your postfix main.cf?

virtual_maps = hash:/etc/postfix/virtusertable
Yes. I have the following lines in /etc/postfix/virtusertable:
web1_pink@test.com
pink@test.com
web1_pink@www.test.com
pink@www.test.com

And I have this line in main.cf:
virtual_maps = hash:/etc/postfix/virtusertable
Reply With Quote
  #4  
Old 9th December 2005, 15:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

And the domain test.com is in your /etc/postfix/local-host-names and you have this line in your main.cf too:

mydestination = /etc/postfix/local-host-names
Reply With Quote
  #5  
Old 10th December 2005, 01:56
rosa hsiao rosa hsiao is offline
Member
 
Join Date: Oct 2005
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till
And the domain test.com is in your /etc/postfix/local-host-names and you have this line in your main.cf too:

mydestination = /etc/postfix/local-host-names
The domain test.com is in my /etc/postfix/local-host-names and I find a line in main.cf:
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain, mail.$mydomain, www.$mydomain, ftp.$mydomain

So I change it to
mydestination = /etc/postfix/local-host-names

I will let you know if this will solve the problem.

I also have the following lines in main.cf:
alias_maps = hash:/etc/aliases
virtual_maps = hash:/etc/postfix/virtusertable
Reply With Quote
  #6  
Old 10th December 2005, 02:33
rosa hsiao rosa hsiao is offline
Member
 
Join Date: Oct 2005
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by rosa hsiao
The domain test.com is in my /etc/postfix/local-host-names and I find a line in main.cf:
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain, mail.$mydomain, www.$mydomain, ftp.$mydomain

So I change it to
mydestination = /etc/postfix/local-host-names

I will let you know if this will solve the problem.

I also have the following lines in main.cf:
alias_maps = hash:/etc/aliases
virtual_maps = hash:/etc/postfix/virtusertable
Finally I can receive emails for both web1_pink@test.com and alias email pink@test.com. I can send emails of other domain name such as web2_sale@test2.com. But I can't receive alias email for sale@test2.com.


Which parameter do I need to modify in main.cf ?

mynetworks = 127.0.0.0/8
or
mynetworks = 192.168.1.0/24 ???


mynetworks_style = subnet
or
mynetworks_style = host ???
Reply With Quote
  #7  
Old 10th December 2005, 13:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by rosa hsiao
Finally I can receive emails for both web1_pink@test.com and alias email pink@test.com. I can send emails of other domain name such as web2_sale@test2.com. But I can't receive alias email for sale@test2.com.
Is sale@test2.com in /etc/postfix/virtusertable? Is test2.com in /etc/postfix/local-host-names?


Quote:
Originally Posted by rosa hsiao
Which parameter do I need to modify in main.cf ?

mynetworks = 127.0.0.0/8
or
mynetworks = 192.168.1.0/24 ???


mynetworks_style = subnet
or
mynetworks_style = host ???
You don't have to change these parameters.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 11th December 2005, 09:52
rosa hsiao rosa hsiao is offline
Member
 
Join Date: Oct 2005
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
Is sale@test2.com in /etc/postfix/virtusertable? Is test2.com in /etc/postfix/local-host-names?
Yes. I have the following line in /etc/postfix/local-host-names:

web1_pink@www.test.com web1_pink
web1_pink@test.com web1_pink
pink@www.test.com web1_pink
pink@test.com web1_pink
web2_sale@www.test2.com web1_sale
web2_sale@test2.com web1_sale
sale@www.test2.com web1_sale
sale@test2.com web1_sale

I am using ipop3 daemon now. I also have installed vm-pop3,but not running it.


Quote:
Originally Posted by falko
You don't have to change these parameters.
In my main.cf I have the following lines:
#mynetworks_style = class
#mynetworks_style = subnet
#mynetworks_style = host
#mynetworks = 192.168.1.0/28, 127.0.0.0/8
#mynetworks = $config_directory/mynetworks
#mynetworks = hash:/etc/postfix/network_table

Do you mean that I can just leave them alone and don't bother to change or comment out any of those lines?
Reply With Quote
  #9  
Old 11th December 2005, 13:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by rosa hsiao
Yes. I have the following line in /etc/postfix/local-host-names:

web1_pink@www.test.com web1_pink
web1_pink@test.com web1_pink
pink@www.test.com web1_pink
pink@test.com web1_pink
web2_sale@www.test2.com web1_sale
web2_sale@test2.com web1_sale
sale@www.test2.com web1_sale
sale@test2.com web1_sale
These lines belong into /etc/postfix/virtusertable, not local-host-names!

Quote:
Originally Posted by rosa hsiao
I am using ipop3 daemon now. I also have installed vm-pop3,but not running it.
ipop3 uses mbox format, so make sure you disabled Maildir under Management -> Server -> Settings -> Email.



Quote:
Originally Posted by rosa hsiao
In my main.cf I have the following lines:
#mynetworks_style = class
#mynetworks_style = subnet
#mynetworks_style = host
#mynetworks = 192.168.1.0/28, 127.0.0.0/8
#mynetworks = $config_directory/mynetworks
#mynetworks = hash:/etc/postfix/network_table

Do you mean that I can just leave them alone and don't bother to change or comment out any of those lines?
Leave them unchanged for now.
I don't know if you've told us before, but what distribution do you use, and did you follow any of the "Perfect Setup" tutorials on HowtoForge?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 12th December 2005, 03:35
rosa hsiao rosa hsiao is offline
Member
 
Join Date: Oct 2005
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by falko
These lines belong into /etc/postfix/virtusertable, not local-host-names!
Sorry for the mistake! My local-host-names has the following lines:

www.test.com
test.com
www.test2.com
test2.com

Quote:
Originally Posted by falko

ipop3 uses mbox format, so make sure you disabled Maildir under Management -> Server -> Settings -> Email.
I have already disabled Maildir!


Quote:
Originally Posted by falko

Leave them unchanged for now.
I don't know if you've told us before, but what distribution do you use, and did you follow any of the "Perfect Setup" tutorials on HowtoForge?
I have follow the "Perfect Setup for Fedora Core 3" tutorials on HowtoForge.
The reason for not using Fedora Core 4 is because FC4 doesn't run some applications such as PHPBB2 very smoothly.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 01:56
Email problem skeeta Installation/Configuration 3 29th November 2005 17:54
Receiving Email and Username Problem dstme General 20 16th November 2005 09:33
Email sent to domain being rejected Lil'Brudder Installation/Configuration 9 25th October 2005 11:17
another problem, with email aliases.. SkIRmiS Installation/Configuration 3 27th September 2005 12:03


All times are GMT +2. The time now is 01:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.