Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th August 2012, 01:36
JESUSSAVES JESUSSAVES is offline
Member
 
Join Date: Sep 2011
Location: U.S.
Posts: 78
Thanks: 10
Thanked 5 Times in 4 Posts
Default new install Deb/ISPC3 and StartSSL

Hi,

I had obtained a class 1 certificate from StartSSL following howto on my previous Fedora ISPConfig3 installation.

Now I've changed to Debian 6 and ISPConfig3 following

perfect-server-debian-squeeze-with-bind-and-dovecot-ispconfig-3

and want to use my certificate again.

Can I do this? It is the same hardware but different OS so I think there may be a problem.

I tried at StartSSL.com to take out another certificate for the same FQDN but it wouldn't let me, said that e.g. server1.example.com certificate already exits.

It suggested that I either revoke my current certificate ($25) or apply for a class 2 certificate.

Can I use my existing certificate? I need to get rid of the browser cert warnings. Can I go to a class 2 without having to revoke my class 1?

Could someone please point in the best direction? Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 28th August 2012, 09:04
cfoe cfoe is offline
ISPConfig Developer
 
Join Date: Oct 2011
Location: NRW, Germany
Posts: 233
Thanks: 27
Thanked 57 Times in 32 Posts
Send a message via Skype™ to cfoe
Default

The cert is not bound to hardware or OS.
You can use the "old" cert on the new installation.

I am not totally sure but I think you do not need to revoke the class1 cert (server1.example.com) if you register the class2 cert with a wildcard (*.example.com).

The class2 cert you can use on all you machines like server1.example.com, server2.example.com ....
__________________
Christian Foellmann

OpenSource-Projects - GitHub-Projects - SVN-Mirrors on GitHub - Foe Services
Reply With Quote
  #3  
Old 28th August 2012, 18:33
JESUSSAVES JESUSSAVES is offline
Member
 
Join Date: Sep 2011
Location: U.S.
Posts: 78
Thanks: 10
Thanked 5 Times in 4 Posts
Default

Thank you for your response.

Perhaps I did something wrong but I tried to paste my existing cert into the
/usr/local/ispconfig/interface/ssl/ispserver.crt file and continued with the howto

securing-your-ispconfig-3-installation-with-a-free-class1-ssl-certificate-from-startssl

from that point forward. But when it came to restarting apache it got an error.

Perhaps I should try it again.
Reply With Quote
  #4  
Old 29th August 2012, 09:15
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,976
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

If you use a existing cert, then you have to replace the key as well as key and cert file belong together and apache will not start when ou use the wrong ky for the cert.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
JESUSSAVES (29th August 2012)
  #5  
Old 29th August 2012, 14:54
JESUSSAVES JESUSSAVES is offline
Member
 
Join Date: Sep 2011
Location: U.S.
Posts: 78
Thanks: 10
Thanked 5 Times in 4 Posts
Default

I see, I don't have the original key (I've only saved the crt), so I can't reuse my existing cert without it.

Thank you Till! I know what to do from here. Thanks again.
Reply With Quote
  #6  
Old 29th August 2012, 15:27
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,976
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

Quote:
I see, I don't have the original key (I've only saved the crt), so I can't reuse my existing cert without it.
Most SSL authoritys offer to reissue a cert free of charge if the key is lost.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
JESUSSAVES (30th August 2012)
  #7  
Old 30th August 2012, 02:23
JESUSSAVES JESUSSAVES is offline
Member
 
Join Date: Sep 2011
Location: U.S.
Posts: 78
Thanks: 10
Thanked 5 Times in 4 Posts
 
Default

Thanks again, I'll check into it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NEW INSTALL WORKS GREAT BUT a few issues webwork Installation/Configuration 4 18th April 2008 20:58
Database Empty After Install ollietrex Installation/Configuration 8 1st February 2008 19:03
Login Failure after Install ds0101 Installation/Configuration 6 19th December 2007 08:00
After install error(s) by starting ISPconfig BvO Installation/Configuration 4 14th January 2007 15:17
ISPConfig install error clabrown Installation/Configuration 6 4th January 2007 16:46


All times are GMT +2. The time now is 20:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.