Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd August 2012, 23:09
fireshard fireshard is offline
Junior Member
 
Join Date: Aug 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ftp Passwords not working

Hello,

I've recently installed ISPConfig 3.0.4.6 on an Ubuntu virtual server and it says that all services are working in the monitor tab of ISPConfig, but when I created an ftp account and tried to logon with Filezilla, it told me the password was incorrect and I check if it was the wrong password, but it is not, does anyone know how to fix this issue ?

Thank you in advance.

Text from Filezilla, with hostname and IP removed.
Status: Resolving address of hostname.domain.tld
Status: Connecting to *.*.*.*:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 20:39. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER creatures_wsftp
Response: 331 User creatures_wsftp OK. Password required
Command: PASS ********
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server
Reply With Quote
Sponsored Links
  #2  
Old 23rd August 2012, 00:25
yuro yuro is offline
Junior Member
 
Join Date: Jun 2008
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I'm having the same problem as well. Same scenario too. Ubuntu VM, fresh install.
Reply With Quote
  #3  
Old 23rd August 2012, 10:12
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 262 Times in 208 Posts
Default

Please have a look in the server logs (ftp-server log, syslog, auth.log) if there are any messages during login try.
__________________
Marius Cramer

pixcept KG
Reply With Quote
The Following User Says Thank You to Croydon For This Useful Post:
yuro (26th August 2012)
  #4  
Old 25th August 2012, 01:03
yuro yuro is offline
Junior Member
 
Join Date: Jun 2008
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default from /var/log/auth.log

Here's what seems to be the issue. Seems Jailkit is the problem, but not sure what to do.

from /var/log/auth.log
Code:
Aug 24 14:55:30 server1 sshd[3760]: Accepted password for [client_user] from 192.168.0.24 port 53909 ssh2
Aug 24 14:55:30 server1 sshd[3760]: pam_unix(sshd:session): session opened for user [client_user] by (uid=0)
Aug 24 14:55:31 server1 sshd[3878]: subsystem request for sftp by user [client_user]
Aug 24 14:55:31 server1 jk_chrootsh[3879]: now entering jail /var/www/clients/client1/web1 for user [client_user] (5004) with arguments -c /usr/lib/openssh/sftp-server
Aug 24 14:55:31 server1 sshd[3760]: pam_unix(sshd:session): session closed for user [client_user]
Reply With Quote
  #5  
Old 25th August 2012, 05:22
yuro yuro is offline
Junior Member
 
Join Date: Jun 2008
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Fixed. Was a problem with Jailkit.

Found the solution in the developers forum:
http://www.howtoforge.com/forums/sho...4&postcount=12

I can now use SFTP with Coda for my sites with jailkit securely.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ftp not working :( bernholdt General 1 19th February 2010 11:24
Slow download from own FTP (vsftpd + proftpd) Overcrook Installation/Configuration 0 12th January 2010 22:41
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 20:38
Cannot connect to anonymus ftp n1kol1s Installation/Configuration 39 15th February 2007 19:36
After Install: Mail not working and FTP strange Raffnix Installation/Configuration 24 8th January 2007 16:51


All times are GMT +2. The time now is 09:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.