#1  
Old 16th August 2012, 03:36
bscottMD bscottMD is offline
Junior Member
 
Join Date: Aug 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix / Dovecot

I am having some issues configuring outlook to work with postfix / dovecot.

I can receive mail to the domain but cannot send.

I have done the following:

email account setup using the following:

Code:
IMAP

Incoming mail server: mail.domain.com
outgoing mail server: mail.domain.com

SPA (Unchecked)

More Settings: Outgoing Server

Authentication (Unchecked)
Test results say: Completed

However when sending mail I get:

Code:
The following recipient(s) cannot be reached:

      'name@domain.com' on 8/15/2012 7:10 PM
            554 5.7.1 <name@domain.com>: Relay access denied
Now with the "My outgoing server (SMTP) requires authentication checked with "Use the same settings......" checked the test asks for my credentials which I have tried both username and username@domain.com (both reject)

telnet replies:

Code:
220 PostfixMail ESMTP Postfix (Ubuntu)
ehlo domain.com
250-PostfixMail
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH GSSAPI DIGEST-MD5 CRAM-MD5 NTLM PLAIN LOGIN ANONYMOUS
250-AUTH=GSSAPI DIGEST-MD5 CRAM-MD5 NTLM PLAIN LOGIN ANONYMOUS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
Any thoughts?
Reply With Quote
Sponsored Links
  #2  
Old 16th August 2012, 03:38
bscottMD bscottMD is offline
Junior Member
 
Join Date: Aug 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Addition:

main.cf
Code:
#See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = PostfixMail, localhost, mdoor.com, localhost.localdomain, ubuntufileserver, postfixmail.domain.com
mynetworks = 127.0.0.0/8, 172.16.16.0/20
mailbox_size_limit = 0
recipient_delimiter = +
inet_protocols = all
inet_portocols = IPv4
home_mailbox = Maildir/
myhostname = PostfixMail
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated permit_inet_interfaces reject_unauth_destination check_relay_domains
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = 
broken_sasl_auth_clients = yes
fallback_relay =
Reply With Quote
  #3  
Old 16th August 2012, 11:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Are there any errors in your mail log (in the /var/log/ directory)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 16th August 2012, 14:36
bscottMD bscottMD is offline
Junior Member
 
Join Date: Aug 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

/var/log/mail.err.1

Code:
Aug 15 19:03:34 postfixmail postfix/smtpd[29239]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
Reply With Quote
  #5  
Old 17th August 2012, 00:47
bscottMD bscottMD is offline
Junior Member
 
Join Date: Aug 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
220 PostfixMail ESMTP Postfix (Ubuntu)
ehlo mdoor.com
250-PostfixMail
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH GSSAPI DIGEST-MD5 CRAM-MD5 NTLM PLAIN LOGIN ANONYMOUS
250-AUTH=GSSAPI DIGEST-MD5 CRAM-MD5 NTLM PLAIN LOGIN ANONYMOUS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
mail from:test@test.com
250 2.1.0 Ok
rcpt to name@domain.com
501 5.5.4 Syntax: RCPT TO:<address>
RCPT TO:name@domain.com
250 2.1.5 Ok
data
354 Please start mail input.
TEST
.
250 Mail queued for delivery.
quit
221 Closing connection. Good bye.
Reply With Quote
  #6  
Old 18th August 2012, 00:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by bscottMD View Post
/var/log/mail.err.1

Code:
Aug 15 19:03:34 postfixmail postfix/smtpd[29239]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
Strange... Your smtpd_recipient_restrictions seems to be ok...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 18th August 2012, 22:25
tahunasky tahunasky is offline
Member
 
Join Date: Jul 2012
Location: Buenos Aires
Posts: 84
Thanks: 1
Thanked 8 Times in 8 Posts
 
Default

This is what i have in my postfix/main.cf file:

Code:
mydomain = domain.com
myhostname = tui.$mydomain
mydestination = $myhostname, mail.$mydomain, localhost, localhost.localdomain
mynetworks = 127.0.0.0/8, 10.0.0.0/24, localhost
myorigin = $myhostname


smtpd_sender_restrictions = reject_unknown_address
smtpd_recipient_restrictions =  
    permit_mynetworks, 
    permit_sasl_authenticated, 
    reject_unauth_destination
    reject_invalid_hostname, 
    reject_unauth_pipelining, 
    reject_non_fqdn_sender, 
    reject_non_fqdn_recipient, 
    reject_unknown_sender_domain, 
    reject_unknown_recipient_domain, 
    reject_rbl_client zen.spamhaus.org,
    permit

Last edited by tahunasky; 18th August 2012 at 22:29.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 won't start after update Cracklefish Installation/Configuration 15 28th February 2012 14:11
Postfix SMTP Auth to Dovecot Not Working -- HELP! Scratchpad Server Operation 6 12th April 2011 13:29
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
Postfix can't received email from exterior astra2000 Server Operation 5 17th October 2009 23:26
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47


All times are GMT +2. The time now is 02:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.