Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 14th August 2012, 18:58
Wsbs9GC Wsbs9GC is offline
Member
 
Join Date: Aug 2012
Posts: 36
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Interesting that it wouldn't be listening on port 25. I did have to set it up for port 587 due to my ISP not allowing mail out on port 25 if that has any relevance. I followed this guide for that http://www.justatheory.com/computers...d-comcast.html. Here's postconf -n:
Quote:
alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
append_dot_mydomain = no
biff = no
body_checks = regexp:/etc/postfix/body_checks
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
dovecot_destination_recipient_limit = 1
header_checks = regexp:/etc/postfix/header_checks
html_directory = /usr/share/doc/postfix/html
inet_interfaces = all
mailbox_size_limit = 0
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
message_size_limit = 0
mime_header_checks = regexp:/etc/postfix/mime_header_checks
mydestination = www.quantumcooler.net, localhost, localhost.localdomain
myhostname = www.quantumcooler.net
mynetworks = 127.0.0.0/8 [::1]/128
myorigin = /etc/mailname
nested_header_checks = regexp:/etc/postfix/nested_header_checks
owner_request_special = no
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
readme_directory = /usr/share/doc/postfix
receive_override_options = no_address_mappings
recipient_delimiter = +
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
relayhost = [smtp.comcast.net]:587
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl/passwd
smtp_sasl_security_options =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_client_message_rate_limit = 100
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,reject _unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_path = private/auth
smtpd_sasl_type = dovecot
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_transport = dovecot
virtual_uid_maps = static:5000
postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
Reply With Quote
Sponsored Links
  #12  
Old 14th August 2012, 19:15
Sir Henry Sir Henry is offline
Member
 
Join Date: Jan 2012
Posts: 51
Thanks: 0
Thanked 5 Times in 5 Posts
Default

You are mixing up two things. If you want the Comcast server to relay your mail via its port 587 you do not need to exclude port 25 on your own server.

Anyway your settings look ok so far, and we need to find out if Postfix is listening at all, and on which port.

Please post the output of:
Code:
netstat -l | grep smtp
and
Code:
netstat -l | grep subm
__________________
Cheers, Sir Henry
Reply With Quote
  #13  
Old 14th August 2012, 21:38
Wsbs9GC Wsbs9GC is offline
Member
 
Join Date: Aug 2012
Posts: 36
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Sorry for getting the two mixed up. As I said in my original post, I'm new to linux and server administration so my knowledge on server daemons is limited to say the least.

netstat -l | grep smtp:
Quote:
tcp 0 0 *:smtp *:* LISTEN
tcp6 0 0 [::]:smtp [::]:* LISTEN
unix 2 [ ACC ] STREAM LISTENING 10413 private/smtp
unix 2 [ ACC ] STREAM LISTENING 10455 private/bsmtp
The output of netstat -l | grep subm was empty.
Reply With Quote
  #14  
Old 14th August 2012, 21:59
Sir Henry Sir Henry is offline
Member
 
Join Date: Jan 2012
Posts: 51
Thanks: 0
Thanked 5 Times in 5 Posts
Default

Ok, are you sure you have selected port 25 in Thunderbird, Outgoing Server settings ?

Alternatively, enable port 587 in Postfix by editing master.cf as described e.g. here.
__________________
Cheers, Sir Henry

Last edited by Sir Henry; 14th August 2012 at 22:06.
Reply With Quote
The Following User Says Thank You to Sir Henry For This Useful Post:
Wsbs9GC (15th August 2012)
  #15  
Old 15th August 2012, 02:39
Wsbs9GC Wsbs9GC is offline
Member
 
Join Date: Aug 2012
Posts: 36
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Wow! Thank you so much Sir Henry! I tried sending on port 25 and it worked and I enabled submission on 587 and it worked there. Thank you for the support. Just one thing, can you summarize what the problem was for me? What I gather is that postfix wasn't able to accept email submissions on port 587 by default so my connections from thunderbird were being dropped by postfix. Is this correct?
Reply With Quote
  #16  
Old 15th August 2012, 11:40
Sir Henry Sir Henry is offline
Member
 
Join Date: Jan 2012
Posts: 51
Thanks: 0
Thanked 5 Times in 5 Posts
 
Default

Well, it's great that I could help you in the end. Better specialists would have spotted your problem straight after your first post; I just needed a bit longer.
__________________
Cheers, Sir Henry
Reply With Quote
Reply

Bookmarks

Tags
dovecot, postfix, sending mail

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Catchall and Forwarding not working simmo General 6 22nd March 2014 00:54
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
How cai remove amavis from postfix ? gabrix Server Operation 16 2nd October 2012 09:58
Email being accepted but not delivered punto Installation/Configuration 8 25th May 2011 00:13
sneaking suspicion my postfix config has gone awry mjbarfoot Installation/Configuration 7 24th August 2010 12:23


All times are GMT +2. The time now is 09:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.