Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd August 2012, 10:37
malak33 malak33 is offline
Junior Member
 
Join Date: Aug 2012
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default CentOS owncloud setup issues

m trying to setup owncloud on a virtualbox. I am using the tutorial on http://www.howtoforge.com/your-cloud...-on-centos-6.2

i have gotten to the end of the tutorial and when i try to get to the webpage using elinks the error i get says "Unable to retrieve https://owncloud.example.com/: SSL error

i would appreciate any help at all if you need any more information or any have questions let me know.

i have even deleted all the certs and gone through that section of the walkthrough again. No luck...
Reply With Quote
Sponsored Links
  #2  
Old 4th August 2012, 10:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Are there any errors in the nginx error log?

Can you disable SSL and let the ownCloud vhost listen on port 80? Does it work then?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th August 2012, 18:23
malak33 malak33 is offline
Junior Member
 
Join Date: Aug 2012
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default

i was having trouble getting the nginx error log to my host machine. So i just screen shot it and hosted it on imgur here http://imgur.com/gVMIX

also i'm still pretty green if you could tell me how to switch the owncloud vhost to listen to port 80 instead i would be happy to try that out. along with disabling SSL.

Thanks again
Reply With Quote
  #4  
Old 5th August 2012, 19:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

It seems as if the owncloud directory /usr/share/nginx/html/owncloud does not exist.

Quote:
also i'm still pretty green if you could tell me how to switch the owncloud vhost to listen to port 80 instead i would be happy to try that out. along with disabling SSL.
Can you post your vhost configuration?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th August 2012, 03:26
malak33 malak33 is offline
Junior Member
 
Join Date: Aug 2012
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default

something tells me that this is wrong. but here is the config i have in /etc/hosts

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
#this is for owncloud
192.168.1.100 owncloud.example.com

also if i turn off iptables and navigate to
http://localhost/
the nginx default webpage loads
not sure if that helps at all.

if that is not the file you are talking about let me know...

Last edited by malak33; 8th August 2012 at 03:32.
Reply With Quote
  #6  
Old 8th August 2012, 14:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by malak33 View Post
if that is not the file you are talking about let me know...
I need the nginx configuration of your owncloud site.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
malak33 (9th August 2012)
  #7  
Old 9th August 2012, 05:01
malak33 malak33 is offline
Junior Member
 
Join Date: Aug 2012
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default

so you mean the file you need is
/etc/nginx/nginx.conf
correct?
or do you want /etc/nginx/conf.d/owncloud.conf???

I'm guessing you want the first one?
correct?
here is the url for the image gallery
http://imgur.com/a/9Wglz

i also moved all the .conf's in the /etc/nginx/conf.d/ directory to a backup directory i made
i kept owncloud.conf and restarted nginx
still the same error

also i did not make the directory /usr/share/nginx/html/owncloud
am i supposed to?
thanks again.

Last edited by malak33; 9th August 2012 at 05:12. Reason: i'm an idiot
Reply With Quote
  #8  
Old 9th August 2012, 15:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by malak33 View Post
so you mean the file you need is
/etc/nginx/nginx.conf
correct?
or do you want /etc/nginx/conf.d/owncloud.conf???
Can you post the contents of both files here (as text, not images)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 10th August 2012, 02:03
malak33 malak33 is offline
Junior Member
 
Join Date: Aug 2012
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default

here is /etc/gninx/nginx.conf

user nginx;
worker_processes 1;

error_log /var/log/nginx/error.log;
#error_log /var/log/nginx/error.log notice;
#error_log /var/log/nginx/error.log info;

pid /var/run/nginx.pid;

events {
worker_connections 1024
}

http {
include /etc/nginx/mime.types;
default_type application/octet-stream;

log_format main '$remote_addr - $remote_user [$time_local] "$request"'
'$status $body_bytes_sent "$http_referer"'
'"$http_user_agent" "$http_x_forwarded_for"';

access_log /var/log/nginx/access.log main;

sendfile on;
#tcp_nopush on;

#keepalive_timeout 0;
keepalive_timeout 65;

#gzip on;

#loadconfig files from the /etc/nginx/conf.d directory
#The default server is in conf.d/default.conf
inclue /etc/nginx/conf.d/*.conf/

}


here is the /etc/nginx/conf.d/owncloud.conf

#redirect http to https.
server {
listen 80;
server_name owncloud.example.com;
rewrite ^ https://$server_name$request_url? permanent; #enforce https
}
#owncloud (ssl/tls)
server {
listen 443 ssl;
ssl_certificate /etc/nginx/certs/server.crt;
ssl_certificate_key /etc/nginx/certs/server.key;
server_name owncloud.example.com;
root /var/www/owncloud;
index index.php;
client_max_body_size 64M; #set maximum upload size
#deny direct access
location ~ ^/(data|config|\.ht|db_structure\.xml|README) {
deny all;
}
#default try order
location / {
try_files $uri $url/ @webdav;
}
#owncloud WEBDAV
location @webdav {
fastcgi_split_path_info ^(.+\.php)(/.*)$;
fastcgi_pass unix:/var/run/php-fpm/php-fpm.sock'
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param HTTPS on;
include fastcgi_params;
}
#enable php
location ~\.php$ {
fastcgi_pass unix:/var/run/php-fpm/php-fpm-sock;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param HTTPS on;
include fastcgi_params;
}
}

that is both of the files; thanks for the help
Reply With Quote
  #10  
Old 10th August 2012, 12:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Modify /etc/nginx/conf.d/owncloud.conf as follows and reload nginx:
Code:
#redirect http to https.
#server {
#listen 80;
#server_name owncloud.example.com;
#rewrite ^ https://$server_name$request_url? permanent; #enforce https
#}
#owncloud (ssl/tls)
server {
#listen 443 ssl;
#ssl_certificate /etc/nginx/certs/server.crt;
#ssl_certificate_key /etc/nginx/certs/server.key;
listen 80;

server_name owncloud.example.com;
root /var/www/owncloud;
index index.php;
client_max_body_size 64M; #set maximum upload size
#deny direct access
location ~ ^/(data|config|\.ht|db_structure\.xml|README) {
deny all;
}
#default try order
location / {
try_files $uri $url/ @webdav;
}
#owncloud WEBDAV
location @webdav {
fastcgi_split_path_info ^(.+\.php)(/.*)$;
fastcgi_pass unix:/var/run/php-fpm/php-fpm.sock'
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param HTTPS on;
include fastcgi_params;
}
#enable php
location ~\.php$ {
fastcgi_pass unix:/var/run/php-fpm/php-fpm-sock;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param HTTPS on;
include fastcgi_params;
}
}
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
malak33 (11th August 2012)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect Server - CentOS 5.5 x86_64 [ISPConfig 3] - Issues Aradan Server Operation 6 11th July 2010 02:38
Chrome + Ubuntu + Flash player andor Desktop Operation 1 25th May 2010 16:59
Multiple Issues on A multi-Server setup centosarus General 2 29th March 2010 06:02
The Perfect Setup - SuSE 10.1 (32-bit) - Qouta Issues ? ezfilez HOWTO-Related Questions 3 26th September 2006 18:09
The Perfect Setup - CentOS 4.3 (64-bit) - Flex Missing d3m0nic HOWTO-Related Questions 1 20th April 2006 11:39


All times are GMT +2. The time now is 02:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.