#1  
Old 31st July 2012, 16:14
dbriggs dbriggs is offline
Junior Member
 
Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Install on Second Server

I attempted to install ISPconfig 3 on a second server. Every thing appeared to run fine at first. Then I noticed my system memory was being eaten up. After a while I start seeing errors on the system console for out of memory. ISP config runs great if its standalone. If its runs as a secondary it dies due to memory faults. It looks like a memory leak.
Reply With Quote
Sponsored Links
  #2  
Old 31st July 2012, 18:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

There are no known problems with multiserver setups and the slave server setup is identical to the master one, so if there would be a memory leak, then you would see it on your master as well. The reason for your problem is most likely a configuration issue on the second server that causes the ispconfig server process to die. Take a look at the debugging instructions in the faq:

http://www.faqforge.com/linux/debugg...-of-a-failure/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd August 2012, 00:29
dbriggs dbriggs is offline
Junior Member
 
Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the input, Particular the link to stopping cron job and running it manually. The problem was that the mysql user names and permmisions where not set currently, once I fixed this it ran just perfect.
Reply With Quote
  #4  
Old 2nd August 2012, 09:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
 
Default

Quote:
The problem was that the mysql user names and permmisions where not set currently, once I fixed this it ran just perfect.
This happens when the /etc/hosts file on master and slave are not exactly as described in the tutorial. Common mistakes are that not all servers of the clusters are configured there or that the file contains lines that contain maore names then the fqdn of the nodes. Examples:

Wrong:

192.168.0.1 server1 server1.domain.tld

Correct:

192.168.0.1 server1.domain.tld

With the wrong entry, mysql will not be able to authenticate the slave.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 20:02
php Apps email not going through palkat General 8 21st September 2011 06:35
Some problems after upgrade OS lenny to squeeze matiasCU Installation/Configuration 3 31st May 2011 23:53
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
Companion Script #2 for The Perfect Server - Fedora 13 x86_64 [ISPConfig 3]" MrCompTech Tips/Tricks/Mods 0 10th July 2010 06:11


All times are GMT +2. The time now is 04:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.