#1  
Old 16th May 2013, 12:58
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 150
Thanks: 27
Thanked 15 Times in 10 Posts
Default phpmyadmin uploads do not work

Hello,

I have a problem with phpmyadmin uploads. Whenever I try to upload database scripts I get the following error:
"Es wurden keinen Daten zum importieren empfangen. Entweder wurde keine Datei ausgewählt, oder die Dateigröße hat die maximal erlaubte Größe der PHP Konfiguration überschritten. Siehe FAQ 1.16."

I have tried every hint of the FAQ 1.16, and also read and applied a lot of hints from posts of people having similar problems, but to no avail.
I can state that it is NOT a problem of the upload size, for I have tried upload with a 4kB file and my upload limit is 38M, as shown by phpmyadmin itself.

In the phpmyadmin configuration no upload directory is set, and no upload_tmp_dir is specified in the php.ini either; I am not sure if this is correct. Could anybody tell me please?

When I use bigger files, the upload seems to take place and I get the error afterwards. So I thought it might be a permissions problem; The upload perhaps goes to some directory where phpmyadmin has no permission to read.

The system is: Debian Squeeze, Mysql 5.1.66-0+squeeze1, Apache 2.2.16, PHP 5.3.3-7+squeeze15, Ispconfig 3.0.5.1

Does anybody have an idea?

regards, Tom
Reply With Quote
Sponsored Links
  #2  
Old 17th May 2013, 21:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

What are the values of post_max_size and upload_max_filesize in /etc/php5/apache2/php.ini?

Are there any errors in Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
teves (24th May 2013)
  #3  
Old 19th May 2013, 19:20
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 150
Thanks: 27
Thanked 15 Times in 10 Posts
Default

Hello,

the values are:
post_max_size = 40MB
upload_max_filesize = 38MB

There are no errors in /var/log/apache2/error.log


Regards, Tom
Reply With Quote
  #4  
Old 23rd May 2013, 13:04
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
Default

I had some similar symptoms a while back on one of my installs even when max upload size statements were good.

Turned out that while the file HTTP(S) upload occured correctly, phpmyadmin was trying to process the file as a "LOAD DATA INFILE" statement.

From memory there's a global permission to set to allow the specified user to perform INFILE commands.

Wonder if you're seeing similar?
Reply With Quote
The Following User Says Thank You to monkfish For This Useful Post:
teves (24th May 2013)
  #5  
Old 24th May 2013, 16:54
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 150
Thanks: 27
Thanked 15 Times in 10 Posts
Default

That does not seem to be the case.

Setting the upload directory does not help either. I have no clue...

Can I just re-install phpmyadmin? How would I do that without harming the configuration of the Server?

Regards, Tom
Reply With Quote
  #6  
Old 26th May 2013, 11:52
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
Default

You can indeed reinstall phpmyadmin at any time you like. Should not affect the rest of the services.

If you suspect its your phpmyadmin install, you could use a second deployment to test - why not add a virtual host to your dns and ispconfig as a separate website, and deploy phpmyadmin into there.

For example, phptools.yourdomain.com

- add A host dns entries pointing to your server
- create ispconfig webiste site for domain
- download phpmyadmin and unpack to web folder, set file permissions as necessary
- run install script to generate config file and save
- access that copy of phpmyadmin by http(s)://phptools.yourdomain.com
- perhaps if you wanted simple added security password protect the folder you put it in.

If that installation works, you've got a problem with the original and you could compare things like config files, permissions, etc. If it doesnt work you might have another issue manifesting itself.
You can wipe the virtual site once you've completed your testing.

My 0.02
Reply With Quote
  #7  
Old 30th May 2013, 03:42
bch bch is offline
Junior Member
 
Join Date: Feb 2013
Posts: 12
Thanks: 1
Thanked 2 Times in 2 Posts
 
Default

I'm not 100% sure if it matters, but the proper way of declaring the size in megabytes is by using "M" and not "MB", according to http://www.php.net/manual/en/ini.core.php.

post_max_size = 40M
upload_max_filesize = 38M
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
phpmyadmin is 404 file not found CSU-Bill Server Operation 11 13th March 2011 19:53
PHPMyadmin not work thenicespider Installation/Configuration 26 11th October 2010 15:59
drupal, phpmyadmin and localhost: drupal installation blesbok Server Operation 7 8th October 2008 10:46
phpMyAdmin goes PHP5 & MySQL5 Hans General 5 28th September 2008 21:46
phpMyAdmin question? ctroyp Installation/Configuration 1 21st March 2006 00:19


All times are GMT +2. The time now is 13:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.