Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd July 2012, 18:30
mroppolo mroppolo is offline
Junior Member
 
Join Date: Jan 2010
Posts: 22
Thanks: 2
Thanked 0 Times in 0 Posts
Default ISPConfig Configuration For SquirrelMail To Run Under SSL

Hello all -

I'm finalizing my Debian Squeeze installation using "The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Dovecot [ISPConfig 3]" (instructions by Falco).

My problem is configuring SquirrelMail to run under SSL as a subdomained site in ISPConfig:

I have configured 2 websites:
/var/www/clients/client0/www/web1 is for www.myurl.com
/var/www/clients/client0/www/web2 is for mail.myurl.com

I first created a new site in ISPConfig, then manually installed SquirrelMail in the ../www/web2 directory.
http://mail.myurl.com --> works !
https://mail.myurl.com --> displays the default ISPConfig Home page

Any help would be appreciated !

Thanks !
Reply With Quote
Sponsored Links
  #2  
Old 23rd July 2012, 17:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Did you create a ssl cert in the website mail.myurl.com and is ssl enabled for that site? Also ensure that you selcted the IP address in the ipv4 field and not * for both websites.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 23rd July 2012, 17:37
mroppolo mroppolo is offline
Junior Member
 
Join Date: Jan 2010
Posts: 22
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

I discovered that I didn't enable SSL on the mail website. Mea culpa !

The only other change I made was modifying the header command in the index.php page to this:
header('Location: ./src/login.php'); // added "./" so the reference is correct.

One final related question: Now all subdomain references go to my mail website. ie:

http://www1.mysite.com --> redirects to http://mail.mysite.com
http://junk.mysite.com --> redirects to http://mail.mysite.com
http://mysite.com --> redirects to http://mail.mysite.com

I'd like them to redirect to my main website http://www.mysite.com

Can anyone provide some assistance ?

Thanks !

Last edited by mroppolo; 24th July 2012 at 03:01.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
haproxy with stunnel problem abubin Server Operation 6 10th April 2012 15:08
Hosting multiple websites and webmail dmwcool Installation/Configuration 8 30th March 2010 03:15
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
SSL Cert Question for ISPConfig Access giganet Installation/Configuration 33 28th March 2009 07:56
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15


All times are GMT +2. The time now is 20:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.