Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th April 2006, 10:31
HoUsECAt HoUsECAt is offline
Member
 
Join Date: Mar 2006
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default created_partsdir FAILED

hi all...

great tutorial on virtual postfix tutorial ... it all works great and mail gets delivered and scanned ....

Only even now and then a message appears in mail.log and amavisd.log like:

Code:
Apr 14 10:09:57 adam amavisd-new[18705]: (18705-07) lookup_sql: 2013, Lost connection to MySQL server during query
Apr 14 10:09:57 adam amavisd-new[18705]: (18705-07) NOTICE: Disconnected from SQL server
Apr 14 10:09:57 adam amavisd-new[18705]: (18705-07) TROUBLE in check_mail: creating_partsdir FAILED: DBD::mysql::st execute failed: Lost connection to MySQL server during query at (eval 41) line 238, <GEN16> line 2855.
Apr 14 10:09:57 adam amavisd-new[18705]: (18705-07) PRESERVING EVIDENCE in /var/lib/amavis/amavis-20060413T084946-18705
this particular mail got in the mailq and when i requed it, it got delivered. Any ideas what this can be?
Reply With Quote
Sponsored Links
  #2  
Old 14th April 2006, 14:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

You can tryto remove all the proxy: strings in /etc/postfix/main.cf, e.g. replace

Code:
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
with
Code:
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
and do the same for all other lines with proxy:
Restart Postfix afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 14th April 2006, 14:21
HoUsECAt HoUsECAt is offline
Member
 
Join Date: Mar 2006
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default

thanks.. i wil test that... can you explain to me what proxy: does?
Reply With Quote
  #4  
Old 14th April 2006, 15:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

If you use proxy:, then Postfix uses only one persistent MySQL connection; if you don't use it, Postfix creates a new connection everytime.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 14th April 2006, 15:11
HoUsECAt HoUsECAt is offline
Member
 
Join Date: Mar 2006
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default

which can't hurt much in a small business server?
Reply With Quote
  #6  
Old 15th April 2006, 15:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Unless you're running a high-traffic mail server, it doesn't matter at all.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 20th April 2006, 09:04
HoUsECAt HoUsECAt is offline
Member
 
Join Date: Mar 2006
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default

this morning i again saw the error message again

Code:
Apr 20 08:59:23 adam amavisd-new[2374]: (02374-04) lookup_sql: 2013, Lost connection to MySQL server during query
Apr 20 08:59:23 adam amavisd-new[2374]: (02374-04) NOTICE: Disconnected from SQL server
Apr 20 08:59:23 adam amavisd-new[2374]: (02374-04) TROUBLE in check_mail: creating_partsdir FAILED: DBD::mysql::st execute failed: Lost connection to MySQL adam during query at (eval 41) line 238, <GEN16> line 2833.
Apr 20 08:59:23 adam amavisd-new[2374]: (02374-04) PRESERVING EVIDENCE in /var/lib/amavis/amavis-20060419T160329-02374
this mail also appears in the mailq, and i have to requeue it.....

any ideas?
Reply With Quote
  #8  
Old 20th April 2006, 17:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Seems to be a problem with amavisd. Maybe a bug?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 20th April 2006, 18:25
HoUsECAt HoUsECAt is offline
Member
 
Join Date: Mar 2006
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default

alright... thanks... i will go and try to gather some information with amavisd....

will keep you posted
Reply With Quote
  #10  
Old 4th May 2006, 10:15
HoUsECAt HoUsECAt is offline
Member
 
Join Date: Mar 2006
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

i figured out a little bit what the cause is, I haven't got a very busy mailserver and it mostly happens in the night, due the 'inactivitiy' of amavisd it loses the connection to the database. When i restart amavisd it is solved.

so i can solve this by a cron restart of amavisd, but for now i'm happy as it is
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 11:30
imap and pop connection failed (debian sarge) ayolo Installation/Configuration 3 30th January 2006 16:19
Problems with postfix-mysql Pelle Installation/Configuration 39 13th November 2005 23:25
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 11:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.