#1  
Old 14th September 2005, 14:34
n2s n2s is offline
Junior Member
 
Join Date: Sep 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Question Mail Probs

Hi there,

I'm new here, I installed Suse 9.3 with the The Perfect Setup guide and it worked out quite well (reading the forum, thanx ).
Unfortunately I still have two problems left regarding postfix.

It's not possible to send mail over a SMTP-SSL connection (receiving works fine), I always get warnings in the log (not sure that's the reason):

postfix/smtpd[18593]: warning: connect to private/tlsmgr: Connection refused
postfix/smtpd[18593]: warning: problem talking to server private/tlsmgr: Connection refused
postfix/smtpd[18593]: warning: connect to private/tlsmgr: Connection refused
postfix/smtpd[18593]: warning: problem talking to server private/tlsmgr: Connection refused
postfix/smtpd[18593]: warning: no entropy for TLS key generation: disabling TLS support


Second, I can't receive mails. The mails are always returned with the message:

Final-Recipient: RFC822; xxx@yyyyyyyyy.yy
Action: failed
Status: 5.0.0
Remote-MTA: DNS; yyyyyyyyy.yy
Diagnostic-Code: SMTP; 554 <xxx@yyyyyyyyy.yy>: Recipient address rejected: Access denied
Last-Attempt-Date: Wed, 14 Sep 2005 13:48:08 +0200 (MEST)


Producing the following log entries:

postfix/smtpd[18593]: connect from natfrord.rzone.de[81.169.145.161]
postfix/smtpd[18593]: NOQUEUE: reject: RCPT from natfrord.rzone.de[81.169.145.161]: 554 <xxx@yyyyyyyyy.yy>: Recipient address rejected: Access denied; from=<zzzzzz@zzzzzzz.zz> to=<xxx@yyyyyyyyy.yy> proto=ESMTP helo=<natfrord.rzone.de>
disconnect from natfrord.rzone.de[81.169.145.161]


The domains appears in /etc/postfix/local-host-names, and /etc/postfix/local-host-names seems ok, too.

Any idea why this is happening?

Regards,
n2s
Reply With Quote
Sponsored Links
  #2  
Old 14th September 2005, 14:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by n2s
Hi there,

I'm new here, I installed Suse 9.3 with the The Perfect Setup guide and it worked out quite well (reading the forum, thanx ).
Unfortunately I still have two problems left regarding postfix.

It's not possible to send mail over a SMTP-SSL connection (receiving works fine), I always get warnings in the log (not sure that's the reason):

postfix/smtpd[18593]: warning: connect to private/tlsmgr: Connection refused
postfix/smtpd[18593]: warning: problem talking to server private/tlsmgr: Connection refused
postfix/smtpd[18593]: warning: connect to private/tlsmgr: Connection refused
postfix/smtpd[18593]: warning: problem talking to server private/tlsmgr: Connection refused
postfix/smtpd[18593]: warning: no entropy for TLS key generation: disabling TLS support
Did you create the certificate according to the SuSE 9.3 howto?

Quote:
Originally Posted by n2s
Second, I can't receive mails. The mails are always returned with the message:

Final-Recipient: RFC822; xxx@yyyyyyyyy.yy
Action: failed
Status: 5.0.0
Remote-MTA: DNS; yyyyyyyyy.yy
Diagnostic-Code: SMTP; 554 <xxx@yyyyyyyyy.yy>: Recipient address rejected: Access denied
Last-Attempt-Date: Wed, 14 Sep 2005 13:48:08 +0200 (MEST)


Producing the following log entries:

postfix/smtpd[18593]: connect from natfrord.rzone.de[81.169.145.161]
postfix/smtpd[18593]: NOQUEUE: reject: RCPT from natfrord.rzone.de[81.169.145.161]: 554 <xxx@yyyyyyyyy.yy>: Recipient address rejected: Access denied; from=<zzzzzz@zzzzzzz.zz> to=<xxx@yyyyyyyyy.yy> proto=ESMTP helo=<natfrord.rzone.de>
disconnect from natfrord.rzone.de[81.169.145.161]


The domains appears in /etc/postfix/local-host-names, and /etc/postfix/local-host-names seems ok, too.

Any idea why this is happening?

Regards,
n2s
Check if you have inet_interfaces = all in /etc/postfix/main.cf.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 14th September 2005, 14:56
n2s n2s is offline
Junior Member
 
Join Date: Sep 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, I have inet_interfaces = all and I followed the howto.
Reply With Quote
  #4  
Old 14th September 2005, 15:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
Default

Quote:
Originally Posted by n2s
Yes, I have inet_interfaces = all and I followed the howto.
Try to restart the mail specific services postfix, sasl and fam.
Reply With Quote
  #5  
Old 14th September 2005, 18:48
n2s n2s is offline
Junior Member
 
Join Date: Sep 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Try to restart the mail specific services postfix, sasl and fam.
No effect.

I figured out the receiving problem, I had a wrong entry in smtpd_recipient_restrictions. I changed it because it was (and is know again) possible to send emails without an authentication !
Has anyone tried this on Suse 9.3 using the how-to installation?
I’ am only requested to use SMTP Auth when I remove the option check_relay_domains from smtpd_recipient_restrictions with the result that all incoming mails are rejected.

And I'm still able to send mails with SSL.
Any clues?
Reply With Quote
  #6  
Old 14th September 2005, 18:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by n2s
Has anyone tried this on Suse 9.3 using the how-to installation?
Yes, me!
Hm, let me think a little bit about it...

Can you post /etc/postfix/main.cf here?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 14th September 2005, 19:54
n2s n2s is offline
Junior Member
 
Join Date: Sep 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Can you post /etc/postfix/main.cf here?
Here it is:
Code:
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
mail_owner = postfix
unknown_local_recipient_reject_code = 550
debug_peer_level = 2
debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = maildrop
html_directory = /usr/share/doc/packages/postfix/html
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/packages/postfix/samples
readme_directory = /usr/share/doc/packages/postfix/README_FILES
inet_protocols = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
#virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = XXXXX.$mydomain
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
disable_dns_lookups = no
relayhost =
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = yes
smtpd_use_tls = yes
smtp_use_tls = yes
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
mydomain = XXXXXXXXXX.XXX
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
I followed the install instructions on a Strato Box with a new Suse 9.3 installation
Reply With Quote
  #8  
Old 14th September 2005, 20:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Try to set mailbox_size_limit to a value bigger than message_size_limit, e.g.

Code:
mailbox_size_limit = 50000000
and restart Postfix afterwards:
Code:
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 14th September 2005, 22:28
n2s n2s is offline
Junior Member
 
Join Date: Sep 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Try to set mailbox_size_limit to a value bigger than message_size_limit
Just tried it, does not work. Still got this strange “postfix/smtpd[13828]: warning: connect to private/tlsmgr: Connection refused” warning if I try to connect over SLL to SMTP and still could send messages with SMTP without using AUTH.

Thanks for your help so far . Any other idea?
Reply With Quote
  #10  
Old 15th September 2005, 11:51
n2s n2s is offline
Junior Member
 
Join Date: Sep 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by n2s
postfix/smtpd[13828]: warning: connect to private/tlsmgr: Connection refused
It’s been solved! Had to uncomment the tlsmgr entry in master.cf, seems I overlooked that .

However, what is about the possibility to send mails without using authentication ? How could I prevent that?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Web Mail mphayesuk General 10 15th September 2005 12:21
Mail Configuration mphayesuk General 1 12th September 2005 13:16
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28
Mailserver not receiving mail Unsaferanger Installation/Configuration 3 26th August 2005 08:59
2 mail servers? thedude General 2 15th August 2005 16:34


All times are GMT +2. The time now is 04:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.