#1  
Old 15th June 2012, 10:19
paradoxni paradoxni is offline
Junior Member
 
Join Date: Jun 2008
Posts: 19
Thanks: 1
Thanked 1 Time in 1 Post
Default shell users

Good Morning,

I have installed the latest ISPconfig3 on Ubuntu 12.04 using the perfect server guide on here.

The problem I am having is when creating shell users - the users cannot log in at all over SSH:

Invalid user *** from ***
input_userauth_request: invalid user ** [preauth]
Failed password for invalid user ** from *** port 8056 ssh2

I do not have jailkit installed, and the chroot is set to none - I simply want to get SSH working basically first.

Any thoughts?

Cheers,

Last edited by paradoxni; 15th June 2012 at 10:23.
Reply With Quote
Sponsored Links
  #2  
Old 15th June 2012, 12:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,394
Thanks: 833
Thanked 5,489 Times in 4,321 Posts
Default

Did you enter the full username incl prefix as shown in the ssh users list and as you find it in /etc/passwd?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th June 2012, 12:02
paradoxni paradoxni is offline
Junior Member
 
Join Date: Jun 2008
Posts: 19
Thanks: 1
Thanked 1 Time in 1 Post
Default

it seems the users are not being added to /etc/passwd

I can see the client users are added web1,2,3 etc. However the usernames I create for the shell users do not seem to be added??
Reply With Quote
  #4  
Old 18th June 2012, 12:04
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,394
Thanks: 833
Thanked 5,489 Times in 4,321 Posts
Default

Please see here for debug instructions:

http://www.faqforge.com/linux/debugg...-of-a-failure/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 25th June 2012, 17:02
paradoxni paradoxni is offline
Junior Member
 
Join Date: Jun 2008
Posts: 19
Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks for this...however the following was all I got after adding a new shell user and then manually running the script:

/usr/bin/fail2ban-client
/sbin/iptables
/sbin/ip6tables
finished.

Again, the shell user does not appear in /etc/passwd

however the overall client name appears in /etc/group:

sshusers:x:5002:web1,web5,web7,web8,web13,web14
Reply With Quote
  #6  
Old 25th June 2012, 17:19
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,394
Thanks: 833
Thanked 5,489 Times in 4,321 Posts
Default

You missed to enable the debug mode as described in the FAQ.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 25th June 2012, 18:27
paradoxni paradoxni is offline
Junior Member
 
Join Date: Jun 2008
Posts: 19
Thanks: 1
Thanked 1 Time in 1 Post
Default

I do apologize! Totally missed the first bit.


25.06.2012-16:23 - WARNING - Directory of the shell user is outside of website docroot.

25.06.2012-16:23 - WARNING - Jailkit Plugin -> insert username:alun skipped, the user does not exist.

The shell user dir is /var/www/clients/client3/web14 - which seems correct.

I have chosen the option Chroot: None
Reply With Quote
  #8  
Old 26th June 2012, 13:30
paradoxni paradoxni is offline
Junior Member
 
Join Date: Jun 2008
Posts: 19
Thanks: 1
Thanked 1 Time in 1 Post
Default

I am now trying with jailkit...but again users are not created.

/etc/passwd does not include the shell users I create.

This is Ubuntu 12.04 64bit

when I delete the shell user the log shows: WARNING - User: does not exist in in /etc/passwd, skipping delete.

Last edited by paradoxni; 26th June 2012 at 13:47.
Reply With Quote
  #9  
Old 26th June 2012, 14:01
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,394
Thanks: 833
Thanked 5,489 Times in 4,321 Posts
Default

Which directory is set as website basedir under System > Server config > Web > Website basedir in ISPConfig?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 26th June 2012, 15:03
paradoxni paradoxni is offline
Junior Member
 
Join Date: Jun 2008
Posts: 19
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by till View Post
Which directory is set as website basedir under System > Server config > Web > Website basedir in ISPConfig?
Website basedir: /var/www
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem creating jailed shell users tspau General 12 10th August 2011 15:03
Users created but cannot login (FTP and shell) baskin General 13 18th December 2009 20:05
Problem with Clamav + samba configuration wammy28 HOWTO-Related Questions 8 31st January 2009 19:12
Cacti and ISPConfig: Monitoring Tool VMartins Tips/Tricks/Mods 11 9th August 2008 18:37
Junk mail and spamassassin... sthompson Installation/Configuration 4 27th December 2006 16:11


All times are GMT +2. The time now is 18:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.