Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th July 2012, 04:04
piyush piyush is offline
Junior Member
 
Join Date: Jul 2011
Posts: 22
Thanks: 1
Thanked 1 Time in 1 Post
Default Unable to Send & Recieve Email ISPConfig

Long time before (may be one and half year ) I configure server with ISPConfig and all going fine.

Recently we are facing problem in sending & Recieving email on mail.aissworld.com.

Few weeks before ISP Block email port they said we are spamming from that port.

How ever after a while port open and we able to recieve email but still issue in sending email.

Few days before I am even unable to recieve email.

Here is message from gmail when sending email.



This is an automatically generated Delivery Status Notification

THIS IS A WARNING MESSAGE ONLY.

YOU DO NOT NEED TO RESEND YOUR MESSAGE.

Delivery to the following recipient has been delayed:

??????@aissworld.com

Message will be retried for 2 more day(s)

Technical details of temporary failure:
The recipient server did not accept our requests to connect. Learn more at http://support.google.com/mail/bin/a...py?answer=7720
[(10) mail.aissworld.com. [114.34.87.31]:25: Connection timed out]

----- Original message -----

DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
d=gmail.com; s=20120113;
h=mime-version:date:message-id:subject:from:to:content-type;
bh=cHiHuKLSZgwxoOohmakZKZGnajobgNk8ihO4nQidB5Y=;
b=Vx/R5a9GnaUAqbmNRElRPh9QKyzNTTowqGq0w71HCrsjOG8+PM7Oj LvXedpitNja7j
vqpEqUgOsvQPpQQ/iJDsE/+LCsAx1QLl6Z7YGW1y6XgeTVRZkQ6GKvGBrZIffu0lM6uH
26tC7enjipTuz4ANCX417VnZX6crkDD6PGWj17yTsQ97YbHLha kn6kQUHb/ntz7i9yDA
d1ARTrxw8YX6szhOTUR2+FNnhXOY1tVnN65TYb8h7Z+Q3s17tn 9+/fCgitlDpmrem2ub
g934PcMw+5ie1jORAEtEQEeTyZNAs5/AVoeBIYXUkrtG9gyHPVN40n/MuWuFiIoylKQ9
83mA==
MIME-Version: 1.0
Received: by 10.52.28.71 with SMTP id z7mr19971685vdg.105.1342026236679; Wed,
11 Jul 2012 10:03:56 -0700 (PDT)
Received: by 10.220.80.8 with HTTP; Wed, 11 Jul 2012 10:03:56 -0700 (PDT)
Date: Thu, 12 Jul 2012 01:03:56 +0800
Message-ID: <CAATPF_RYm=KU9nHbOYfvqBRMaozWkHtxYt=rL2t=uNmEZJqg ng@mail.gmail.com>
Subject: Test Mail
From: Piyush Verma <????????@gmail.com>
To: ????????@aissworld.com
Content-Type: multipart/alternative; boundary=20cf3078119e1dd5c904c490d5bf


Port is still open no idea why so.

Please Suggest us solution .

Webhosting is not my business but we use it for our internal office use.

For us is there any effordable paid service for mentainence of server ?


Thanks & Regards

Piyush Verma

Last edited by piyush; 13th July 2012 at 04:06.
Reply With Quote
Sponsored Links
  #2  
Old 13th July 2012, 08:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,414
Thanks: 812
Thanked 5,204 Times in 4,080 Posts
Default

Seems as if your provider blocks port 25 incoming (from the internet to your server) and gmail rejects the emails for that reason. Many email providers do a check of the sending email server by connecting back to it and if that fails like in your case, the email is rejected.

A solution might be to use a external relay server for sending. If your internet access provider offers a smtp server for sending emails, then you might use this server as relay. You can set the relay server in ispconfig under System > server config > mail.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th July 2012, 03:02
piyush piyush is offline
Junior Member
 
Join Date: Jul 2011
Posts: 22
Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks Till for relay suggestion I will check for that.

Currently I am not even able to recieve email.

and port is open I jsut tested again now and here is the result below.

nmap aissworld.com

Starting Nmap 5.21 ( http://nmap.org ) at 2012-07-14 08:57 CST
Nmap scan report for aissworld.com (114.34.87.31)
Host is up (0.011s latency).
rDNS record for 114.34.87.31: 114-34-87-31.HINET-IP.hinet.net
Not shown: 983 closed ports
PORT STATE SERVICE
21/tcp open ftp
22/tcp open ssh
25/tcp open smtp
53/tcp open domain
80/tcp open http
110/tcp open pop3
143/tcp open imap
443/tcp open https
993/tcp open imaps
995/tcp open pop3s
3306/tcp open mysql
5222/tcp open unknown
7777/tcp open unknown
8080/tcp open http-proxy
8081/tcp open blackice-icecap
9090/tcp open zeus-admin
9091/tcp open unknown


Before when port was block result of nmap was different.

Do you think it's still blocked by ISP ?


Thanks & Regards

Piyush Verma
Reply With Quote
  #4  
Old 14th July 2012, 07:08
loadingjkr loadingjkr is offline
Member
 
Join Date: May 2012
Location: Perú
Posts: 85
Thanks: 12
Thanked 0 Times in 0 Posts
Default

my not work for me on CentOS 6.0 64-bit
Reply With Quote
  #5  
Old 15th July 2012, 12:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Quote:
Originally Posted by piyush View Post
Do you think it's still blocked by ISP ?
You should ask your ISP. If you run nmap on localhost, you cannot tell if the port is blocked or not.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
piyush (25th July 2012)
  #6  
Old 25th July 2012, 11:26
piyush piyush is offline
Junior Member
 
Join Date: Jul 2011
Posts: 22
Thanks: 1
Thanked 1 Time in 1 Post
Default

After lots of fight and time west.

Finaly ISP accept that he have blocked the port.

And recently opened again.

They say that it was spamming form our side from port 25 that's why they block.

But I would port 25 is used to recieve emails not send email right ?

To send email I just need to establish connection to remote server on port 25 from any local port right ?

How ever any possible way to check and solve that this situation not happen agail ?


Thanks & Regards

Piyush Verma
Reply With Quote
  #7  
Old 25th July 2012, 11:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,414
Thanks: 812
Thanked 5,204 Times in 4,080 Posts
Default

Port 25 is used for email server communication, it can be used to send emails and to receive emails. If your server was blocked for spamming, they should have blocked only port 25 outgoing but it seems that they blocked it in both directions in your case.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 25th July 2012, 11:45
piyush piyush is offline
Junior Member
 
Join Date: Jul 2011
Posts: 22
Thanks: 1
Thanked 1 Time in 1 Post
Default

Dear Till,

Thanks for information. Now the port is open my side but next big question is how to test and prevent spamming.

Is there any predefined checklist or tutorial which I could follow ?

Thanks & Regards

Piyush Verma

Last edited by piyush; 25th July 2012 at 11:48.
Reply With Quote
  #9  
Old 25th July 2012, 14:11
piyush piyush is offline
Junior Member
 
Join Date: Jul 2011
Posts: 22
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

I think Any program running in host can open port 22 and start sending email like sendmail or may be some other jave based socket program.

if some how we could restrict that only postfix have rights to open outgoing port 25..........

Humm. I know a bit socket programming in that we only specify destination ip and port how blocking local port 25 can prevent stablising connection to xIP:25 port ?

But when I block port 25 outgoing postfix was not able to send mail out it's mistry for me.

Any suggestion ?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to send or recieve emails. Showa Installation/Configuration 24 30th November 2011 13:26
can't send email after installing ispconfig 3 from email client anubix Server Operation 15 9th October 2011 12:16
Unable to receive mail on ISPConfig configured email addresses. ahoivik Installation/Configuration 7 21st April 2008 22:56
Can Send Email, But Not Recieve mfdp10 Installation/Configuration 15 4th June 2007 09:18
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19


All times are GMT +2. The time now is 11:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.