Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th July 2012, 12:08
blustem blustem is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig 3 and creating db mysql from panel

Hi guys,
I have a problem that occurred yesterday and is as follows:
In panel ISPConfig 3, I created a new user, domain, database, and ... surprise, the database is not created!
I made other attempts, but the problem persists. ISPC does not seem to make the necessary operations to create user / database.
Through the tool mysql with the command show databases, the database engine does not actually exist;
the query select * from mysql.user I verified that the user is not created.
I do not know how to fix it.
Please help me. Thank you!

System:
Debian 6 64
ISP Config 3.0.4.6 (updated)
Reply With Quote
Sponsored Links
  #2  
Old 12th July 2012, 12:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

The most likely reason is that you changed the mysql root password in the mysql database without changing it in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf as well.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th July 2012, 12:20
blustem blustem is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello Till,
having said that the root password was not changed,
password in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf and password in the database match.
Reply With Quote
  #4  
Old 12th July 2012, 12:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Please see FAQ for debugging instructions:

http://www.faqforge.com/linux/debugg...-of-a-failure/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 12th July 2012, 12:39
blustem blustem is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

nothing. command returns... finished.
I'm desperate. This is a server operating whit many domains...
Reply With Quote
  #6  
Old 12th July 2012, 12:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Quote:
nothing. command returns... finished.
Then you havent debugging enabled as decsribed in the faq.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 12th July 2012, 14:55
blustem blustem is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Then you havent debugging enabled as decsribed in the faq.
Yes...

Before
* * * * * /usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log

After
#* * * * * /usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log

Then run command:
/usr/local/ispconfig/server/server.sh

Result "now"
/usr/bin/fail2ban-client
/sbin/iptables
/sbin/ip6tables
finished.

Re run and result is
finished.
Reply With Quote
  #8  
Old 12th July 2012, 17:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

No, you did just 2 of the 3 nescessary steps, please reread the faq. Debugging has to be enabled in the ispconfig interface first.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 12th July 2012, 18:04
blustem blustem is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Ok Till,
I enabled debugging on ispconfig and the result is:

Creating db prova from ISPC and run by terminal
> /usr/local/ispconfig/server/server.sh

12.07.2012-15:38 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
12.07.2012-15:38 - DEBUG - Found 1 changes, starting update process.
12.07.2012-15:38 - DEBUG - Calling function 'db_insert' from plugin 'mysql_clientdb_plugin' raised by event 'database_insert'.
12.07.2012-15:38 - DEBUG - Created MySQL database: test
12.07.2012-15:38 - DEBUG - Processed datalog_id 1187
12.07.2012-15:38 - DEBUG - Remove Lock: usr/local/ispconfig/server/temp/.ispconfig_lock
finished.

Second step
Removing db and run
> /usr/local/ispconfig/server/server.sh

12.07.2012-15:43 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
12.07.2012-15:43 - DEBUG - Found 1 changes, starting update process.
12.07.2012-15:43 - DEBUG - Calling function 'db_delete' from plugin 'mysql_clientdb_plugin' raised by event 'database_delete'.
12.07.2012-15:43 - DEBUG - Dropping MySQL user: test
12.07.2012-15:43 - DEBUG - Dropping MySQL database: prova
12.07.2012-15:43 - DEBUG - Processed datalog_id 1189
12.07.2012-15:43 - DEBUG - Remove Lock: usr/local/ispconfig/server/temp/.ispconfig_lock
finished.

The db "prove" is correctly created and dropped in mysql only if I run /usr/local/ispconfig/server/server.sh

And now? I try to replace the crontab?

Last edited by blustem; 12th July 2012 at 18:13.
Reply With Quote
Reply

Bookmarks

Tags
ispconfig3, mysql

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 12:04
vsftpd mysql & ispconfig gluki General 2 7th March 2011 02:17
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
ISPConfig 2.3.2-dev released till General 9 4th June 2007 10:46
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48


All times are GMT +2. The time now is 13:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.