#1  
Old 3rd July 2012, 20:30
PrfctGdess PrfctGdess is offline
Junior Member
 
Join Date: Jul 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default open_basedir driving me nuts!

OK, am I missing something here? This is my error:

PHP Warning: include(): open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web3/) in /var/www/clients/client1/web3/web/wp-includes/update.php on line 371, referer: http://mysite.com/wp-admin/network/upgrade.php

Um, it sure LOOKS like web/wp-includes... is a subdirectory of the allowed path; I've tried the allowed path with both the final / and without it.

Any ideas?! This warning is causing me issues on my Wordpress installation.
Reply With Quote
Sponsored Links
  #2  
Old 4th July 2012, 10:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,344
Thanks: 810
Thanked 5,173 Times in 4,055 Posts
Default

This is most likey a problem with file permissions and not a open_basedir issue. If you changed open_basedir, please change it back.

Then check that you selected as php mode of the website "php-fcgi" and that the suexec checkbox is enabled. Then ensure that all files and folders in the directory /var/www/clients/client1/web3 and its subdirectories are owned by the user "web3" and the group of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 4th July 2012, 16:34
PrfctGdess PrfctGdess is offline
Junior Member
 
Join Date: Jul 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for your response! Yes, I have the site set to FastCGI for the php mode (although I've tried others, too) and I have the suexec IS checked. I HAVE changed the open_basedir directory, but only because I've been trying to find a combination that works...I even tried disabling it at one point, and I tried leaving it as the base directory (including everything under it). I know all the folders and files belong to the user web3 and the website group, but still no luck. Do I need to manually change the file permissions, perhaps?
Reply With Quote
  #4  
Old 4th July 2012, 22:42
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 125
Thanks: 7
Thanked 27 Times in 8 Posts
 
Default

try to disable (remove) eaccellerator, if you have it, and see if it helps
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email from server driving me crazy chaloum General 29 13th April 2012 13:45
postfix saslauthd, Please! help (going nuts) telmathedog HOWTO-Related Questions 7 2nd September 2010 10:53
IspConfig 3 geting me nuts... robilaur General 2 10th February 2009 11:25
System message driving me crazy! cambo Installation/Configuration 4 31st January 2007 11:14
mysql: root access denied ~ driving me nuts! domino Server Operation 4 16th January 2007 03:20


All times are GMT +2. The time now is 03:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.