Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd July 2012, 18:28
rdhir rdhir is offline
Junior Member
 
Join Date: May 2009
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Default FCGID or PHP broken

OK, I have had a perfectly functioning ISPConfig setup running for a while.

Its based on a CentOS 6.2 vm run at Bytemark.co.uk.

I recently issued a yum install update and seem to have broken my system in a subtle way.

ISPConfig (3.0.4.6) seems to work fine.

However I am running various wordpress sites and while they deliver content, various configuration pages are broken. It seems to be related to FCGID as I get the following errors in the server log for any site

Code:
[Tue Jul 03 17:07:46 2012] [warn] [client *.*.*.*] mod_fcgid: stderr: PHP Warning:  require(): open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client5/web20/web:/var/www/clients/client5/web20/tmp:/var/www/www.clientdomain.com/web:/srv/www/clientdomain.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in /var/www/clients/client5/web20/web/wp-admin/admin-header.php on line 110, referer: http://www.clientdomain.com/wp-admin/index.php
[Tue Jul 03 17:07:46 2012] [warn] [client *.*.*.*] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://www.clientdomain.com/wp-admin/index.php
[Tue Jul 03 17:07:46 2012] [warn] [client *.*.*.*] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer: http://www.clientdomain.com/wp-admin/index.php
I have tried various things such as changing to CGI, Mod PHP and SU PHP but I just get a different set if errors.

I have tried editing the .php-fcgi wrapper file to eliminate openbasedir, but I think thats just a symptom as I still get the 104 errors. It is as if PHP can't read a list of some kind, as simple pages work but pages which should contain a list it items taken from the database don't

Happy to provide more info if you tell me what you need.

Linux kernel is 2.6.32.33-kvm-i386-20111128-dirty
php.i686 is 5.3.3-3.el6_2.8
httpd.i686 is 2.2.15-15.el6.centos.1


Any help gratefully received

Cheers

Rajiv
Reply With Quote
Sponsored Links
  #2  
Old 4th July 2012, 10:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,166
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

1) Ensure that all files in /var/www/clients/client5/web20/web and its sub directoris are owned by the web user and client group of the website.
2) Check the website settings, php mode should be php-fcgi and the suexec checkbox must be enabled.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 4th July 2012, 11:41
rdhir rdhir is offline
Junior Member
 
Join Date: May 2009
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Checked the from /var/www/www.clientdomain.com/ and all files are owned by the correct owner group combination

Similarly in the control panel

suexec is ticked and Fast-CGI is selected as the PHP mode.
Reply With Quote
  #4  
Old 4th July 2012, 13:50
rdhir rdhir is offline
Junior Member
 
Join Date: May 2009
Posts: 20
Thanks: 2
Thanked 0 Times in 0 Posts
Default Further Clues

ok after more investigation I can make it work a little bit better, but I still get plenty of time outs in the admin pages.

a) I temporarily hacked /var/www/php-fcgid-scripts/xxx/.php-fcgi-starter

I set openbasedir = "none"

some configuration pages started to work.

b) I changed the timeout values as follows

Code:
        FcgidIdleTimeout 300
        FcgidProcessLifeTime 3600
        # MaxProcessCount 1000
        FcgidMinProcessesPerClass 0
        FcgidMaxProcessesPerClass 100
        FcgidConnectTimeout 20
        FcgidIOTimeout 3600
        FcgidBusyTimeout 300
previously they used older? names eg IdleTimeout

I am still getting fails on configuration pages which are extracting longer lists from MySQL

yum reports mod_fcgid

mod_fcgid.i686 2.3.7-1.el6 @epel

So did an update somehow make fcgid need different names for parameters and perhaps change openbasedir or the location of some temporary file?
Reply With Quote
  #5  
Old 4th July 2012, 14:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,166
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
 
Default

Quote:
previously they used older? names eg IdleTimeout
Then you havent selected the correct fcgi configuration mode for your apache version in system > server config in apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Only Problems since Updating from 3.0.3.3 to 3.0.4.1 mbay General 4 17th May 2012 12:56
ubuntu and nginx delgado2061 Installation/Configuration 0 27th November 2011 23:36
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 21:13
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 08:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.