Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd July 2012, 09:31
sxlderek sxlderek is offline
Junior Member
 
Join Date: Nov 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Lost all accounts and emails in one virtual email domain

Hi All,

I have ISPC 3.0.4.1 running in 2 Ubuntu 10.04 OpenVz contrainers.
1st server for DNS, Web, MySQL, etc.
2nd server for DNS, Postfix, Dovecot, Webmail, etc.
These servers has been running fine for almost a year.

But today, in one of the virtual domain, all emails and account settings lost. The domain folder does not even existing in /var/vmail/(domain).

Now I want know

1. how to restore everything related to this particular domain from backup. The backup is a simple "tar" of everything in the server (created by vzdump command)

2. what can cause this? is the customer delete his own domain from the control panel?

Please help, this is quite urgely.
Thank you in advance.

--
Derek Chan
Reply With Quote
Sponsored Links
  #2  
Old 2nd July 2012, 10:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,983
Thanks: 825
Thanked 5,372 Times in 4,219 Posts
Default

Quote:
1. how to restore everything related to this particular domain from backup. The backup is a simple "tar" of everything in the server (created by vzdump command)
Restore the folder /var/vmail/domain.tld of the deleted domain from your backup. To get the domain back in the controlpanel, either restore a database backup of the ispconfig database which was created before the domain got deleted or recreate the domain and mailboxes in ispconfig before you copy back the emails from the file backup.

Quote:
2. what can cause this? is the customer delete his own domain from the control panel?
Thast the most likely reason.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd July 2012, 13:35
sxlderek sxlderek is offline
Junior Member
 
Join Date: Nov 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you so much for your quick reply Till,

I created a mail domain (with the same name) via ISPconfig web interface.

Then I restored only the records of this particular domain to the mail_user table

And then, I restored the /var/vmail/(domain) directory.

Now, everything "looks" right in the ispconfig web, but users cannot login to their mail account.

Code:
Jul  2 19:18:51 h12 dovecot: imap-login: Aborted login (auth failed, 1 attempts): user=<username@xxxxxx.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
If I create a new email account in this domain, it works fine.

What I am missed?
Reply With Quote
  #4  
Old 3rd July 2012, 16:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by sxlderek View Post
Then I restored only the records of this particular domain to the mail_user table
Did you check if these records have unique IDs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 3rd July 2012, 21:36
sxlderek sxlderek is offline
Junior Member
 
Join Date: Nov 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I didn't check. I end up reset everybody's password form the control panel and it works.

Thank you again for your help
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
mail recipient linux_red Installation/Configuration 6 9th March 2012 14:24
Sending emails with custom FROM email address merisor Installation/Configuration 4 8th February 2010 16:27
relay access denied with virtual emails setup in mysql tkaman2 Server Operation 22 2nd January 2008 22:34


All times are GMT +2. The time now is 05:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.