Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 11th October 2013, 10:38
stemio77 stemio77 is offline
Junior Member
 
Join Date: Oct 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, i tried to apply this patch to ISPConfig 3.0.5.1 and got an error:

Hunk #1 succeeded at 257 with fuzz 2 (offset 8 lines).
Hunk #2 succeeded at 298 with fuzz 2 (offset 8 lines).
patching file templates/mail_user_mailbox_edit.htm
Hunk #1 FAILED at 51.
1 out of 1 hunk FAILED -- saving rejects to file templates/mail_user_mailbox_edit.htm.rej

thnx for help..
Reply With Quote
Sponsored Links
  #12  
Old 11th October 2013, 10:47
Dehumanizer Dehumanizer is offline
Junior Member
 
Join Date: Oct 2012
Posts: 16
Thanks: 1
Thanked 2 Times in 1 Post
Thumbs up

Hello,

I don't have time to update the patch right now, but here is the quick fix:
Locate mail_user_mailbox_edit.htm file in your ispconfig installation (most likely it will be /usr/local/ispconfig/interface/web/mail/templates/mail_user_mailbox_edit.htm )
then find lines that go like this:
Code:
<div class="ctrlHolder">

                <p class="label">{tmpl_var name='disableimap_txt'}</p>
and immediately before that div, put this:

Code:
           <div class="ctrlHolder">
                               <p class="label">{tmpl_var name='disablesmtp_txt'}</p>
                                       <div class="multiField">
                                               {tmpl_var name='disablesmtp'}
                                       </div>
                       </div>
and that should fix it. The "disable SMTP" checkbox should appear when you are editing a mailbox.
Let me know if you have any problems with that.
Reply With Quote
  #13  
Old 11th October 2013, 11:43
stemio77 stemio77 is offline
Junior Member
 
Join Date: Oct 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Dehamanizer,
thanks for your quick response.
Please see the attach
Attached Images
 
Reply With Quote
  #14  
Old 11th October 2013, 11:44
Dehumanizer Dehumanizer is offline
Junior Member
 
Join Date: Oct 2012
Posts: 16
Thanks: 1
Thanked 2 Times in 1 Post
Default

Please attach your mail_user_mailbox_edit.htm file
Reply With Quote
  #15  
Old 11th October 2013, 11:55
stemio77 stemio77 is offline
Junior Member
 
Join Date: Oct 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

here my mail_user_mailbox_edit
Attached Files
File Type: txt mail_user_mailbox_edit.txt (5.4 KB, 13 views)
Reply With Quote
  #16  
Old 11th October 2013, 12:28
stemio77 stemio77 is offline
Junior Member
 
Join Date: Oct 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

solved (but not tried yet) if SMTP work
i've found 3 files .rej, in each of them were highlighted the changes that had not been made ​​to the main fileexample:

en_mail_user.lng.rej
$wb["disableimap_txt"] = 'Disable IMAP';
+ $wb["disablesmtp_txt"] = 'Disable SMTP';
$wb["disablepop3_txt"] = 'Disable POP3';

in
mail_user.tform.php.rej
+ 'disablesmtp' => array (
+ 'datatype' => 'VARCHAR',
+ 'formtype' => 'CHECKBOX',
+ 'default' => 'n',
+ 'value' => array(1 => 'y',0 => 'n')
+ ),

insert these codes in my en_mail_user.lng and mail_user.tform.php..

now i'll try to see if works or not!!

Last edited by stemio77; 11th October 2013 at 12:33.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
link my domain to my server, impossible! 007007 Installation/Configuration 7 17th January 2012 13:59
DNS Lookups kieron General 4 4th May 2011 19:49
Can't access to my website - after install problem pallermo Installation/Configuration 18 4th June 2010 13:29
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47


All times are GMT +2. The time now is 06:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.