Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th July 2006, 01:00
paulley paulley is offline
Member
 
Join Date: Feb 2006
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Default problem with displaying website with ispconfig

hi all

i have just installed ispconfig with the prefect setup fedora 4. But my problem is i have put the index.html file and also a image folder on to it and its saying it cant find the directory, i have put it in all the folder in the root and even the index.html but its not bring up the site and just displays the fedora test page on all sites. This does the same on all the 3 site i am hosting.

thanks
Reply With Quote
Sponsored Links
  #2  
Old 25th July 2006, 09:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Is your server in a NAT enviroment behind a router?
Is the file Vhost_ispconfig.conf included at the end of your apache configuration file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th July 2006, 10:53
paulley paulley is offline
Member
 
Join Date: Feb 2006
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes but all the ports need are forwarded. yes the Vhost_ispconfig.conf is included at the bottom in the httpd.conf
Reply With Quote
  #4  
Old 25th July 2006, 11:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Have you selected your internal IP for the websites and not your external?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 25th July 2006, 22:26
paulley paulley is offline
Member
 
Join Date: Feb 2006
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Cool

cool its working now but when connecting to the ftp site of any site it connects fine but when i enter my username and password it dont let me in and the login box comes up again even though it worked fine when the site wasnt appearing

also has every ip on the site configure and dns etc have to be the internal ip

thanks

Last edited by paulley; 25th July 2006 at 23:08.
Reply With Quote
  #6  
Old 26th July 2006, 08:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Websites must use the internal IP, DNS must use the external IP.

To your FTP problem:

Did you connect from inside your lan or from outside?
Is the ISPConfig WebFTP working?
Have you checked the FTP checkbox in the website settings?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 26th July 2006, 10:18
paulley paulley is offline
Member
 
Join Date: Feb 2006
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Default

well i have connected from inside the lan and outside the lan does the same thing. the webftp is working fine ,and the ftp access is selected on all sites
Reply With Quote
  #8  
Old 26th July 2006, 12:11
paulley paulley is offline
Member
 
Join Date: Feb 2006
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Default

dont worry i have sorted it thanks till i looked it the proftpd_ispconfig.conf and there was 2 virtual hosts one with the internal ip and one with the external ip , i deleted the internal ip one and restart proftpd and then tried it again and it logged me in. thanks for ya help
Reply With Quote
  #9  
Old 26th July 2006, 12:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Quote:
Originally Posted by paulley
dont worry i have sorted it thanks till i looked it the proftpd_ispconfig.conf and there was 2 virtual hosts one with the internal ip and one with the external ip , i deleted the internal ip one and restart proftpd and then tried it again and it logged me in. thanks for ya help
Please check your ISPConfig settings under Management > server > settings and remove your external IP there, if it is listed in the server settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 26th July 2006, 13:49
paulley paulley is offline
Member
 
Join Date: Feb 2006
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

on the server setting i got the main ip has the external ip but when i change it to the internal ip its stop the ftp logging me in
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" Problem with ISPConfig chipw Installation/Configuration 6 30th October 2006 09:38
Mambo And ISPconfig Link Problem rikardo Server Operation 1 9th May 2006 16:41
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37


All times are GMT +2. The time now is 01:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.