#1  
Old 16th January 2014, 21:29
mattltm mattltm is offline
Member
 
Join Date: Jun 2011
Posts: 60
Thanks: 11
Thanked 5 Times in 5 Posts
Default IMAP very slow

I seem to have a small issue with IMAP connections.

They get very slow (taking around 40 seconds to download a single message). If I reboot the server then the IMAP connection is fast for a few hours before slowing down again.

The server load average is around 0.02 - 0.05 and I can't see any problems in the mail log.

Any ideas as to what's happening?
Reply With Quote
Sponsored Links
  #2  
Old 17th January 2014, 09:06
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 922
Thanks: 16
Thanked 259 Times in 206 Posts
Default

Have you checked if your server suffers from high io?
Install iotop and check usage there.
__________________
Marius Cramer

pixcept KG
Reply With Quote
  #3  
Old 17th January 2014, 10:12
mattltm mattltm is offline
Member
 
Join Date: Jun 2011
Posts: 60
Thanks: 11
Thanked 5 Times in 5 Posts
Default

Yes, I left iotop running all day and noticed nothing unusual and no sustained high loads.
Reply With Quote
  #4  
Old 17th January 2014, 14:15
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,146
Thanks: 4
Thanked 55 Times in 51 Posts
Default

what Imap Server? Dovecot?
__________________
"Common sense is not as common as commonly believed" by sjau

Auto-Install Script for ISPConfig and Horde on a Vanilla Debian Stable

Need more Repos for Ubuntu? Repository Generator
Need more Repos for Debian? Debian Repository Generator
Reply With Quote
  #5  
Old 17th January 2014, 15:43
mattltm mattltm is offline
Member
 
Join Date: Jun 2011
Posts: 60
Thanks: 11
Thanked 5 Times in 5 Posts
Thumbs up

Yes, Dovecot...
Reply With Quote
  #6  
Old 17th January 2014, 16:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,771
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

You should consider to install munin, it shows graphically many server parameters and might help to identify the source of your issue.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 17th January 2014, 19:04
mattltm mattltm is offline
Member
 
Join Date: Jun 2011
Posts: 60
Thanks: 11
Thanked 5 Times in 5 Posts
Default

Done.

Lets see what it throws up...
Reply With Quote
  #8  
Old 18th January 2014, 19:23
mattltm mattltm is offline
Member
 
Join Date: Jun 2011
Posts: 60
Thanks: 11
Thanked 5 Times in 5 Posts
 
Default

Nothing unusual in iotop, nothing strange in munin but still very slow right now
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with ISPConfig Mail and Squirrelmail m.xander Installation/Configuration 109 3rd February 2012 00:15
ISP CONFIG 3 + Devocot 2.x - cant send mail ondrusina Installation/Configuration 2 24th June 2011 16:09
Not working emails (DNS and postfix problem?) shekiman Installation/Configuration 9 1st March 2011 16:25
ISPconfig IMAP slower than naked install DHDSP General 7 5th June 2008 13:02
Email not going out! cybereatl Installation/Configuration 12 28th February 2007 14:02


All times are GMT +2. The time now is 07:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.