Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th June 2012, 23:32
MaddinXx MaddinXx is offline
Senior Member
 
Join Date: Jul 2011
Location: Switzerland
Posts: 197
Thanks: 25
Thanked 62 Times in 46 Posts
 
Lightbulb IP based Virtual Host - Bad Request

Hi all

I'm having problems with IP virtual hosts. I've found many threads here about this, however they are all about IP in combination with HTTPS - and my one isn't.

OK I have name based virtual hosts as well as IP based virtual hosts on my apache server (ISPConfig powered of course).

Name based ones just work fine, however I'm having problems with IP based.

What errors encounter?

1. When I try to access the server itself by IP rather than hostname I get a 400 - Bad Request

2. When a Domain is IP based, accessing it by domain works well, however when I try to access it by IP, I get a 400 - Bad request as well.

Oh, I've found the answer

Stupid me. A quick look into apache's error log showed, that mod_security was blocking the access.

To solve:

Code:
nano /etc/apache2/mod-security/modsecurity_crs_99_whitelist.conf
and paste

Code:
SecRuleRemoveById 960017
I thought I'll write this to end, since it might be helpful to others.

If you don't agree, feel free to delete the topic

Regards,
MaddinXx

Last edited by MaddinXx; 15th June 2012 at 23:46.
Reply With Quote
The Following User Says Thank You to MaddinXx For This Useful Post:
falko (16th June 2012)
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2 and multiple SSL configs and name based virtual hosting Creator1326 Server Operation 11 5th October 2010 19:28
Squirrelmail login failure Cracklefish Installation/Configuration 9 30th June 2010 20:38
problem with upgrade to 2.2.34 brianetilley Installation/Configuration 14 11th November 2009 17:22
Add ons for ISPConfig 3 virtue Installation/Configuration 24 16th October 2009 17:30
problem with mail server setup kentor HOWTO-Related Questions 27 16th July 2009 15:22


All times are GMT +2. The time now is 20:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.