Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th June 2012, 04:11
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default Strange error: client denied by server configuration

Hi, I got the following code in my website (HTML page):

Code:
<script type="text/javascript" src="javascript/showimages.js"></script>
<script type="text/javascript" src="javascript/openwindow.js"></script>
the browser is denied access to these files, the log contains the following errors:

Code:
[Sun Jun 10 03:36:26 2012] [error] [client *.*.*.*] client denied by server configuration: /usr/share/javascript/showimages.js, referer: http://www.mydomain.com/index.php
[Sun Jun 10 03:36:26 2012] [error] [client *.*.*.*] client denied by server configuration: /usr/share/javascript/openwindow.js, referer: http://www.mydomain.com/index.php
ISPConfig 3.0.4.5 on Debian Squeeze (setup following Falko's Perfect Server How-To)

This is not mod-security related, I checked.

I also have no idea why the server is looking in /usr/share/ for these javascript files... very strange

any ideas?
Reply With Quote
Sponsored Links
  #2  
Old 10th June 2012, 11:46
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

there is a directory /javascript/ in /usr/share/
(containing mootools)

for some reason the server mistakes it with the directory in my website?
Reply With Quote
  #3  
Old 10th June 2012, 11:55
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
 
Default

found the culprit, it's a bug in either apache or debian:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=553173
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 mail doesn't work pehden Installation/Configuration 20 9th December 2013 14:05
Local mail server - final touch Alexhor Installation/Configuration 4 12th April 2012 22:33
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 13:21
FTP cannot open remote folder!?! andysm849 Server Operation 23 16th October 2008 23:34


All times are GMT +2. The time now is 20:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.