Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th May 2012, 13:30
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default Problem with phpmyadmin after

Hi,

I followed the multiserver setup with dedicated web email dns and myslq database servers on debian squeeze, but phpmyadmin not work. I get the message "Not Found. The requested URL /phpmyadmin was not found on this server."

Any idea?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 18th May 2012, 13:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,247 Times in 4,112 Posts
Default

And which server hostname or IP did you use to access phpmyadmin?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th May 2012, 13:39
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

Use the interface link in database section.

This link redirect to https://ip-web-server:8080/phpmyadmin

Any idea?

Last edited by esezako; 18th May 2012 at 17:10.
Reply With Quote
  #4  
Old 18th May 2012, 19:53
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

Another problem, can't connect with "myslq -u root -h db_server -p" from web_server to db_server.
Reply With Quote
  #5  
Old 19th May 2012, 15:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,732 Times in 2,569 Posts
Default

Quote:
Originally Posted by esezako View Post
Use the interface link in database section.

This link redirect to https://ip-web-server:8080/phpmyadmin

Any idea?
You might have to adjust the URL in the ISPConfig interface settings under System.

Quote:
Another problem, can't connect with "myslq -u root -h db_server -p" from web_server to db_server.
I guess this is just a typo, but the command is mysql, not myslq.

Do you get any error messages?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 21st May 2012, 10:22
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

Quote:
Originally Posted by falko View Post
You might have to adjust the URL in the ISPConfig interface settings under System.

I guess this is just a typo, but the command is mysql, not myslq.

Do you get any error messages?
What is the correct link?


Quote:
Originally Posted by falko View Post
Quote:
Another problem, can't connect with "myslq -u root -h db_server -p" from web_server to db_server.
I guess this is just a typo, but the command is mysql, not myslq.

Do you get any error messages?
ERROR 2003 (HY000): Can't connect to MySQL server on 'db1.nombresweb.net' (110)
Reply With Quote
  #7  
Old 22nd May 2012, 14:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,732 Times in 2,569 Posts
Default

What's the output of
Code:
netstat -tap
and
Code:
iptables -L
on db1.nombresweb.net
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 22nd May 2012, 14:26
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

Code:
root@db1:/# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.2:smtp          *:*                     LISTEN      6401/master     
tcp        0      0 localhost.localdom:smtp *:*                     LISTEN      6401/master     
tcp        0      0 localhost.localdom:6010 *:*                     LISTEN      6030/0          
tcp        0      0 *:mysql                 *:*                     LISTEN      8075/mysqld     
tcp        0      0 *:sunrpc                *:*                     LISTEN      197/portmap     
tcp        0      0 *:ssh                   *:*                     LISTEN      6158/sshd       
tcp        0      0 db1.mydomain.net:47141 web1.mydomain.net:mysql TIME_WAIT   -               
tcp        0     48 db1.mydomain.net:ssh  122.Red-**-**-**.:41745 ESTABLISHED 6030/0          
tcp6       0      0 localhost.localdom:6010 [::]:*                  LISTEN      6030/0          
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      6158/sshd       
root@db1:/# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
fail2ban-ssh  tcp  --  anywhere             anywhere            multiport dports ssh 

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

Chain fail2ban-ssh (1 references)
target     prot opt source               destination         
RETURN     all  --  anywhere             anywhere
Reply With Quote
  #9  
Old 23rd May 2012, 14:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,732 Times in 2,569 Posts
Default

That looks ok, MySQL is listening on all interfaces and not blocked by the server's firewall (it is however possible that there's another firewall somewhere on the way between both servers which blocks requests).

Does the DNS record for db1.nombresweb.net point to the correct server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 23rd May 2012, 14:30
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
 
Default

Now work, but I marked "remote access" in database config.

It's necessary mark "remote access"?
For safety I have to add the ip of web server right?

As a cluster expected this to be automatic.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Urgent Please ISPConfig 3 and phpmyadmin problem checho01 Installation/Configuration 1 6th January 2012 08:50
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
phpmyadmin login problem ddouma Installation/Configuration 14 20th January 2009 02:33


All times are GMT +2. The time now is 13:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.