Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th June 2012, 06:53
orasis orasis is offline
Senior Member
 
Join Date: Mar 2007
Posts: 183
Thanks: 13
Thanked 13 Times in 13 Posts
Default Ubuntu 12.04 "waiting for network configuration" on boot

Searched but didn’t find a topic related to this here. Got a small problem on ubuntu 12.04 3.2.0-24-generic-pae (desktop) running ispconfig 3.0.4.5.

Setting ispconfig to manage the network configuration causes ubuntu to show “waiting for network configuration” followed by “waiting up to 60 more seconds for network configuration..” messages on boot, and they take about 2 minutes to let the system continue to boot.

I’ve seen there is an ubuntu bug related to this:
https://bugs.launchpad.net/ubuntu/+s...wn/+bug/916890

The only way for the system to boot normally is to un-check “Network Configuration” in Server Config.

I am not sure if there is something I can do with your help, once if I don’t use the ispconfig feature “Network Configuration”, then additional server IP Addresses don’t work on (at least) lan.
There was nothing like this on ubuntu 10.04

Other than that, the system runs excellent.
Thanks for your help.


EDIT:
This is my /etc/network/interfaces
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 192.168.0.200
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1

auto eth0:0
iface eth0:0 inet static
        address 192.168.0.100
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
eth0:0 is the one that causes the problem, although without it, 192.168.0.100 (the additional ip) will never work.

By the way, on page 3 of "The Perfect Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3)" http://www.howtoforge.com/perfect-se...ispconfig-3-p3 you add this part:
Code:
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 192.168.0.100
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
        dns-nameservers 8.8.8.8 8.8.4.4
My question is, why now my interfaces have the "dns-nameservers" missing ?
cheers

Last edited by orasis; 6th June 2012 at 07:07.
Reply With Quote
Sponsored Links
  #2  
Old 6th June 2012, 10:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,986
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

You dont have to use the ispconfig network configuration feature to use ispconfig. Noramally IP addresses are configured with the config tools of the operating system directly, thats why the ispconfig network config is disabled by default and leving it off is the recommended setting.

So in your case, disable the network configuration option in ispconfig again and add the IP addresses with the ubuntu network configuration utility instead.

Quote:
My question is, why now my interfaces have the "dns-nameservers" missing ?
Normally the nameservers are set in /etc/resolv.conf, they dont have to be set in the interfaces file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
orasis (6th June 2012)
  #3  
Old 6th June 2012, 11:47
orasis orasis is offline
Senior Member
 
Join Date: Mar 2007
Posts: 183
Thanks: 13
Thanked 13 Times in 13 Posts
Default

Hi till, thanks for the fast reply as always.

It is excellent to use the default network tool of ubuntu for such a job.
So the default contents of /etc/network/interfaces before installing ispconfig was:
Code:
auto lo
iface lo inet loopback
I think I just go back to that.
I tried it, and only had to reboot computer for the network tool of ubuntu to be re-enabled. Also adding ip addresses there is very easy.

I only wonder what I would have to do if the server was remote ?

Concerning /etc/resolv.conf there was where I always used to edit the dns entries yes. It also takes the dns entries directly from the gui tool of ubuntu. My question was only related to your tutorial's part where you add "dns-nameservers 8.8.8.8 8.8.4.4" inside the /etc/network/interfaces

thanks for the help
Reply With Quote
  #4  
Old 6th June 2012, 11:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,986
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

Quote:
I only wonder what I would have to do if the server was remote ?
Most likely the configuration in /etc/network/interfaces will work on a Ubuntu server as it works on Debian Linux and on systems based on the ubuntu server DVD. I guess the problem with the desktop is that the ubuntu desktop tool gets loaded when the desktop is started and seems to dynamically configure some network settings and ignores the classic network config file /etc/network/interfaces.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
orasis (6th June 2012)
  #5  
Old 6th June 2012, 12:27
orasis orasis is offline
Senior Member
 
Join Date: Mar 2007
Posts: 183
Thanks: 13
Thanked 13 Times in 13 Posts
Default

right... something that most likely wasn't happening on 10.04 I guess.
I got no idea where the network tool saves the static IPs now. I am very new to 12.04.

By the way, do you think there might be a way to set an ip range instead of separate IPs ? maybe this is very stupid I ask.
Reply With Quote
  #6  
Old 6th June 2012, 12:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,986
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

There is no tool to setup ip ranges available yet as far as I know.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 6th June 2012, 13:01
orasis orasis is offline
Senior Member
 
Join Date: Mar 2007
Posts: 183
Thanks: 13
Thanked 13 Times in 13 Posts
Default

Thanks till for everything. The problem is solved and I currently don't need the server remotely, I was just asking for informative reasons.

It works excellent on 12.04, I also love the new look of phpmyadmin.

cheers, nice talking to you again.
Reply With Quote
  #8  
Old 24th June 2012, 11:50
Bookworm Bookworm is offline
Junior Member
 
Join Date: Aug 2009
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
Default

Update. With the newer versions of ubuntu, they actually discourage the use of /etc/resolv.conf.

Instead, you need to use the 'interfaces' file (/etc/network/interfaces)

As part of the primary network interface, you would add (after gateway)

dns-nameserver <ip address of server>

---

The timeout problem is caused by a couple of things. 1) udev is a piece of crap when it comes to network interfaces. You can have your network adapters renamed from eth0 to eth1 without knowing it, even if you _don't_ move the drive to a new system. (If you were, perhaps, doing the right thing and building it on another box for testing before replacing a live system). or 2) edit /etc/init/failsafe.conf and comment out the extra 'wait' time.
Reply With Quote
  #9  
Old 24th June 2012, 16:02
orasis orasis is offline
Senior Member
 
Join Date: Mar 2007
Posts: 183
Thanks: 13
Thanked 13 Times in 13 Posts
Default

Quote:
Originally Posted by Bookworm View Post
Update. With the newer versions of ubuntu, they actually discourage the use of /etc/resolv.conf.
yes I also read about that.

Quote:
Originally Posted by Bookworm View Post
Instead, you need to use the 'interfaces' file (/etc/network/interfaces)

As part of the primary network interface, you would add (after gateway)

dns-nameserver <ip address of server>
The thing is If you do that and then go make a change to the ubuntu network manager using the gui tool, I think it wipes out your additions in /etc/network/interfaces no ?

Quote:
Originally Posted by Bookworm View Post
edit /etc/init/failsafe.conf and comment out the extra 'wait' time.
As I've seen around the internet, many have used this solution so far.

Well anyway, so far, after till's suggestions on this topic everything works without a problem except the fact that you got to add IPs manually using the gui (one by one) in case you need more server ips.

I've just recently noticed another silly message hidden in the lower right corner (using gnome). it says:

Network service discovery disabled.
Your current network has a .local domain, which is not recommended and incompatible with the Avahi network service discovery. The service has been disabled.


I've been seeing a similar one even on ubuntu 10.04 but I always ignored it. Is there a way to set this off ?
Reply With Quote
  #10  
Old 25th June 2012, 04:52
Bookworm Bookworm is offline
Junior Member
 
Join Date: Aug 2009
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

http://magnus-k-karlsson.blogspot.co...n-network.html

It sounds like you have the full graphic install of Ubuntu (Gnome, I'm assuming, rather than Kubuntu).

You'll want to shut a lot of things off - in fact, if you're using this machine remotely, for the most part, you might want to just remove gnome completely, and use one of the lightweight X managers (if any at all).

As for the network settings - I don't use the network-manager tool. I remove it completely from servers, then do everything by hand - since I have no need/intention of changing the IP addresses once installed. (meaning I modify the interfaces file)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error 12 Invalid Device blinx Installation/Configuration 0 15th January 2011 06:27
Problem send/receive Courier+Postfix+Squirrelmail Pirk Installation/Configuration 2 21st May 2010 14:26
Ubuntu install on software RAID 10 gone wrong lord bucket HOWTO-Related Questions 2 10th May 2010 11:03
Connection timed out on intermail outgoing mails gouravgarg Server Operation 6 5th March 2010 21:31
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 14:49


All times are GMT +2. The time now is 03:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.