#1  
Old 2nd June 2012, 14:55
erkan erkan is offline
Senior Member
 
Join Date: May 2012
Posts: 113
Thanks: 1
Thanked 3 Times in 3 Posts
Default mod security

How do I download and install mod security on Debian 6?
Reply With Quote
Sponsored Links
  #2  
Old 2nd June 2012, 16:42
rosehosting rosehosting is offline
Member
 
Join Date: Jun 2012
Posts: 39
Thanks: 0
Thanked 7 Times in 6 Posts
Default

Quote:
Originally Posted by erkan View Post
How do I download and install mod security on Debian 6?
You can do that by using debian's package manager. So, install 'libapache2-mod-security' if it's not installed already and then you need to actually enable it.

Code:
apt-get update && apt-get upgrade --show-upgraded -y
apt-get install libapache-mod-security -y
a2enmod mod-security
That's how I would install it on a Debian box

Last edited by rosehosting; 2nd June 2012 at 16:54. Reason: typo in the package name. it is libapache-mod-security instead of libapache2-mod-security
Reply With Quote
  #3  
Old 2nd June 2012, 16:45
erkan erkan is offline
Senior Member
 
Join Date: May 2012
Posts: 113
Thanks: 1
Thanked 3 Times in 3 Posts
Default

When I try to install it I get this message:

E: Unable to locate package libapache2-mod-security
Reply With Quote
  #4  
Old 2nd June 2012, 16:53
rosehosting rosehosting is offline
Member
 
Join Date: Jun 2012
Posts: 39
Thanks: 0
Thanked 7 Times in 6 Posts
Default

Quote:
Originally Posted by erkan View Post
When I try to install it I get this message:

E: Unable to locate package libapache2-mod-security
Sorry that was a typo. The package is named as:

Code:
 ┌┤host->root /
 └╼ apt-cache search libapache2-mod-security
libapache-mod-security - Tighten web applications security for Apache
so install 'libapache-mod-security' instead of 'libapache2-mod-security'.
Reply With Quote
  #5  
Old 2nd June 2012, 17:31
erkan erkan is offline
Senior Member
 
Join Date: May 2012
Posts: 113
Thanks: 1
Thanked 3 Times in 3 Posts
 
Default

Yes that worked much better!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mod security and phpmyadmin manarak Installation/Configuration 8 27th August 2012 20:00
Problem with ispconfig 3 staff007 Installation/Configuration 4 10th October 2011 22:17
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 09:20
Mod Security and Suse 10.2 mgross Server Operation 3 6th July 2007 19:07
mod security exclude list. gabrix Server Operation 3 23rd October 2006 18:02


All times are GMT +2. The time now is 06:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.