Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th May 2012, 12:32
Numerizen Numerizen is offline
Member
 
Join Date: Dec 2007
Location: Cherbourg -FRANCE
Posts: 50
Thanks: 18
Thanked 5 Times in 4 Posts
Default Corrupted /etc/shadow

Hello,

I'm not sure if it's a ISPConfig related issue, but you'll tell me.

My server is a Debian 6 installation more or less conform to Falko's perfect server tutorial. ISPConfig is 2.2.35.

My /etc/shadow and /etc/passwd files got corrupted, root account included.

I fortunately managed to recover things (short night), but would like to have a hint of what happened.

Just before everything got down, I was configuring things on a domain name I registered but never used before : http://c-est.la

It is the first domain I configure which is not "standard" (not .fr, .com, .net or .org).

I noticed that my shadow file was truncated just before the users related to that domain.

May ISPConfig have messed up the file because of the unusual domain name ?

Thanks for reading and waiting for the wisdom of the power users around here.

Last edited by Numerizen; 12th May 2012 at 13:35.
Reply With Quote
Sponsored Links
  #2  
Old 13th May 2012, 10:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by Numerizen View Post
May ISPConfig have messed up the file because of the unusual domain name ?
I don't think so, but I suggest you update to 2.2.41.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following 2 Users Say Thank You to falko For This Useful Post:
AbannyvabVask (22nd December 2013), Numerizen (18th June 2012)
  #3  
Old 14th May 2012, 09:02
Numerizen Numerizen is offline
Member
 
Join Date: Dec 2007
Location: Cherbourg -FRANCE
Posts: 50
Thanks: 18
Thanked 5 Times in 4 Posts
Default

OK , I'll do that, if you confirm it won't mess up things more, given everything is not completely repaired (some missing users, etc.).

Also, if you had any hint about the origin of the problem, besides the domain name, just to make myself feel a bit less confused, I'd be very thankful.

PS : 2.2.41 really ? I don't see this version. Am I missing something ?
Reply With Quote
  #4  
Old 15th May 2012, 09:28
Numerizen Numerizen is offline
Member
 
Join Date: Dec 2007
Location: Cherbourg -FRANCE
Posts: 50
Thanks: 18
Thanked 5 Times in 4 Posts
Default

Tried the upgrade to 2.2.40 and got :

Debian 5.0.9
ERROR: Ihr Betriebssystem wird nicht unterst?tzt! / Your operating system is not supported! / Votre systeme d'exploitation n'est pas support?!

______________
Besides, I can't create databases anymore : entries are created in the UI, but the relevant database does not exist.

I tried to create it manually via PhpMyAdmin with root account, but it has not the rights to create databases, which I guess is the same problem, but I can't seem to find a solution to solve it.

Also, /var/log/mysql.log and mysql.err are empty, so I'm suspecting something is badly wrong.

Last edited by Numerizen; 15th May 2012 at 09:58.
Reply With Quote
  #5  
Old 16th May 2012, 09:17
Numerizen Numerizen is offline
Member
 
Join Date: Dec 2007
Location: Cherbourg -FRANCE
Posts: 50
Thanks: 18
Thanked 5 Times in 4 Posts
Default

Still stuck on this. Verified root privileges on mysql, tried different ways but no luck. I can't create any database. I can't really activate mysql logging as it is a production server.

I was asking myself if it would be a good idea to reinstall the same ISPConfig version (2.2.35).

Do you think it would put everything back into place again ?
Reply With Quote
  #6  
Old 16th May 2012, 10:35
Numerizen Numerizen is offline
Member
 
Join Date: Dec 2007
Location: Cherbourg -FRANCE
Posts: 50
Thanks: 18
Thanked 5 Times in 4 Posts
Default

Sorted the databse issue. It happened permissions were wrong on the datadir directory so a chown mysql:mysql did the trick.

I think it happened already, but can't figure why the permissions changed again.
Reply With Quote
  #7  
Old 18th June 2012, 09:45
Numerizen Numerizen is offline
Member
 
Join Date: Dec 2007
Location: Cherbourg -FRANCE
Posts: 50
Thanks: 18
Thanked 5 Times in 4 Posts
 
Default

Thanks to your advice, I did some tests and I could successfully create users on the subdomain. Everything went fine. No /etc/shadow trashing or the like.

The /var/lib/mysql directory keeps reverting to root:root ownership though, and I can't figure why.

Maybe an idea about this ?
Reply With Quote
The Following User Says Thank You to Numerizen For This Useful Post:
AbannyvabVask (21st December 2013)
Reply

Bookmarks

Tags
debian 6, files, shadow, user

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Disk corrupted: files corrupted mike_p General 1 3rd February 2011 05:31
ISPconfig2, problem with pop authentication, /etc/shadow moiseev.igor General 6 26th May 2010 19:41
/etc/shadow and authentication problem on ispconfig + ubuntu moiseev.igor Developers' Forum 5 30th April 2010 11:28
Copiying /etc/shadow with sudo and rsync jnsc Technical 2 17th November 2009 19:42
backups - Archive Corrupted IKShadow General 4 16th May 2007 15:36


All times are GMT +2. The time now is 06:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.