#1  
Old 30th May 2012, 21:35
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default switch to mod_php not working?

Hi guys,

just installed a new server with debian 6 and ispcfg 3.0.4.5. I also cross check the settings with the ones that can be found in the perfect setup just to make sure everything should be fine to work well with the control panel.

Anyhow I face the problem that in neither webpage the switch for the type of php is working properly. In all cases php is used as cgi (phpinfo output for server api: CGI/FastCGI). Also the vhost file does not change at all.
The only switch for php what is working is disabling php.

Any ideas what to check next?
Reply With Quote
Sponsored Links
  #2  
Old 31st May 2012, 08:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,230 Times in 4,099 Posts
Default

Edit the apache suphp config file in /etc/apache2/conf.d/ and check if it contains a addtype statement for .php files, this addtype stamement should be commented out.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 31st May 2012, 08:48
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

So this should end up with no addtype in the vhost's config when setting php to mod_php and in case of suphp there should be this addtype line (like it currently is), right?
Reply With Quote
  #4  
Old 31st May 2012, 09:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,230 Times in 4,099 Posts
Default

No, the addtype is set by ispconfig for each php type in the vhost, it does not matter if you use mod_php or suphp. See vhost file template. Just remove the global addtype in the config file I pointed out.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 31st May 2012, 15:16
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

thanks for the hint. I assume you mean the suphp.conf in /etc/apache2/mods-available/ (or the symlinkg in mods-enabled).

I commented this line out, so now php is used as mod_php.

But the problem just changed. Now I have mod_php or no php, but all other choices in the drop down do not change the behaviour.

Any idea why the checkbox does not result in any change?
Reply With Quote
  #6  
Old 31st May 2012, 15:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,230 Times in 4,099 Posts
Default

Check the vhost file of the affected site to see whoch php mode is enabled for that vhost.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 31st May 2012, 18:10
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

hmm might be that I have not waited long enough, anyhow I missed the point that the cron processes the changes thus I have to wait at least a minute.

so the only error was the addhandler thing. Shall I report this to the bugtracker or will it be fixed in the next release anyway?
Reply With Quote
  #8  
Old 31st May 2012, 22:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,230 Times in 4,099 Posts
 
Default

Thats not a issue in ispconfig, the file is from suphp debian package. The ispconfig generated files are fine and when you follow the perfect setup guide to install ispconfig hn your server will work out of the box.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
my site not working busykid Installation/Configuration 1 27th September 2011 10:55
my site not working busykid Installation/Configuration 1 26th September 2011 20:39
Qemu-kVM setup vm using 2 NIC's are not working muzi Technical 1 14th February 2011 22:27
auto update svn working copy donix Installation/Configuration 0 9th June 2010 20:59
DNS stop working MZH General 3 22nd February 2008 11:10


All times are GMT +2. The time now is 23:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.