#1  
Old 29th May 2012, 13:59
rrijken rrijken is offline
Junior Member
 
Join Date: Feb 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Weird problem

All,

Have ISPconfig 3 installed and have several websites running without problems. Added a new website the other day (birdman-teamholland.org) and installed wordpress on it. Everything ran fine, no problems whatsoever.

Today I come home and find the server turned off, no error in the logs so no idea why, but turned it on again and everything works. Accessing the websites work fine, just the website birdman-teamholland.org gives me an "internal server error" all the time.

If I access the page from a different PC not on my homenetwork then it works fine.

If I turn off Apache all my other websites say, can't access, just the birdman website keeps giving "internal server error". Have no idea anymore and have tried a lot (.htaccess, new install etc.)

What can this be?
Reply With Quote
Sponsored Links
  #2  
Old 30th May 2012, 09:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Please post the error messages from the error.log of the website birdman-teamholland.org that you get there wehn you see the internal server error message in the browser.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th May 2012, 14:58
rrijken rrijken is offline
Junior Member
 
Join Date: Feb 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

That's the weird thing, there is nothing logged in error.log, only 2 entries and none for today, but I just tried to access it from the server:

[Tue May 29 18:28:17 2012] [error] [client 182.249.241.74] File does not exist: /var/www/birdman-teamholland.org/web/wp-content/uploads, referer: http://www.birdman-teamholland.org/
[Tue May 29 18:28:34 2012] [error] [client 182.249.241.74] File does not exist: /var/www/birdman-teamholland.org/web/wp-content/uploads, referer: http://www.birdman-teamholland.org/

Acces.log:

127.0.0.1 - - [30/May/2012:20:00:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [30/May/2012:20:05:01 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [30/May/2012:20:10:01 +0900] "GET / HTTP/1.1" 200 7769 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [30/May/2012:20:15:02 +0900] "GET / HTTP/1.1" 200 7769 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [30/May/2012:20:20:01 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [30/May/2012:20:25:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [30/May/2012:20:30:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [30/May/2012:20:35:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [30/May/2012:20:40:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [30/May/2012:20:45:02 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
127.0.0.1 - - [30/May/2012:20:50:01 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"
180.76.5.150 - - [30/May/2012:20:51:43 +0900] "GET /robots.txt HTTP/1.1" 200 24 "-" "Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2"
180.76.6.225 - - [30/May/2012:20:52:18 +0900] "GET /robots.txt HTTP/1.1" 200 24 "-" "Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2"
127.0.0.1 - - [30/May/2012:20:55:01 +0900] "GET / HTTP/1.1" 200 7773 "-" "Mozilla/5.0 (ISPConfig monitor)"

Have no idea why it works from outside the network, but not from inside where it used to work without problems.... All other sites still work. Server was off yesterday when I came home and that was because of a thunderstorm seems, electricity went off for a few minutes seems, but this cannot be the cause?
Reply With Quote
  #4  
Old 30th May 2012, 14:59
rrijken rrijken is offline
Junior Member
 
Join Date: Feb 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The exact error:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Cleared browser cache, tried another browser, no change. Checked DNS, no problems...
Reply With Quote
  #5  
Old 30th May 2012, 17:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

But it works for computers from outside your network?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 31st May 2012, 02:10
rrijken rrijken is offline
Junior Member
 
Join Date: Feb 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks, yes, from outside the network no problem. All my other websites (3) are accessible though even from inside the network so I cannot understand why this 4th one suddenly stopped working from inside the network.

I was able to set it up from inside the network (install wordpress etc.)...
Reply With Quote
  #7  
Old 1st June 2012, 00:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Do all four web sites use the same local IP?

Did you compare the vhost configurations of all four vhosts?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 1st June 2012, 02:04
rrijken rrijken is offline
Junior Member
 
Join Date: Feb 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks! All 4 use same IP, where do I check vhost configuration?
Reply With Quote
  #9  
Old 1st June 2012, 18:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

If you use Debian/Ubuntu with apache, the vhost configurations are in the /etc/apache2/sites-enabled/ directory.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 3rd June 2012, 15:32
rrijken rrijken is offline
Junior Member
 
Join Date: Feb 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks! Use Fedora 16, but found the vhost files. Here is one from a working site:

<Directory /var/www/more-than-wine.com>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /var/www/more-than-wine.com/web

ServerName more-than-wine.com
ServerAlias www.more-than-wine.com
ServerAdmin webmaster@more-than-wine.com

ErrorLog /var/log/ispconfig/httpd/more-than-wine.com/error.log


<IfModule mod_ssl.c>
</IfModule>

<Directory /var/www/more-than-wine.com/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>
<Directory /var/www/clients/client1/web3/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>

<IfModule mod_ruby.c>
<Directory /var/www/more-than-wine.com/web>
Options +ExecCGI
</Directory>
RubyRequire apache/ruby-run
#RubySafeLevel 0
<Files *.rb>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
<Files *.rbx>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
</IfModule>

<IfModule mod_python.c>
<Directory /var/www/more-than-wine.com/web>
AddHandler mod_python .py
PythonHandler mod_python.publisher
PythonDebug On
</Directory>
</IfModule>

# cgi enabled
<Directory /var/www/clients/client1/web3/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /var/www/clients/client1/web3/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
<IfModule mod_suexec.c>
SuexecUserGroup web3 client1
</IfModule>
# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
# php as fast-cgi enabled
# For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
<IfModule mod_fcgid.c>
IdleTimeout 300
ProcessLifeTime 3600
# MaxProcessCount 1000
DefaultMinClassProcessCount 0
DefaultMaxClassProcessCount 100
IPCConnectTimeout 3
IPCCommTimeout 360
BusyTimeout 300
</IfModule>
<Directory /var/www/more-than-wine.com/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web3/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client1/web3/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web3/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>


# add support for apache mpm_itk
<IfModule mpm_itk_module>
AssignUserId web3 client1
</IfModule>

<IfModule mod_dav_fs.c>
# Do not execute PHP files in webdav directory
<Directory /var/www/clients/client1/web3/webdav>
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
</Directory>
DavLockDB /var/www/clients/client1/web3/tmp/DavLock
# DO NOT REMOVE THE COMMENTS!
# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
# WEBDAV BEGIN
# WEBDAV END
</IfModule>


</VirtualHost>


Here is the one that gives me the internal server error:

<Directory /var/www/birdman-teamholland.org>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /var/www/birdman-teamholland.org/web

ServerName birdman-teamholland.org
ServerAlias www.birdman-teamholland.org
ServerAdmin webmaster@birdman-teamholland.org

ErrorLog /var/log/ispconfig/httpd/birdman-teamholland.org/error.log


<IfModule mod_ssl.c>
</IfModule>

<Directory /var/www/birdman-teamholland.org/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>
<Directory /var/www/clients/client1/web6/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>

<IfModule mod_ruby.c>
<Directory /var/www/birdman-teamholland.org/web>
Options +ExecCGI
</Directory>
RubyRequire apache/ruby-run
#RubySafeLevel 0
<Files *.rb>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
<Files *.rbx>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
</IfModule>

<IfModule mod_python.c>
<Directory /var/www/birdman-teamholland.org/web>
AddHandler mod_python .py
PythonHandler mod_python.publisher
PythonDebug On
</Directory>
</IfModule>

# cgi enabled
<Directory /var/www/clients/client1/web6/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /var/www/clients/client1/web6/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
<IfModule mod_suexec.c>
SuexecUserGroup web6 client1
</IfModule>
# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
# php as fast-cgi enabled
# For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
<IfModule mod_fcgid.c>
IdleTimeout 300
ProcessLifeTime 3600
# MaxProcessCount 1000
DefaultMinClassProcessCount 0
DefaultMaxClassProcessCount 100
IPCConnectTimeout 3
IPCCommTimeout 360
BusyTimeout 300
</IfModule>
<Directory /var/www/birdman-teamholland.org/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web6/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client1/web6/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web6/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>


# add support for apache mpm_itk
<IfModule mpm_itk_module>
AssignUserId web6 client1
</IfModule>

<IfModule mod_dav_fs.c>
# Do not execute PHP files in webdav directory
<Directory /var/www/clients/client1/web6/webdav>
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
</Directory>
DavLockDB /var/www/clients/client1/web6/tmp/DavLock
# DO NOT REMOVE THE COMMENTS!
# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
# WEBDAV BEGIN
# WEBDAV END
</IfModule>


</VirtualHost>

Do not see any differences....
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix/trivial-rewrite digitalage HOWTO-Related Questions 19 13th March 2013 20:02
mail.err warnings and some mail unable to receive HellMind General 4 8th October 2010 20:57
Need some Hints to "The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3]" wahid HOWTO-Related Questions 10 25th August 2010 16:18
help: weird co-domains problem edge Installation/Configuration 2 21st March 2007 09:11
Very WEIRD Problem! Prolly very easy question. drogers1988 Installation/Configuration 2 2nd March 2007 13:56


All times are GMT +2. The time now is 21:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.