Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 25th July 2006, 11:03
zarrelli zarrelli is offline
Member
 
Join Date: Jul 2006
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did and restarted the server. The problem still remain. Here are the new configurations:

homeland:~# cat /etc/hosts
127.0.0.1 localhost.localdomain localhost homeland homeland.zarrelli.org control control.zarrelli.org
88.198.37.43 control control.zarrelli.org homeland homeland.zarrelli.org

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
homeland:~#

# /etc/aliases
mailer-daemon: postmaster
postmaster: root
nobody: root
hostmaster: root
usenet: root
news: root
webmaster: root
www: root
ftp: root
abuse: root
noc: root
security: root
root: giorgio@zarrelli.org

homeland:/etc/postfix# cat main.cf
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = homeland.zarrelli.org
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = zarrelli.org, localhost.localdomain, localhost.localdomain, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names

homeland:/etc/postfix# cat local-host-names
###################################
#
# ISPConfig local-host-names Configuration File
# Version 1.0
#
###################################
localhost
homeland.zarrelli.org.localdomain
localhost.homeland.zarrelli.org.localdomain
localhost.zarrelli.org.localdomain
www.zarrelli.org
www.wavetechnology.it
www.xforce.it
wavetechnology.it
zarrelli.org
xforce.it
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####homeland:/etc/postfix#

homeland:/etc/postfix# cat /etc/hostname
homeland.zarrelli.org

homeland:/etc/postfix# cat /etc/hostname
homeland.zarrelli.org
Reply With Quote
Sponsored Links
  #12  
Old 25th July 2006, 11:04
zarrelli zarrelli is offline
Member
 
Join Date: Jul 2006
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I forgot...

homeland:/etc/postfix# hostname
homeland.zarrelli.org
homeland:/etc/postfix# hostname -f
localhost.localdomain
homeland:/etc/postfix#
Reply With Quote
  #13  
Old 25th July 2006, 11:35
todvard todvard is offline
Member
 
Join Date: Aug 2005
Posts: 85
Thanks: 1
Thanked 6 Times in 5 Posts
Default

try to change your hosts file to look like this:

homeland:~# cat /etc/hosts
127.0.0.1 localhost.localdomain localhost
88.198.37.43 control.zarrelli.org control homeland.zarrelli.org homeland

after the change the otput of hostname command should look like this:

homeland:/etc/postfix# hostname
homeland.zarrelli.org
homeland:/etc/postfix# hostname -f
homeland.zarrelli.org
Reply With Quote
  #14  
Old 25th July 2006, 14:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by todvard
try to change your hosts file to look like this:

homeland:~# cat /etc/hosts
127.0.0.1 localhost.localdomain localhost
88.198.37.43 control.zarrelli.org control homeland.zarrelli.org homeland

after the change the otput of hostname command should look like this:

homeland:/etc/postfix# hostname
homeland.zarrelli.org
homeland:/etc/postfix# hostname -f
homeland.zarrelli.org
You might have to reboot the system, too.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 25th July 2006, 22:58
redweb redweb is offline
Junior Member
 
Join Date: Jul 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am having this same exact issue. (Ubuntu 5.10, ISPConfig

Just upgraded yesterday to 2.2.5 from 2.2.3. I've upgraded before without issue.

**UPDATE**

When the catchall is enabled I cannot use a mail client (TBird or outlook) because I get a server timeout error however when I turn off the catchall I can then log in with my email client.

I've run through suggestions above and my system look to be set up in the same manner as Zarelli and output looks to be good as well.

I have made other changes yesterday as well. Changed hostname but tested before upgrade and server was functioning. I've gone through postfix walkthrough as described on the perfect setup for 5.10 as well as rechecked DNS (using registrar for DNS)

--Will be happy to provide logs, files everything but physical access to the server to help resolve this issue.

Last edited by redweb; 25th July 2006 at 23:33.
Reply With Quote
  #16  
Old 26th July 2006, 09:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,796
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Quote:
(TBird or outlook) because I get a server timeout error
When you want to send or receive mail?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #17  
Old 30th July 2006, 05:32
redweb redweb is offline
Junior Member
 
Join Date: Jul 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
When you want to send or receive mail?
Yes when I crank up tbird or outlook it won't even let me connect to my mail server as I get the timeout pop-up. Works as it should when I turn off the catchall.
Reply With Quote
  #18  
Old 31st July 2006, 16:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

What's the output of
Code:
netstat -tap
when you can't connect with Outlook or Thunderbird?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
POP3 and IMAP strange behaviour zarrelli Installation/Configuration 2 24th July 2006 00:47
Strange Salutatory Email helfrez Installation/Configuration 3 18th May 2006 21:44
Strange Behaviour ratebri General 2 30th November 2005 12:57
Strange behaviour of foreach in PHP 4.3.11 minimi Programming/Scripts 3 30th May 2005 20:20


All times are GMT +2. The time now is 06:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.