Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd July 2006, 21:11
tarndt tarndt is offline
Junior Member
 
Join Date: Jun 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default .htaccess and .htpasswd files in symbolic link directories.

I have a symbolic link in one of my accounts created in ISPConfig:

So in
/home/www/web8
I have:
web -> /var/www/html/dealer/

Question is...How do I password protect this directory. Because the directory is owned by another user, it does not show in Web_FTP.
So I password protect another folder, and modified the .htaccess file and moved to the /var/www/html/dealer folder. This however returns a 500 Internal Server Error. Ownership of the .htacess and .htpasswd files are associated with the web8 user. I have also tried specifying the .htpasswd as both the symbolic link and the actual directory from within the .htaccess file. Any suggestions?
Reply With Quote
Sponsored Links
  #2  
Old 24th July 2006, 16:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Did you have a look here? http://httpd.apache.org/docs/2.0/howto/auth.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 25th July 2006, 20:51
tarndt tarndt is offline
Junior Member
 
Join Date: Jun 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ya, I had it set up in httpd.conf before installing ISPConfig. It seems as though after installin ISPConfig however, these directives are being ignored. Any other suggestions?
Reply With Quote
  #4  
Old 26th July 2006, 08:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
Originally Posted by tarndt
Ya, I had it set up in httpd.conf before installing ISPConfig. It seems as though after installin ISPConfig however, these directives are being ignored. Any other suggestions?
The WebFTP uses also authentication with .htpassword files to protect directories, so this feature is enabled for the websites in ISPConfig.

Please check your .htaccess and .htpasswd file if the directives are correct.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 26th July 2006, 10:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Also have a look at Apache's error log.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.