Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 18th May 2012, 19:21
erkan erkan is offline
Senior Member
 
Join Date: May 2012
Posts: 113
Thanks: 1
Thanked 3 Times in 3 Posts
Default

Yes I know, I just need to know if this setup would work for my site or if I need to look for something else.

Ok I have now downloaded ISPConfig, what do I need to run in order to start the installation?
Reply With Quote
Sponsored Links
  #12  
Old 18th May 2012, 19:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Before you install ispconfig, ensure that you configured your server as described in the perfect setup guide as these are the install requirements for ispconfig. The perfects etuo guide contains also the instructions to install ispconfig, the only difference is that you downloaded it from svn and not with wget.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 18th May 2012, 19:31
erkan erkan is offline
Senior Member
 
Join Date: May 2012
Posts: 113
Thanks: 1
Thanked 3 Times in 3 Posts
Default

I have done that but I can´t get the installer to start.

After downloaded I tried to run: cd ispconfig3_install/install/

And: php -q install.php

But nothing works.
Reply With Quote
  #14  
Old 18th May 2012, 20:59
erkan erkan is offline
Senior Member
 
Join Date: May 2012
Posts: 113
Thanks: 1
Thanked 3 Times in 3 Posts
Default

I got the installation to start now! But ISPConfig says I have version 3.0.4.4, shouldn´t it say I have 3.0.5?
Reply With Quote
  #15  
Old 18th May 2012, 23:40
erkan erkan is offline
Senior Member
 
Join Date: May 2012
Posts: 113
Thanks: 1
Thanked 3 Times in 3 Posts
Default

Ok I have gotten ISPonfig and PHP-FPM up and working now. I have also created a site and uploaded a website but all I get is a 500 internal server error.

http://www.ffatest.se/

Is it a bug or is it me that haven´t configured PHP-FPM properly?
Reply With Quote
  #16  
Old 19th May 2012, 11:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Please check your logs.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 19th May 2012, 13:21
erkan erkan is offline
Senior Member
 
Join Date: May 2012
Posts: 113
Thanks: 1
Thanked 3 Times in 3 Posts
Default

Which log? I checked all the logs in ISPConfig but most of them where empty.

Except PHP-FPM and what this guide says I should install: http://www.howtoforge.com/perfect-se...ispconfig-3-p3 do I need to instal anything else to get PHP-FPM working?

Last edited by erkan; 19th May 2012 at 13:42.
Reply With Quote
  #18  
Old 19th May 2012, 15:55
erkan erkan is offline
Senior Member
 
Join Date: May 2012
Posts: 113
Thanks: 1
Thanked 3 Times in 3 Posts
Default

It seems that I have installed mod_fcgid instead of mod_fastcgi that must be why PHP-FPM isn´t working.
Reply With Quote
  #19  
Old 19th May 2012, 16:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by erkan View Post
It seems that I have installed mod_fcgid instead of mod_fastcgi that must be why PHP-FPM isn´t working.
That's right - see chapter 14.2 on http://www.howtoforge.com/perfect-se...ispconfig-3-p4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 19th May 2012, 17:12
erkan erkan is offline
Senior Member
 
Join Date: May 2012
Posts: 113
Thanks: 1
Thanked 3 Times in 3 Posts
 
Default

I tried running:

apt-get install libapache2-mod-fastcgi

But it won´t install. It just says:

Package libapache2-mod-fastcgi is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libapache2-mod-fastcgi' has no installation candidate

Do you know what the problem is?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Only Problems since Updating from 3.0.3.3 to 3.0.4.1 mbay General 4 17th May 2012 13:56
Control Panel - E-mail Tab is empty domi-nik General 15 14th April 2011 19:17
PHP warnings after upgrade to ISP config 3.03 stevegjacobs Installation/Configuration 5 30th October 2010 15:31
network issues now it says "401 The web site is blocked by administrator" Check General 3 26th February 2008 15:22
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18


All times are GMT +2. The time now is 18:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.