#1  
Old 10th January 2012, 16:49
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 322
Thanks: 55
Thanked 88 Times in 54 Posts
Send a message via Skype™ to Horfic
Default VirtualHost overlaps

Hi,
I received after the update from 3.0.4.1 to 3.0.4.2 the apache error
Code:
apache2[Tue Jan 10 16:26:11 2012] [warn] VirtualHost xx.xx.xx.xx:80 overlaps with VirtualHost xx.xx.xx.xx:80, the first has precedence, perhaps you need a NameVirtualHost directive
 ... waiting [Tue Jan 10 16:26:12 2012] [warn] VirtualHost xx.xx.xx.xx:80 overlaps with VirtualHost xx.xx.xx.xx:80, the first has precedence, perhaps you need a NameVirtualHost directive
What happend is, that obviously ispconfig reconfigured everything but forgot to add the ip in the ports.conf from apache2. So I had to add the ip with

NameVirtualHost xx.xx.xx.xx:80 manually

Did anybody else got this error after upgrade?
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
Sponsored Links
  #2  
Old 10th January 2012, 16:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

The namevirtualhost directives are not in ports.conf on a ispconfig 3 server, they are in the ispconfig.conf file instead. So please remove the entry from ports.conf as it can cause the system to fail when ISPConfig adds the namevirtualhost directive in its configuration. Then login to ispconfig and check under System > Server IP if you added the IP there and if the namevirtualhost checkbox for this IP is enabled.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th January 2012, 17:02
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 322
Thanks: 55
Thanked 88 Times in 54 Posts
Send a message via Skype™ to Horfic
Default

Yes it was/is checked and added.

So why didn't he add it into the file when he updated?

PS: Changed it
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3

Last edited by Horfic; 10th January 2012 at 17:04.
Reply With Quote
  #4  
Old 10th January 2012, 17:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Tested it here again and the namevirtualhost lines had been added automatically by the updater on my server. I dont know why it did not work on your system.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 20th May 2012, 08:40
ras ras is offline
Junior Member
 
Join Date: Jul 2011
Posts: 7
Thanks: 2
Thanked 2 Times in 1 Post
 
Default Port dependency?

Same problem here, when IP address in ISPconfig setting was associated with 443 port only.
Assigned with "80,443" again.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
403 Forbidden gillesdevals Installation/Configuration 13 5th December 2010 17:48
server crashed, tried to restore, sites don't load crypted Installation/Configuration 3 30th November 2010 16:49
ssl problems stevegjacobs Installation/Configuration 5 30th October 2010 17:16
ISPConfig 3.0.0.8 RC1 released till General 92 22nd February 2010 09:52
PHP doesn't work! JimmiJames Server Operation 1 30th January 2007 12:30


All times are GMT +2. The time now is 06:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.