Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 18th May 2012, 15:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Please try to use the vlogger version from Ubuntu to see if you get the same problems there:

apt-get install vlogger

then edit the file:

/etc/apache2/sites-available/ispconfig.conf

and replace the line:

Code:
CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" -d \"/etc/vlogger-dbi.conf\" /var/log/ispconfig/httpd" combined_ispconfig
with:

Code:
CustomLog "| /usr/sbin/vlogger -s access.log -t \"%Y%m%d-access.log\" -d \"/etc/vlogger-dbi.conf\" /var/log/ispconfig/httpd" combined_ispconfig
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #22  
Old 18th May 2012, 16:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

And check if the dependencies are installed:

apt-get install libdbi-perl libtimedate-perl
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #23  
Old 18th May 2012, 16:13
jumba jumba is offline
Member
 
Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Vlogger from Ubuntu and all its dependencies were already installed during the perfect server setup.

I replaced the old line with the new one in ispconfig.conf and now I get:
Code:
DBI connect('database=dbispconfig;host=localhost:3306','ispconfig',...) failed: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) at /usr/sbin/vlogger line 507
Code:
DBI Error:  at /usr/sbin/vlogger line 507, <STDIN> line 60.
Code:
piped log program ' /usr/sbin/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Reply With Quote
  #24  
Old 18th May 2012, 16:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Please check the file /etc/vlogger-dbi.conf and compare the database name, username and password in that file if they are identical with the ones in the file /usr/local/ispconfig/interface/lib/config.inc.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #25  
Old 18th May 2012, 16:42
jumba jumba is offline
Member
 
Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, the database name, username and password are identical.
Reply With Quote
  #26  
Old 18th May 2012, 16:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

There seems to be a general problem that perl cant connect to a mysql server. Try to change the:

host=localhost

to

host=127.0.0.1

in the /etc/vlogger-dbi.conf file and restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #27  
Old 18th May 2012, 17:08
jumba jumba is offline
Member
 
Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, I did that.
Now, with Vlogger from Ubuntu I get this:
Code:
piped log program ' /usr/sbin/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Code:
DBD::mysql::db do failed: Table 'dbispconfig.wwwusage' doesn't exist at /usr/sbin/vlogger line 521, <STDIN> line 104.
DBD::mysql::st execute failed: Table 'dbispconfig.wwwusage' doesn't exist at /usr/sbin/vlogger line 514, <STDIN> line 104.
Reply With Quote
  #28  
Old 18th May 2012, 17:14
jumba jumba is offline
Member
 
Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

and if I change back to the original Vlogger in ispconfig.conf, I get the old error
Code:
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Reply With Quote
  #29  
Old 18th May 2012, 17:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Ok, this is most likely caused due to the usage of the vlogger script from ubuntu as ispconfig uses a different table name. Please undo the change of the customlog directive in the ispconfig.conf file that we did in this step:

http://www.howtoforge.com/forums/sho...5&postcount=21

so that the vlogger script from ispconfig is used again, but keep the edited /etc/vlogger-dbi.conf file and check if the problem is solved now.

to sum it up, perl can not connect to mysql on hostname localhost but it can connect to the IP of localhost, now we just have to try to find out what the problem in the mysql or hostname configuration is.

Please post the /etc/hosts file of your server and the output of:

netstat -tap
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #30  
Old 19th May 2012, 22:57
oriongr oriongr is offline
Member
 
Join Date: Nov 2007
Posts: 38
Thanks: 28
Thanked 3 Times in 3 Posts
 
Default

Hi,
I am not sure I have the same error...but for sure vlogger is the cause of the problem.
If I try to run vlogger manually this is what I get
Quote:
/usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd

Use of uninitialized value $vhost in lc at /usr/local/ispconfig/server/scripts/vlogger line 385, <STDIN> line 1.
Use of uninitialized value $reqsize in pattern match (m//) at /usr/local/ispconfig/server/scripts/vlogger line 463, <STDIN> line 1.
Use of uninitialized value $reqsize in numeric gt (>) at /usr/local/ispconfig/server/scripts/vlogger line 463, <STDIN> line 1.
For now I have disabled vlogger..
Reply With Quote
Reply

Bookmarks

Tags
apache 2, vlogger

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with suexec gobokster Installation/Configuration 7 7th May 2009 13:33
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
Apache won't configure cybiko123 Installation/Configuration 1 13th January 2008 10:43
ispconfig installation errors kcmohan Installation/Configuration 1 9th April 2007 20:14
MaxClients set to appropriate level, but ISPconfig is crashing from it (I think) bpmee Server Operation 6 11th January 2007 19:29


All times are GMT +2. The time now is 08:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.