Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd July 2006, 16:54
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Question getting mailgraph spam and virus

I installed mailgraph but do not get spam and virus report.

I think I should enable amavis and spamassassin to log into /var/log/mail.log

I am using ISPconfig, so I should look I think somewhere in
/home/admispconfig/ispconfig/tools#

but what do I need to change to log virus and spam?

many thanks

RayIT
Reply With Quote
Sponsored Links
  #2  
Old 23rd July 2006, 17:21
TheRudy TheRudy is offline
Senior Member
 
Join Date: Dec 2005
Posts: 215
Thanks: 1
Thanked 7 Times in 5 Posts
Default

Heh, i'm about to do the same thing and it seems that you have to install amavisd and configurate it for spam and virus to work in the monitoring.. No idea yet how to do it..

Anyone done this before with Perfect Setup configuration? If so, can someone tell how..

http://www.howtoforge.com/virtual_po...ota_courier_p4

I'm betting that that is not enought for it to work.. Installation and configuring spamassasin..
Reply With Quote
  #3  
Old 23rd July 2006, 23:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
Default

Have a look here:
http://www.ijs.si/software/amavisd/
http://gentoo-wiki.com/HOWTO_Spam_Fi...ostfix,_Amavis
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 24th July 2006, 10:36
TheRudy TheRudy is offline
Senior Member
 
Join Date: Dec 2005
Posts: 215
Thanks: 1
Thanked 7 Times in 5 Posts
Default

great falko! Will look into it and report back how did it go..
Reply With Quote
  #5  
Old 24th July 2006, 13:29
TheRudy TheRudy is offline
Senior Member
 
Join Date: Dec 2005
Posts: 215
Thanks: 1
Thanked 7 Times in 5 Posts
Default

well it didn't work first time
removed everything for now...

installed amavis, configured postfix, configuring amavis: got stuck

questions!
clamav? comes with ispconfig, yes? Can i use that one or do i have to install it? I keep getting that clamav can't be found like errors..
Code:
Jul 24 13:28:46 mercury amavis[21354]: (21354-01) Clam Antivirus-clamd av-scanner FAILED: Too many retries to talk to /var/ru$
Jul 24 13:28:46 mercury amavis[21354]: (21354-01) WARN: all primary virus scanners failed, considering backups
$Clam Antivirus-clamd av-scanner FAILED: Too many retries to talk to /var/run/clamav/clamd.ctl (Can't connect to UNIX socket $
Jul 24 13:28:46 mercury amavis[21354]: (21354-01) PRESERVING EVIDENCE in /var/lib/amavis/amavis-20060724T132839-21354
How do i use the one that comes with ispconfig?

Last edited by TheRudy; 24th July 2006 at 13:35.
Reply With Quote
  #6  
Old 24th July 2006, 15:14
rayit rayit is offline
Member
 
Join Date: Nov 2005
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Default I am trying following

strange normally I always saw virus warnings and spam warnings in my syslog, but this seems to have changed in the new ispconfig???

I tried following....
changing the file
/home/admispconfig/ispconfig/tools/clamav/etc/freshclam.conf
to log in to a file
I changed
# Path to the log file (make sure it has proper permissions)
# Default: disabled
UpdateLogFile /var/log/freshclam

made a file /var/log/freshclam with permissions of admispconfig


I start
mailgraph once with --only-mail-rrd -l /var/log/mail
and once with --only-virus-rrd -l /var/log/amavis.log

so:
/usr/bin/perl -w /usr/sbin/mailgraph.pl --only-mail-rrd -l /var/log/mail.log -d --daemon_rrd=/var/lib/mailgraph --ignore-localhost

/usr/bin/perl -w /usr/sbin/mailgraph.pl --only-virus-rrd -l /var/log/freshclam -d --daemon_rrd=/var/lib/mailgraph --ignore-localhost

I think this is a start??
http://www.rayit.com/cgi-bin/mailgraph.cgi

But is seems not to work????

Any suggestions, also spam does not yet work..
Reply With Quote
  #7  
Old 24th July 2006, 16:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
Default

Quote:
Originally Posted by TheRudy
clamav? comes with ispconfig, yes? Can i use that one
Yes, but you need to adjust the paths to ClamAV in your amavisd.conf.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 24th July 2006, 16:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
Default

Quote:
Originally Posted by rayit
strange normally I always saw virus warnings and spam warnings in my syslog, but this seems to have changed in the new ispconfig???
This has nothing to do with ISPConfig. You need to install amavisd.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 25th July 2006, 11:46
TheRudy TheRudy is offline
Senior Member
 
Join Date: Dec 2005
Posts: 215
Thanks: 1
Thanked 7 Times in 5 Posts
Default

Quote:
Originally Posted by falko
Yes, but you need to adjust the paths to ClamAV in your amavisd.conf.
Right, i missed that part of the question.. Where is ClamAV? I can find config file but not the rest.. Probably looking at the wrong place AGAIN..

btw, what's the command to update 'database' of locate function? If you install something new, locate can't find it so i need to update the 'database'..
Reply With Quote
  #10  
Old 25th July 2006, 13:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
 
Default

Quote:
Originally Posted by TheRudy
Right, i missed that part of the question.. Where is ClamAV? I can find config file but not the rest.. Probably looking at the wrong place AGAIN..
It's in /home/admispconfig/ispconfig/tools/clamav.

Quote:
Originally Posted by TheRudy
btw, what's the command to update 'database' of locate function? If you install something new, locate can't find it so i need to update the 'database'..
The command is
Code:
updatedb
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mailgraph Ovidiu Tips/Tricks/Mods 31 18th October 2007 13:35
Mailgraph & logs MathieuMa General 7 3rd July 2006 10:48
Spam vpns2000 Installation/Configuration 7 3rd May 2006 18:07


All times are GMT +2. The time now is 09:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.