Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th May 2012, 11:49
Penny Penny is offline
Junior Member
 
Join Date: May 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default Domain name with emphasis ???

Bonjour,
Depuis quelques jours en france nous avons la possibilité d'enregistrer des noms de domaines avec accents. ISCONFIG n'accepte pas les accents dans les noms de domaines lorsque l'on ajoute un "Site internet" dans la panneau de configuration.
Quelqu'un aurait la solution pour contourner cette problématique ?


------ English ------


Hello,
Since a few days in France we have the ability to record domain names with accents. Isconfig does not accept accents in domain names when adding a "website" in the Control Panel.
Someone would have the workaround for this problem?
Reply With Quote
Sponsored Links
  #2  
Old 7th May 2012, 13:45
cfoe cfoe is offline
ISPConfig Developer
 
Join Date: Oct 2011
Location: NRW, Germany
Posts: 233
Thanks: 27
Thanked 57 Times in 32 Posts
Send a message via Skype™ to cfoe
Default

I do not have a workaround but I would like to give you the following advise:
Try not to use TLDs with special characters. In Germany it is use domains with "umlauts" but I do not see why this must be.
TLDs with special characters do cause a lot of problems for a lot of users and will for a long while.
Reply With Quote
  #3  
Old 7th May 2012, 15:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,173 Times in 4,055 Posts
Default

You can use domains with all kins of special chars incl. umlauts and accents in ISPConfig, you just have to enter them in IDN encoding.

http://en.wikipedia.org/wiki/Interna...ed_domain_name
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 7th May 2012, 17:16
misterm misterm is offline
Senior Member
 
Join Date: Aug 2005
Posts: 513
Thanks: 13
Thanked 7 Times in 6 Posts
Question

yes :

http://www.itespresso.fr/noms-de-dom...iod-52989.html

Last edited by misterm; 7th May 2012 at 17:20.
Reply With Quote
  #5  
Old 8th May 2012, 10:25
Penny Penny is offline
Junior Member
 
Join Date: May 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

http://img171.imageshack.us/img171/3405/isperror.jpg

I can't add a domain name in my panel ...
Reply With Quote
  #6  
Old 8th May 2012, 10:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,173 Times in 4,055 Posts
Default

You entered the domain name in wrong encoding as I explained you in my post #7 in this thread. Please read the wikipedia article if you dont know what punicode encoding is and why it is required to add domains as idn strings. You have to enter it IDN encoding as all web services like apache, postfix etc. reqzuire it as idn domain name.

The correct naming of your domain is:

xn--pte--dent-t1as.com

as thats the name that the domain is used in the internet technically.

Check the registry were you registered the domain, they should have a punicode converter or show you the domain as punicode in the registration email as well.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 8th May 2012 at 10:39.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Penny (8th May 2012)
  #7  
Old 8th May 2012, 10:46
Penny Penny is offline
Junior Member
 
Join Date: May 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by cfoe View Post
I do not have a workaround but I would like to give you the following advise:
Try not to use TLDs with special characters. In Germany it is use domains with "umlauts" but I do not see why this must be.
TLDs with special characters do cause a lot of problems for a lot of users and will for a long while.
All browsers support them for quite some time.
And I need to use a specific domain, which contains the character "â".
Reply With Quote
  #8  
Old 8th May 2012, 10:48
Penny Penny is offline
Junior Member
 
Join Date: May 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
You entered the domain name in wrong encoding as I explained you in my post #7 in this thread. Please read the wikipedia article if you dont know what punicode encoding is and why it is required to add domains as idn strings. You have to enter it IDN encoding as all web services like apache, postfix etc. reqzuire it as idn domain name.

The correct naming of your domain is:

xn--pte--dent-t1as.com

as thats the name that the domain is used in the internet technically.

Check the registry were you registered the domain, they should have a punicode converter or show you the domain as punicode in the registration email as well.
Thank you, I will test this, I had mistranslated your answer
Reply With Quote
  #9  
Old 8th May 2012, 10:54
Penny Penny is offline
Junior Member
 
Join Date: May 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till View Post
You entered the domain name in wrong encoding as I explained you in my post #7 in this thread. Please read the wikipedia article if you dont know what punicode encoding is and why it is required to add domains as idn strings. You have to enter it IDN encoding as all web services like apache, postfix etc. reqzuire it as idn domain name.

The correct naming of your domain is:

xn--pte--dent-t1as.com

as thats the name that the domain is used in the internet technically.

Check the registry were you registered the domain, they should have a punicode converter or show you the domain as punicode in the registration email as well.

Thank you it works with the field I wanted I did not know the standard for domain names.
Anyway thank you for your quick response.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with Baruwa - The Perfect Spamsnake Ubuntu 10.10 neofire HOWTO-Related Questions 44 31st May 2011 15:09
Postfix queue problem? murunix Server Operation 7 2nd May 2011 01:55
Postfix not forwarding for some domains flappy Installation/Configuration 3 21st November 2010 17:57
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49


All times are GMT +2. The time now is 01:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.