Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th July 2006, 08:08
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 12 Times in 10 Posts
Default Serious issue when creating unix accounts

Hi,

I found an interesting problem.

I created some site users (web1_user1, web2_user2, etc) and then had to create some users for other services which useradd automatically used the next uid but I think ISPconfig is keeping track of this uid value somehow as then next site user I created overlapped the uid.

So I have a couple of sites which are owned by 2 users with the same uid.

I have since deleted the users accounts and recreated them using 'useradd myname -u 500' etc.. but wanted to let you know if ISPConfig is keeping track of the uid then this is dangerous.
Reply With Quote
Sponsored Links
  #2  
Old 27th July 2006, 08:41
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,414
Thanks: 812
Thanked 5,204 Times in 4,080 Posts
 
Default

ISPConfig is keeping track of its own userid's in the database, it is not recommended to use other tools to create users above the min. userid you set to be reserved for ISPConfig under management > server > settings on the tab "other".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
php script injections Grizzly General 21 18th July 2006 08:55
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48
POP3 login error /Suse perfect set up 9.3 gimhan90 Server Operation 29 18th February 2006 11:33
Virtual Users And Domains With Postfix, Courier And Mysql....help needed MrMattles HOWTO-Related Questions 9 13th February 2006 09:50


All times are GMT +2. The time now is 09:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.