Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th October 2011, 19:12
uteliux uteliux is offline
Junior Member
 
Join Date: Mar 2011
Posts: 27
Thanks: 2
Thanked 1 Time in 1 Post
Default Hello, i have problem with postfix after update to ubuntu 11.04

Hello, i have problem with postfix after update to ubuntu 11.04. Problem starter just after update. I cant send email from email clients outlook or thunderbird (error i got Relay access denied ) and asks for passwords?? P.S. i can get new mail. But moust interesting that i can send/recieve email thrue squirrelmail... in log files i see:

mail.log
Oct 17 19:43:02 **** postfix/smtpd[2256]: NOQUEUE: reject: RCPT from hst-226-133.444us.lt[11.11.222.124]: 554 5.7.1 <****@gmail.com>: Relay access denied; from=<arturas@*****.lt> to=<****.lap@gmail.com> proto=ESMTP helo=<[192.168.1.104]>

this error i saw just after update in mail.err

Oct 17 16:03:22 ******** postfix/smtpd[30104]: fatal: no SASL authentication mechanisms
Oct 17 16:10:22 ******** postfix/smtp[22220]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
Oct 17 16:10:23 ******** postfix/error[22228]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
Oct 17 16:10:24 ******** postfix/qmgr[22216]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
Oct 17 17:05:09 ******** spamd[1328]: spamd: respawning server at /usr/sbin/spamd line 1140.

mabey someone can hellp? and sorry for my english...
Reply With Quote
Sponsored Links
  #2  
Old 17th October 2011, 19:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Do you use ispconfig 3 on that server? Or is this the postfix virtual user setup from falko?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th October 2011, 19:49
uteliux uteliux is offline
Junior Member
 
Join Date: Mar 2011
Posts: 27
Thanks: 2
Thanked 1 Time in 1 Post
Default

this is ubuntu perfect server with ispconfig 3 http://www.howtoforge.com/perfect-se...at-ispconfig-3
Reply With Quote
  #4  
Old 17th October 2011, 19:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Most likely the update has overwritten some config files. First you should check if mysql is working, e.g. with this command:

netstat -tap | grep mysql

If mysql works, then you can use the ispconfig update script to rebuild the config files. Download ispconfig 3.0.3.3 tar.gz, unpack it and run the update.php script which is in the install folder. Choose "yes" when the updater asks you if the services shall be reconfigured.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th October 2011, 20:00
uteliux uteliux is offline
Junior Member
 
Join Date: Mar 2011
Posts: 27
Thanks: 2
Thanked 1 Time in 1 Post
Default

tcp 0 0 *:mysql *:* LISTEN 1056/mysqld
tcp 0 0 localhost.localdo:33074 localhost.localdo:mysql ESTABLISHED 1365/amavisd (ch9-a
tcp 0 0 localhost.localdo:mysql localhost.localdo:33074 ESTABLISHED 1056/mysqld
tcp 0 0 localhost.localdo:59605 localhost.localdo:mysql ESTABLISHED 1366/amavisd (ch9-a
tcp 0 0 localhost.localdo:mysql localhost.localdo:59605 ESTABLISHED 1056/mysqld

so... i need to try reconfigure ispconfig?
Reply With Quote
  #6  
Old 17th October 2011, 20:03
uteliux uteliux is offline
Junior Member
 
Join Date: Mar 2011
Posts: 27
Thanks: 2
Thanked 1 Time in 1 Post
Default

i already have newest ispconfig...

There are no updates available for ISPConfig 3.0.3.3
Reply With Quote
  #7  
Old 17th October 2011, 21:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please do the exact steps that I described above. It does not matter for that if the intalled version is the latest version.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 18th October 2011, 08:07
uteliux uteliux is offline
Junior Member
 
Join Date: Mar 2011
Posts: 27
Thanks: 2
Thanked 1 Time in 1 Post
Default

Till, i reconfigured like you said, same problem persist.... logs shows same problem, i can get mail but cant send, from external clients.... everything else works fine...
Reply With Quote
  #9  
Old 18th October 2011, 08:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please try this:

Code:
sudo apt-get install libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql
and then restart postfix and saslauthd.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 18th October 2011, 08:30
uteliux uteliux is offline
Junior Member
 
Join Date: Mar 2011
Posts: 27
Thanks: 2
Thanked 1 Time in 1 Post
 
Default

libpam-mysql is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.

and logs show:

Oct 18 09:24:10 ******* postfix/smtpd[4495]: connect from karamele.******* .lt[******* .177]
Oct 18 09:24:10 ******* postfix/smtpd[4495]: warning: karamele.******* .lt[******* .177]: SASL LOGIN authentication failed: no mechanism available
Oct 18 09:24:10 ******* postfix/smtpd[4495]: lost connection after AUTH from karamele.******* .lt[******* .177]
Oct 18 09:24:10 ******* postfix/smtpd[4495]: disconnect from karamele.******* .lt******* .177]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
Vhosts...conf not synced to changes crypted General 50 24th April 2010 00:54
Connection timed out on intermail outgoing mails gouravgarg Server Operation 6 5th March 2010 20:31
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40


All times are GMT +2. The time now is 04:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.