Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st July 2006, 13:25
lipp9000 lipp9000 is offline
Junior Member
 
Join Date: Jul 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy iexplorer FTP NOT WORKING, webftp & cuteftp works tho?

I followed the how-to-forge installation guide for Fedora Core 5 and installed ISP config. I have a couple users who have sites and I can access their FTP through the Web-FTP, and also through CuteFTP with their username and password, but in internet explorer if i go to ftp.mydomain.com, and fill in my user and pw I get a "An error occured opening that folder on the FTP server. Make sure you have permission to access that folder. Details: A connection with the server could not be established."

The same error occurs if i try to access ftp://usernameassword@mydomain.com .

I have seen a few threads with the same problem and have followed their methods and I am still stuck with the same problem.

I tried commenting out..
DefaultRoot ~
Include /etc/proftpd_ispconfig.conf

in the proftpd.conf, restarted the server and still same problem, although this fixed someone elses problem. I also tried deleting the default server 127.0.0.0 in the ispconfigproftpd conf file, restarted the server and same problem.

How can I fix this?? Thanks in advance.

Last edited by lipp9000; 21st July 2006 at 13:35.
Reply With Quote
Sponsored Links
  #2  
Old 21st July 2006, 14:36
fobicodam fobicodam is offline
Senior Member
 
Join Date: Apr 2006
Location: Argentina
Posts: 346
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to fobicodam
Default

Looks like a firewall problem, i access my ftp sites with explorer with no problems.

Try to disable the firewall or (in iexplorer) Tools/Options/ Disable Pasive mode.
Reply With Quote
  #3  
Old 21st July 2006, 14:47
lipp9000 lipp9000 is offline
Junior Member
 
Join Date: Jul 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OMG UR A LEGEND!

It works now, but wot does disabling passive mode mean?? why can't i access it with passive mode on, is there a setting or config i need to change??

otherwise all users will have to disable passivle mode IF they tried to access ftp via iexplorer.
Reply With Quote
  #4  
Old 21st July 2006, 15:01
fobicodam fobicodam is offline
Senior Member
 
Join Date: Apr 2006
Location: Argentina
Posts: 346
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to fobicodam
Default

It quitte hard to explain how pasive mode works with my small english , FTP use port 21 to comunicate but with pasive mode it use alternative ports to do it faster. I had to disable the ispconfig firewall to make it works, but using normal mode ftp is fine too, slow, but fine.
Reply With Quote
  #5  
Old 21st July 2006, 15:10
lipp9000 lipp9000 is offline
Junior Member
 
Join Date: Jul 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Wink

i have just realized that it works even with passive mode on, i just have to add www. before my domain when im going to ftp.mydomain.com

if i go 2 ftp://mydomain.com i am still prompted for user and pw but it doesnt work.

But if i go 2 ftp://www.mydomain.com i get prompted but i can log in.

weird, same problem with my email, emails only get sent to user@www.mydomain.com , and dont get sent to user@mydomain.com


But many thanks anyway
Reply With Quote
  #6  
Old 22nd July 2006, 15:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
 
Default

Quote:
Originally Posted by lipp9000
weird, same problem with my email, emails only get sent to user@www.mydomain.com , and dont get sent to user@mydomain.com
Make sure you added a Co-Domain mydomain.com (without host!) to the www.mydomain.com web site in ISPConfig. Also, make sure that mydomain.com is pointing to the correct IP address. You can test that with
Code:
dig mydomain.com
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.