Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st April 2012, 15:22
MaddinXx MaddinXx is offline
Senior Member
 
Join Date: Jul 2011
Location: Switzerland
Posts: 200
Thanks: 26
Thanked 65 Times in 48 Posts
Default Using mod_spdy With Apache2 On Debian Squeeze - ISPConfig Problem

Hello

I followed the tutorial to install mod_spdy on my ISPConfig Web Server and got it running.

However there seems to be compability problems with the ISPConfig Control Panel. Whenever I login to ISPConfig, the navigations are not working (top-/sidenavigation).

I would really appreciate it if this could be checked

For the moment, everyone else having this problem can manually edit the ispconfig.vhost in /etc/apache2/sites-available and add:

<IfModule spdy_module>
# Turn on mod_spdy. To completely disable mod_spdy, you can set
# this to "off".
SpdyEnabled off
</IfModule>

to deactivate spdy for the CP.

Regards,
MaddinXx
Reply With Quote
The Following User Says Thank You to MaddinXx For This Useful Post:
till (23rd April 2012)
Sponsored Links
  #2  
Old 22nd April 2012, 12:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

I've added this to our bugtracker, however I'm not sure if this is something we must fix. I think this is something the mod_spdy project should check (maybe there are incompatibilites with Ajax?). I suggest you fule a bug report there as well.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd April 2012, 13:16
MaddinXx MaddinXx is offline
Senior Member
 
Join Date: Jul 2011
Location: Switzerland
Posts: 200
Thanks: 26
Thanked 65 Times in 48 Posts
Default

Hi falko

OK I will get in touch with them to check and let you know.

Thank you.

Regards,
MaddinXx
Reply With Quote
  #4  
Old 27th April 2012, 15:59
theWeird theWeird is offline
Member
 
Join Date: Nov 2009
Posts: 70
Thanks: 11
Thanked 6 Times in 5 Posts
Default

I tried using mod_speedy with roundcube.
Same here.
You just have to open Firebug and use roundcube for 1-2 minutes and the console is filled up with errors thrown by the ajax requests.
Reply With Quote
  #5  
Old 18th June 2012, 19:14
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 50 Times in 28 Posts
Default

According to the ticket that was submitted to spdy_devs, this is not an issue with spdy. It is an issue with ISPConfig using mod_php instead if mod_fcgi for serving php? Is there an easy way to switch the panel to mod_fcgi?
Reply With Quote
  #6  
Old 18th June 2012, 19:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Ok, so mod_spy is not compatible with mod_php? Then you should disable mod_php on your server if you want to use mod_spdy. Fastcgi is used automatically in that case by ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 18th June 2012, 19:30
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 50 Times in 28 Posts
Default

Till,

According to this page http://code.google.com/p/mod-spdy/issues/detail?id=41 that is the case. Do I just remove that package from my install to fix it?
Reply With Quote
  #8  
Old 19th June 2012, 18:23
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 50 Times in 28 Posts
Default

Any ideas here? I just want to tell ISPConfig to use fastcgi by default.
Reply With Quote
  #9  
Old 19th June 2012, 21:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Just uninstall mod_php, ispconfig will use fastcgi automatically then. Installing mod_php makes no sense as most cms systems use ajax today so you cant use any of them with mod_php and mod_spdy.

To disable mod_php run:

a2dismod php5

(for Debian and Ubuntu).
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 19th June 2012, 21:27
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 50 Times in 28 Posts
 
Default

Quote:
Originally Posted by till View Post
Just uninstall mod_php, ispconfig will use fastcgi automatically then. Installing mod_php makes no sense as most cms systems use ajax today so you cant use any of them with mod_php and mod_spdy.

To disable mod_php run:

a2dismod php5

(for Debian and Ubuntu).
But I don't want to do that. I want to keep that in case someone wants to use it on the server. Is there no way to force it in the config?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Squeeze ISPConfig 2 issues nellynel Installation/Configuration 1 27th January 2012 09:39
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 13:04
table lookup problem aurelius Installation/Configuration 5 2nd November 2011 20:12
Sending email issue lezelf Installation/Configuration 15 9th August 2011 12:20
Loads of mysql connections to dbispconfig StrikerNL General 2 5th March 2009 15:31


All times are GMT +2. The time now is 00:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.