Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th April 2012, 17:27
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,268
Thanks: 84
Thanked 25 Times in 21 Posts
Default how to temporarily disable a website

using ispcfg 3 on debian squeeze according to the perfect debian server setup with apache2

I edited the website inside ispcfg3 and und unchecked the active check box.
waited a few minutes for the system to write the changes then visited the web site and it is still accessible via browsers...

Am I doing something wrong?

I need to make this site inaccessible to the public till some problems are solved.
Reply With Quote
Sponsored Links
  #2  
Old 18th April 2012, 20:12
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
Default

you may have to clear your browser chache or you can try a hard refresh by hitting ctrl/F5 at the same time
__________________
Operating system Ubuntu Linux 10.04.4
ISPConfig Version: 3.0.4.3
Webmin version 1.580
Kernel and CPU Linux 2.6.32-40-server on x86_64
Processor information AMD Phenom(tm) II X4 945 Processor, 4 cores
Real memory 4.0 GB total
Reply With Quote
  #3  
Old 19th April 2012, 08:45
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,268
Thanks: 84
Thanked 25 Times in 21 Posts
Default

tried that already, different browsers and different computers, the site was still showing up :-(
Reply With Quote
  #4  
Old 19th April 2012, 09:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,596 Times in 4,407 Posts
Default

Disabling the site the way you did it should work. Are there any jobs listed in the jobqueue of the ispconfig monitor?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 19th April 2012, 10:40
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,268
Thanks: 84
Thanked 25 Times in 21 Posts
Default

- nothing in the job queue
- activating the site, saving, waiting 5 minutes, deactivating, saving waiting 5 minutes and the site is still accessible
- the sites are disabled: http://screencast.com/t/L9ROzx8jWG
- but they can still be accessed: http://www.quilombobrasil.com

What else should I check? What is deactivating actually doing? Is it physically moving this vhost from apaches2/sites-enabled/ to apache2/sites-available/ ?
If that is all that happens, I can manually do it...

The reason I want these two websites deactivated is because the owner is MIA and the sites need some updating... its using really old and probably vulnerable stuff :-(

I don't know if this is a problem, but these two vhosts I would like to disable look like this: quilombobrasil.com.vhost
after enabling/disabling and saving a few times, now I have two vhosts: quilombobrasil.com.vhost and 100-quilombobrasil.com.vhost.
Saved again, and now it is again only quilombobrasil.com.vhost - can I manually fi this somehow?

Last edited by Ovidiu; 19th April 2012 at 10:46.
Reply With Quote
  #6  
Old 19th April 2012, 10:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,596 Times in 4,407 Posts
Default

Quote:
What else should I check? What is deactivating actually doing? Is it physically moving this vhost from apaches2/sites-enabled/ to apache2/sites-available/ ?
In sites-enabled are only symlinks, so no file is moved. Deactivating a site removes just the symlink in sites-enabled and when you activate the site, the symlink is created again.

Please delete the symlink in sites-enabled manually and then reload apache to deactivate the site.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 19th April 2012, 10:53
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,268
Thanks: 84
Thanked 25 Times in 21 Posts
 
Default

weird. all vhosts that start with 000- and 100- inside /etc/apache2/sites-enabled/ are symlinks.
All other vhosts are not symlinks.

I deleted quilombobrasil.com.vhost restarted apache, waited, checked again and now everything works as expected: activating and deactivating properly creates/deletes symlinks.

I think I need to do this with all vhosts that are not symlinks...

Thanks for helping me out.
Reply With Quote
Reply

Bookmarks

Tags
deactivate, disable

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig "backend" completely unfunctional after a restart Xaymar Installation/Configuration 1 22nd August 2011 23:31
My Server Is Sending Spam. How Do I Block This? LordJ Server Operation 1 7th July 2011 20:34
Stange mail problem The-Ghost Installation/Configuration 6 25th April 2010 20:59
ISPConfig 3 Send/Receive mail not working. Acidut General 6 4th April 2010 12:24
421 Unexpected failure Lizard King Installation/Configuration 20 7th July 2009 21:43


All times are GMT +2. The time now is 17:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.